[SOLVED] LM13 Cinnamon no longer connects to the Internet...

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby macabu on Wed May 30, 2012 9:14 pm

I think my problem is almost the same.
I boot and then I have internet connection for few seconds, then it disconnects and try forever connect on my network.

Yes, resolv.conf wasn't there, I used:
Code: Select all
sudo dpkg-reconfigure resolvconf


Rebooted, and the resolv.conf has nameserver 127.0.0.1 but nothing has changed.

I'll try two other possible solutions and edit this post with my results.

@edit
This:
Code: Select all
gksudo gedit /etc/NetworkManager/NetworkManager.conf

...etc... didn't work.
Nor this:
Code: Select all
sudo resolvconf -u


@add
I ran that mintWifi script:
Code: Select all
-------------------------
* I. scanning WIFI PCI devices...
  -- Atheros Communications Inc. AR5416 Wireless Network Adapter [AR5008 802.11(a)bgn] (rev 01)
      ==> PCI ID = 168c:0023 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 00:01:6c:7b:2f:69 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:44 Base address:0xe000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3966 (3.9 KB)  TX bytes:3966 (3.9 KB)

wlan0     Link encap:Ethernet  HWaddr b0:48:7a:a6:5e:b3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:11 errors:0 dropped:0 overruns:0 frame:0
          TX packets:38 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1454 (1.4 KB)  TX bytes:7451 (7.4 KB)

-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...
Server:      127.0.0.1
Address:   127.0.0.1#53

** server can't find google.com: REFUSED


Regards.
macabu
Level 1
Level 1
 
Posts: 6
Joined: Thu Oct 14, 2010 6:41 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby Hedaja on Fri Jun 22, 2012 12:43 am

I just found out how to solve my problem.
I changed my Wireless router settings from WPA to WPA2 and everything just worked fine now.
Don't know why but it works
Hedaja
Level 1
Level 1
 
Posts: 15
Joined: Sun Apr 08, 2012 11:48 am

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby oobetimer on Fri Jun 22, 2012 12:14 pm

Hedaja wrote:How can I change the resolv.conf without having it automatically change back?


sudo chattr +i /etc/resolv.conf
User avatar
oobetimer
Level 7
Level 7
 
Posts: 1889
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby mgnapp on Sat Jun 23, 2012 11:06 am



I followed this fix, but no success. Here are the results:

gnapps@gnapps ~ $ sudo gedit/etc/resolv.conf
[sudo] password for gnapps:
sudo: gedit/etc/resolv.conf: command not found
gnapps@gnapps ~ $ sudo gedit /etc/resolv.com

(gedit:2591): GLib-GIO-WARNING **: Missing callback called fullpath = /root/.local/share/recently-used.xbel

What's next? And in case I haven't mentioned, I appreciate everybody's input so far. Just a big learning adventure. When I sleep at night, I dream about this terminal as though I am stuck in the Matrix!
mgnapp
Level 1
Level 1
 
Posts: 8
Joined: Fri Nov 05, 2010 11:01 am

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby bbthomp on Thu Jul 19, 2012 3:06 am

Hey,

I'm having the same problem.

I am using a Dell Adamo 13 with a -- Intel 5300 WLAN 802.11n (3x3) Mini Card

I can connect to my network just fine, but I can't connect to any websites unless I'm on a wired/ethernet connection.

I'm not super tech savvy, so if one of you figures out what's going on I would greatly appreciate the newb-speak version of the solution.

Thanks,
B
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby LMDEFan1 on Mon Jul 23, 2012 9:10 pm

dnsmasq usage is causing network connection definitions to be ignored for DNS Servers and Search Domains. This issue is in all the Mint 13 releases from what I have seen. I suspect it's an upstream issue from Ubuntu.

Here’s a fix:
http://lincgeek.org/blog/?p=1529

The script at this link will create a solution that works between system restarts.

If dnsmasq was intentionally implemented there are tons of irritated network and vpn users. Especially those of us who like this distro at work where we have to configure DNS Servers and Search Domains. It also impacts being able to actually make a connection to an Oracle 11g database with the 11g r2 client (and probably any other database and client combination you are trying to reach on your network). Really frustrating. This is one reason I’m hoping Linux Mint becomes Debian based instead of Debian/Ubuntu. Although I realize there is a ton of work done by Ubuntu to polish Debian just as there is a ton of work done by the Linux Mint team to polish Ubuntu to the point we all prefer it over Ubuntu.
LMDEFan1
Level 1
Level 1
 
Posts: 11
Joined: Tue Mar 06, 2012 2:10 am
Location: Utah USA

Re: [SOLVED] LM13 Cinnamon no longer connects to the Interne

Postby gonnaditchmintsoon on Sat Dec 29, 2012 3:45 pm

This could also be because your laptop is currently not plugged in with power supply and so the power management on mint screws up your wireless connection by disabling somethings.
The following thread viewtopic.php?f=53&t=111658 pointed me to http://uselessuseofcat.com/?p=67 which solved the problem for me.
gonnaditchmintsoon
Level 1
Level 1
 
Posts: 8
Joined: Sat Dec 29, 2012 1:55 pm

Re: [SOLVED] LM13 Cinnamon no longer connects to the Interne

Postby Tom Japan on Sun Feb 24, 2013 7:11 am

I had a similar problem. For some reason I can not guess, I lost my internet connectivity. Rebooting computer, router, etc, nothing worked for 2 days. Found this thread, tried some things, and the one that worked is "dpkg-reconfigure resolveconf"

I choose 'yes' for a few of the options that would allow dynamic updating of the config files.

The only thing I can say is that this is a complete mystery why this would happen. I've been running this version of Mint for almost 8months with no problems. Frustrating. I'm no noobie, been using linux for years. I haven't had this kind of network trouble since the 'win modem' days.

Thanks for the thread and the help.

Love the forums.
Tom Japan
Level 1
Level 1
 
Posts: 1
Joined: Sat Jan 14, 2012 1:03 pm

Linux Mint is funded by ads and donations.
 
Previous

Return to Wireless

Who is online

Users browsing this forum: No registered users and 6 guests