Cannot load webpages via wireless connection

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Cannot load webpages via wireless connection

Postby bbthomp on Thu Jul 19, 2012 9:22 pm

Hey y'all,

I am having an issue connecting to webpages, when I am not plugged into a wired connection. I can connect to the internet through the ethernet just fine. I can also, regardless of wether I am plugged in, connect to my wireless network. When I am only connecting wirelessly, It tells me (in Firefox) that it cannot connect to the server.

I used Linux Mint 12 before this, and it worked fine (I don't recall having to do anything to get the wireless to work). I am a super newb, so suggestions and requests that are as step-by-step as possible are greatly appreciated.

Here are my specs:

-- Linux Mint 13 Cinnamon Edition 64 bit
-- Adamo 13 Laptop: Intel Core 2 Duo SU9300 (3MB cache/1.2GHz/800Mhz FSB)
-- 13.4 inch 720p (HD) WLED Display
-- 2 GB Dual Channel DDR3 SDRAM at 800MHz
-- 128 GB Mobility Solid State Drive
-- Dell Wireless 370 Bluetooth Module
-- Intel 5300 WLAN 802.11n (3x3) Mini Card

This is what I get, when I run "sudo /usr/lib/linuxmint/mintWifi/mintWifi.py" and am only connected via wifi (I did this because I saw it requested by "Clem" of folks in the networking section)::

blake@blake-Adamo-13 ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
-------------------------
* I. scanning WIFI PCI devices...
-- Intel Corporation Ultimate N WiFi Link 5300
==> PCI ID = 8086:4235
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:"Royer WIFI"
Mode:Managed Frequency:2.437 GHz Access Point: 00:23:69:ED:3C:A0
Bit Rate=11 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=34/70 Signal level=-76 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:51 Missed beacon:0

eth0 no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 00:26:b9:01:85:37
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:16922 errors:0 dropped:0 overruns:0 frame:0
TX packets:14972 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:15743633 (15.7 MB) TX bytes:2240794 (2.2 MB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2642 errors:0 dropped:0 overruns:0 frame:0
TX packets:2642 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:427223 (427.2 KB) TX bytes:427223 (427.2 KB)

wlan0 Link encap:Ethernet HWaddr 00:21:6a:7c:39:28
inet addr:192.168.1.117 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::221:6aff:fe7c:3928/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6376 errors:0 dropped:0 overruns:0 frame:0
TX packets:452 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:985776 (985.7 KB) TX bytes:75436 (75.4 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: google.com
Address: 74.125.224.78
Name: google.com
Address: 74.125.224.73
Name: google.com
Address: 74.125.224.72
Name: google.com
Address: 74.125.224.71
Name: google.com
Address: 74.125.224.70
Name: google.com
Address: 74.125.224.69
Name: google.com
Address: 74.125.224.68
Name: google.com
Address: 74.125.224.67
Name: google.com
Address: 74.125.224.66
Name: google.com
Address: 74.125.224.65
Name: google.com
Address: 74.125.224.64
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Linux Mint is funded by ads and donations.
 

Re: Cannot load webpages via wireless connection

Postby dwasifar on Thu Jul 19, 2012 11:02 pm

The last sections of your results show that you do have a working wireless connection, which appears to be successfully connecting at least as far as the router, and appears to be resolving DNS. I do see that your connection is defaulting to use your local gateway for DNS, though.

For diagnostic purposes, try the following:

- In Terminal, type host lizkalish.com and see if it returns the IP address 23.25.11.180. Then try host lizkalish.com 8.8.8.8 and see if that returns the same thing. (This is a low-traffic domain I have control over.)

- In Firefox, put 23.25.11.180 in the URL bar and see if it takes you to a website.

- If you get the website using the IP, but not by using the URL; or if the two host commands in the first step return different results, then it might be a DNS issue. Let us know what the results are and we'll take it from there.
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: Cannot load webpages via wireless connection

Postby bbthomp on Thu Jul 19, 2012 11:32 pm

First, with ethernet plugged in:
blake@blake-Adamo-13 ~ $ host lizkalish.com
lizkalish.com has address 23.25.11.180
lizkalish.com mail is handled by 0 hughescp.com.

Second, with ethernet unplugged and wifi connected (about 35% - 45% strength connection)
blake@blake-Adamo-13 ~ $ host lizkalish.com


;; connection timed out; no servers could be reached
blake@blake-Adamo-13 ~ $
blake@blake-Adamo-13 ~ $

Third, with ethernet replugged in:
blake@blake-Adamo-13 ~ $ host lizkalish.com 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
Aliases:

lizkalish.com has address 23.25.11.180
lizkalish.com mail is handled by 0 hughescp.com.

Fourth, ethernet unplugged and connected to wireless network:
blake@blake-Adamo-13 ~ $ host lizkalish.com 8.8.8.8
;; connection timed out; no servers could be reached
blake@blake-Adamo-13 ~ $

Fifth, ethernet takes me to the site with just the numerical address

Sixth, no ethernet (connected to wifi) did take me to the site with just the numerical address

Seventh, to make sure this was not just a fluke due to cookies/browser data - I deleted all cookies and history and then repeated - this time wifi did not take me to the site using the numerical address
I get the message: "Firefox can't establish a connection to the server at 23.25.11.180."
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby dwasifar on Sat Jul 21, 2012 8:07 am

Hm. Okay, so it doesn't look like a DNS problem then.

I'm not sure what to tell you. You're connected, but your connection isn't letting you do anything. If you go your Network Connections and edit the current wireless connection, what options are selected in the IPv4 tab?
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: Cannot load webpages via wireless connection

Postby bbthomp on Mon Jul 23, 2012 1:58 am

"

Connect automatically [checked]

Method: [Automatic (DHCP)]

Addresses: [This section is all grayed out/not filled out]

DHCP client ID: [left blank]

Require IPv4 addressing for this connection to complete: [box not checked]

available to all users: [box checked]

when I click on the "Routes..." button: [nothing is included in the 'address/netmask/gateway/metric' box - and - neither of the boxes (the 'ignore automatically obtained routes' and the 'use this connection only for resources on its network' boxes) are checked
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby dwasifar on Mon Jul 23, 2012 10:43 pm

I can't think of anything else to try. Those settings are right. It should be working.

At this point I'd start looking at the router. Can other machines connect and use your wireless?
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: Cannot load webpages via wireless connection

Postby bbthomp on Tue Jul 24, 2012 12:00 am

Yeah, all of the other machines in the house (acer laptop (running ubuntu), mac desktop, ipad 1, ipad 2, android and iphones, and roku boxes) connect just fine, so did my machine until I installed Mint 13 (the same issue occurs when I run the new ubuntu release).

Should I just give up on using Linux Mint and look at other distros?
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby bbthomp on Tue Jul 24, 2012 12:29 am

"LMDEFan1" Posted this in another forum:

"Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby LMDEFan1 on Mon Jul 23, 2012 7:10 pm
dnsmasq usage is causing network connection definitions to be ignored for DNS Servers and Search Domains. This issue is in all the Mint 13 releases from what I have seen. I suspect it's an upstream issue from Ubuntu.

Here’s a fix:
http://lincgeek.org/blog/?p=1529

The script at this link will create a solution that works between system restarts.

If dnsmasq was intentionally implemented there are tons of irritated network and vpn users. Especially those of us who like this distro at work where we have to configure DNS Servers and Search Domains. It also impacts being able to actually make a connection to an Oracle 11g database with the 11g r2 client (and probably any other database and client combination you are trying to reach on your network). Really frustrating. This is one reason I’m hoping Linux Mint becomes Debian based instead of Debian/Ubuntu. Although I realize there is a ton of work done by Ubuntu to polish Debian just as there is a ton of work done by the Linux Mint team to polish Ubuntu to the point we all prefer it over Ubuntu."

The link in the post brings you to this post by "linc"

"
Mint 13 Fix for Broken DNS.
By linc Linux Mint Add comments

I really love Mint, just let me get that out of that way first. That being said, there are usually a couple things I catch, per release, that filter down from Ubuntu, that I wish were taken care of before Mint hits my desktop.

This time it is DNS.

I installed Mint 13 and was cruising around my home network and noticed that my dns searches weren’t appending my local domain. I had to use the FQDN to get to *anything* on my home network. Well, this frustrated me a bit because I worked hard to set up my own home network, I have resources on it including DNS, and I would like to actually use it. So, I went on the hunt for WHY I had to use a fully qualified domain name on my network…

For some strange reason, someone, somewhere thought it would be a great idea to mess with the way we handle DNS. In fact, the way Linux/Unix/unix has traditionally handled DNS for ever. That being if you put stuff ™ in the friggin /etc/resolv.conf file, your DNS just magically works. Well, not any more.

I have done 3 Mint 13 / Cinnamon installs now (assuming that Mate is the same here) and, in fact, THERE IS NO RESOLV.CONF file! What has happened is this, as far as I can tell. Someone in the Ubuntu camp (I assume) decided that it would be a great idea to start using dnsmasq through the NetworkManager to take care of DNS because they wanted to skirt some VPN issues with single homing. In layman’s terms, when you use a VPN, you are *ONLY* supposed to be able to connect to that network to be secure. Using dnsmasq, you could conceivably be on your VPN and route local traffic around too (multi homing). IPSEC guys frost themselves over stuff like this, BTW.

So, I set about to correct this injustice. Here is a simple script you can run which will turn off the dnsmasq garbage, put your resolv.conf files back in place where they belong and start those services back up so stuff works like we have been doing it for 20+ years.

#!/bin/bash

clear

# Test for UID=0
if [ "$(echo $UID)" != "0" ]
then
echo “You must be superuser to run this program. Try ‘sudo ./fixmint13.sh’”
exit
fi

sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf

ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
resolvconf --create-runtime-directories
resolvconf --enable-updates

reboot

"

Can anyone here tell if this script looks right?
When I get to "fi" it closes terminal on me... and I'm not sure what I'm supposed to expect anyway (after most of the input it just takes me to the next line)


after I put in the line that starts with "sed..." I get:

blake@blake-Adamo-13 ~ $ sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf
sed: couldn't open temporary file /etc/NetworkManager/sedPScuXM: Permission denied
blake@blake-Adamo-13 ~ $

So, I used "sudo" to gain permission:

blake@blake-Adamo-13 ~ $ sudo sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf
blake@blake-Adamo-13 ~ $ ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
ln: failed to create symbolic link `/etc/resolv.conf': File exists
blake@blake-Adamo-13 ~ $ resolvconf --create-runtime-directories
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
blake@blake-Adamo-13 ~ $ resolvconf --enable-updates
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
blake@blake-Adamo-13 ~ $

My intuition tells me this isn't what I'm supposed to be getting

After reboot, nothing has changed (as far as I can tell)
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby bbthomp on Tue Jul 24, 2012 5:24 am

Not sure if this is related, but tonight our Xbox had a 'failure to resolve dns' issue (could connect to router but not the internet).

We reset the network settings in the xbox setting menu and, after restarting the machine, it worked again.

The laptop's wireless still doesn't work.
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby bbthomp on Sat Jul 28, 2012 8:37 pm

Forum,

Because I need wireless internet, I have installed Ubuntu 11.10. I'm not experiencing any problems.

I experienced the problem mentioned above when I booted either LM 13, LMDE, or Ubuntu 12.04 LTS . The problem occured both when installed and when run from flashkeys. The debian looks like it's the common factor here, and might explain why I have no problems with the release I'm using now.

If someone is interested in helping me trouble shoot the problem, I am happy to do so through flash boot or even to install a dual partition (if necessary).

Best,
Blake
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby dwasifar on Sun Jul 29, 2012 12:54 am

All Ubuntu is based on Debian, including the release you're successfully using now. So I don't think Debian itself is the issue. Rather, the version list you posted makes me think there's a driver or kernel support issue that is causing a problem with your particular hardware. Ubuntu 11.10 is the oldest of the four distros you listed. I'm thinking whatever it is probably changed upstream in Debian between the release of Ubuntu 11.10 and 12.04, and it is now in the current rolling-release LMDE, Ubuntu 12.04, and Mint 13 (which is based on Ubuntu 12.04).

If you can use Ubuntu 11.10, you can probably also use Mint 11 or 12. Which one you go with is up to you. I'd take Mint 11.

As an experiment, you might try uninstalling network-manager in Mint 13 and configuring your network connection manually. If you want to do that I'll do my best to point you in the right direction. But it's a shot in the dark.
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: Cannot load webpages via wireless connection

Postby bbthomp on Tue Jul 31, 2012 4:16 am

I'm perfectly happy using Ubuntu 11.1
It works great.

My only concern is the length of support. Is there any reason to be worried about that April 2013 support deadline? What are the possible consequences of using a distro that has 'expired'?
User avatar
bbthomp
Level 1
Level 1
 
Posts: 9
Joined: Thu Jul 19, 2012 3:02 am

Re: Cannot load webpages via wireless connection

Postby xox101 on Wed Aug 01, 2012 11:42 pm

This is perhaps the same old Intel wireless card story again. Ubuntu/Mint have had problems getting Intel cards to work since 11.04 and it still isn't fixed. Easier to ignore I assume!

Try the fixes on this site

http://www.unixmen.com/resolve-slow-con ... y-narwhal/

They didn't work for me personally. If they don't work for you then either replace the wireless card with another model or replace Network Manager with WICD. I changed to WICD first but as WICD does not support USB tethering I ended up changing the card to an Atheros one.

viewtopic.php?f=53&t=101961
xox101
Level 2
Level 2
 
Posts: 61
Joined: Sat Jan 29, 2011 7:34 pm

Re: Cannot load webpages via wireless connection

Postby LMDEFan1 on Thu Aug 16, 2012 11:30 pm

bbthomp wrote:"LMDEFan1" Posted this in another forum:

"Re: Linux Mint 13 Cinnamon no longer connects to the Interne

Postby LMDEFan1 on Mon Jul 23, 2012 7:10 pm
dnsmasq usage is causing network connection definitions to be ignored for DNS Servers and Search Domains. This issue is in all the Mint 13 releases from what I have seen. I suspect it's an upstream issue from Ubuntu.

Here’s a fix:
http://lincgeek.org/blog/?p=1529

The script at this link will create a solution that works between system restarts.

If dnsmasq was intentionally implemented there are tons of irritated network and vpn users. Especially those of us who like this distro at work where we have to configure DNS Servers and Search Domains. It also impacts being able to actually make a connection to an Oracle 11g database with the 11g r2 client (and probably any other database and client combination you are trying to reach on your network). Really frustrating. This is one reason I’m hoping Linux Mint becomes Debian based instead of Debian/Ubuntu. Although I realize there is a ton of work done by Ubuntu to polish Debian just as there is a ton of work done by the Linux Mint team to polish Ubuntu to the point we all prefer it over Ubuntu."

The link in the post brings you to this post by "linc"

"
Mint 13 Fix for Broken DNS.
By linc Linux Mint Add comments

I really love Mint, just let me get that out of that way first. That being said, there are usually a couple things I catch, per release, that filter down from Ubuntu, that I wish were taken care of before Mint hits my desktop.

This time it is DNS.

I installed Mint 13 and was cruising around my home network and noticed that my dns searches weren’t appending my local domain. I had to use the FQDN to get to *anything* on my home network. Well, this frustrated me a bit because I worked hard to set up my own home network, I have resources on it including DNS, and I would like to actually use it. So, I went on the hunt for WHY I had to use a fully qualified domain name on my network…

For some strange reason, someone, somewhere thought it would be a great idea to mess with the way we handle DNS. In fact, the way Linux/Unix/unix has traditionally handled DNS for ever. That being if you put stuff ™ in the friggin /etc/resolv.conf file, your DNS just magically works. Well, not any more.

I have done 3 Mint 13 / Cinnamon installs now (assuming that Mate is the same here) and, in fact, THERE IS NO RESOLV.CONF file! What has happened is this, as far as I can tell. Someone in the Ubuntu camp (I assume) decided that it would be a great idea to start using dnsmasq through the NetworkManager to take care of DNS because they wanted to skirt some VPN issues with single homing. In layman’s terms, when you use a VPN, you are *ONLY* supposed to be able to connect to that network to be secure. Using dnsmasq, you could conceivably be on your VPN and route local traffic around too (multi homing). IPSEC guys frost themselves over stuff like this, BTW.

So, I set about to correct this injustice. Here is a simple script you can run which will turn off the dnsmasq garbage, put your resolv.conf files back in place where they belong and start those services back up so stuff works like we have been doing it for 20+ years.

#!/bin/bash

clear

# Test for UID=0
if [ "$(echo $UID)" != "0" ]
then
echo “You must be superuser to run this program. Try ‘sudo ./fixmint13.sh’”
exit
fi

sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf

ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
resolvconf --create-runtime-directories
resolvconf --enable-updates

reboot

"

Can anyone here tell if this script looks right?
When I get to "fi" it closes terminal on me... and I'm not sure what I'm supposed to expect anyway (after most of the input it just takes me to the next line)


after I put in the line that starts with "sed..." I get:

blake@blake-Adamo-13 ~ $ sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf
sed: couldn't open temporary file /etc/NetworkManager/sedPScuXM: Permission denied
blake@blake-Adamo-13 ~ $

So, I used "sudo" to gain permission:

blake@blake-Adamo-13 ~ $ sudo sed -i -e 's/dns=dnsmasq/#dns=dnsmasq/g' /etc/NetworkManager/NetworkManager.conf
blake@blake-Adamo-13 ~ $ ln -s /run/resolvconf/resolv.conf /etc/resolv.conf
ln: failed to create symbolic link `/etc/resolv.conf': File exists
blake@blake-Adamo-13 ~ $ resolvconf --create-runtime-directories
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
blake@blake-Adamo-13 ~ $ resolvconf --enable-updates
resolvconf: Error: /etc/resolv.conf isn't a symlink, not doing anything.
blake@blake-Adamo-13 ~ $

My intuition tells me this isn't what I'm supposed to be getting

After reboot, nothing has changed (as far as I can tell)



bbthomp,
1) Copy that script into a text file and save it, with name of fixmint13.sh, to your home folder. You want to start copying with line: #!/bin/bash and then end with line: reboot

2) Open a console window / terminal. It should open in your home folder. If you type ls and hit enter you should see the fixmint13.sh file in the list of files displayed.

3) Now, in your terminal window, type: sudo ./fixmint13.sh

It will ask your for your password. Once you enter your password it will run the script and reboot your computer so make sure you've saved and closed any other applications you may have open before you run this script.

Once your computer reboots, and you've logged in, you should be able to access the internet.

If you want to see what the changes are to your system open the following files in your text editor:
/etc/NetworkManager/NetworkManager.conf Notice that the following line has been commented out: dns=dnsmasq It's now #dns=dnsmasq

/etc/resolv.conf This file contains the definition for your name servers (DNS servers) as well as any domain and search domains that you have defined in your network connection.

Hope this helps. :D
LMDEFan1
Level 1
Level 1
 
Posts: 11
Joined: Tue Mar 06, 2012 2:10 am
Location: Utah USA

Re: Cannot load webpages via wireless connection

Postby mcragun on Wed Sep 12, 2012 7:49 am

LMDEFan1 was a big help. Thanks.

I was able to connect to my VPN server at work using openVPN. However, once I was connected, the internet stopped working and it couldn't resolve any page names on the internets. Running your script fixed everything so I am now VPNing and surfing simultaneously. Thanks again.
mcragun
Level 1
Level 1
 
Posts: 1
Joined: Wed Sep 12, 2012 7:45 am

Re: Cannot load webpages via wireless connection

Postby lonoy on Sat Dec 22, 2012 4:33 am

1) Copy that script into a text file and save it, with name of fixmint13.sh, to your home folder. You want to start copying with line: #!/bin/bash and then end with line: reboot

2) Open a console window / terminal. It should open in your home folder. If you type ls and hit enter you should see the fixmint13.sh file in the list of files displayed.

3) Now, in your terminal window, type: sudo ./fixmint13.sh

It will ask your for your password. Once you enter your password it will run the script and reboot your computer so make sure you've saved and closed any other applications you may have open before you run this script.

Once your computer reboots, and you've logged in, you should be able to access the internet.

If you want to see what the changes are to your system open the following files in your text editor:
/etc/NetworkManager/NetworkManager.conf Notice that the following line has been commented out: dns=dnsmasq It's now #dns=dnsmasq

/etc/resolv.conf This file contains the definition for your name servers (DNS servers) as well as any domain and search domains that you have defined in your network connection.

Hope this helps.


Does this work for Mint 14?

I enter all the above but after "sudo ./fixmint13.sh" it says command not found?

Thanks
lonoy
Level 1
Level 1
 
Posts: 28
Joined: Wed Jan 30, 2008 8:28 pm

Re: Cannot load webpages via wireless connection

Postby dwasifar on Sat Dec 22, 2012 1:07 pm

lonoy wrote:
1) Copy that script into a text file and save it, with name of fixmint13.sh, to your home folder. You want to start copying with line: #!/bin/bash and then end with line: reboot

2) Open a console window / terminal. It should open in your home folder. If you type ls and hit enter you should see the fixmint13.sh file in the list of files displayed.

3) Now, in your terminal window, type: sudo ./fixmint13.sh

It will ask your for your password. Once you enter your password it will run the script and reboot your computer so make sure you've saved and closed any other applications you may have open before you run this script.

Once your computer reboots, and you've logged in, you should be able to access the internet.

If you want to see what the changes are to your system open the following files in your text editor:
/etc/NetworkManager/NetworkManager.conf Notice that the following line has been commented out: dns=dnsmasq It's now #dns=dnsmasq

/etc/resolv.conf This file contains the definition for your name servers (DNS servers) as well as any domain and search domains that you have defined in your network connection.

Hope this helps.


Does this work for Mint 14?

I enter all the above but after "sudo ./fixmint13.sh" it says command not found?

Thanks


There is a step missing. Before you can run that script file you need to set it executable. In between step 2 and 3, type chmod +x fixmint13.sh and then continue to step 3.

And yes, it does work on Mint 14.
User avatar
dwasifar
Level 4
Level 4
 
Posts: 344
Joined: Mon May 09, 2011 10:03 pm

Re: Cannot load webpages via wireless connection

Postby lonoy on Sun Dec 23, 2012 2:59 pm

Your advice worked great. Now have DYNDNS back.

Thanks.
lonoy
Level 1
Level 1
 
Posts: 28
Joined: Wed Jan 30, 2008 8:28 pm

Re: Cannot load webpages via wireless connection

Postby uilenspiegel on Wed Dec 26, 2012 9:20 pm

Brilliant fix (god I love the Mint forums). Just to add my details, perhaps to make it easier for others to find what they're searching for:

I recently upgraded from Mint 10 to Mint 13 (Maya). With the older Mint release, I was successfully able to connect to internet and browse webpages over wireless at home, at work, and at the library, no problem. With Mint 13, on the other hand, I was able to connect and browse at home, but not at work or at the library.

At work, the SSID is not broadcast, and my first thought was that the hidden SSID had something to do with the problem, but I didn't have a chance to look into it; then I was at the library a couple of days later and saw that I was getting a proper internet connection, it was just that I was unable to load webpages ...

So when I got home, I searched for a few minutes on the forum, and voila', I found this thread. After running the fixmint13.sh script, I could still connect and browse the web just fine at home, and sure enough, when I tested it out at work this morning everything was working fine there too.

This could definitely have been a painful bug, but bugs are going to happen ... to me the real takeaway is that five minutes of browsing the forum got me a perfect solution, and that I get to keep using a fantastic release that in every other respect has been flawless for me. Thanks all.
uilenspiegel
Level 1
Level 1
 
Posts: 26
Joined: Tue Aug 04, 2009 8:23 pm

Re: Cannot load webpages via wireless connection

Postby Masema on Sun Mar 31, 2013 10:43 pm

xox101 wrote:If they don't work for you then either replace the wireless card with another model or replace Network Manager with WICD. I changed to WICD first but as WICD does not support USB tethering I ended up changing the card to an Atheros one.

viewtopic.php?f=53&t=101961


I just installed Mint (Nadia 32bit with MATE) on my MacBook Pro (5,5, Mid-2009 13").

I had the exact same issue listed here, I could connect beautifully with Wired, and Wireless left me able to Ping but not able to connect to websites with any sort of speed.

I tried the "fix" script above, but it didn't do anything for me. But when I replaced Network Manager with WICD it worked!

Thanks.
Masema
Level 1
Level 1
 
Posts: 1
Joined: Sun Mar 31, 2013 10:35 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 2 guests