Sound not working in Mint 13 XFCE

Forum rules
Before you post please read this

Sound not working in Mint 13 XFCE

Postby bolter40k on Thu Aug 02, 2012 8:40 pm

Hello everyone,

Try to bare with me. I just installed Linux Mint 13 XFCE after being away from the linux scene for about a year. I am having issues with my sound. As I log into my session sound will play acknowledging a successful log in. Once in my session however sound no longer functions. No matter what I select as a playback device I do not have sound.

If anyone could be of any help id be extremely greatful.

Thanks,
Bolter40k
bolter40k
Level 1
Level 1
 
Posts: 10
Joined: Fri Aug 27, 2010 12:18 pm

Linux Mint is funded by ads and donations.
 

Re: Sound not working in Mint 13 XFCE

Postby jjaythomas on Fri Aug 03, 2012 3:14 pm

If getting sound 'feedback' for a sucesfull login usually means alsa itself is working Before pulse-audio is started.

I think LMint-XFCE activates Pulse-Audio in start-up.
See if uncheching pulse-audio in startup (maybe in session also) rectifies no sound. If so you can uninstall 'pulse-audio' or try to figure out problem in 'puls-audio.

P.S. could also end 'pulse-audio' from terminal or 'system>Task Manager' to test

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Sound not working in Mint 13 XFCE

Postby tadpole1954 on Tue Aug 07, 2012 11:27 pm

That happened to me too. No sound. To get it working I did this. Menu/Settings/Settings Manager/Session and Startup/Application Autostart/ then select PulseAudio Sound Systen (start the PulseAudio Sound System).
tadpole1954
Level 2
Level 2
 
Posts: 53
Joined: Thu Sep 11, 2008 8:20 pm

Re: Sound not working in Mint 13 XFCE

Postby MasterGT on Fri Aug 10, 2012 12:58 pm

I have a fresh Xfce install and I don't have sound either, but when I follow your path, there is nothing in the settings manager regarding PulseAudio, so I can't turn it on or off there.

$ inxi -SAxc 0
System: Host lmde-xfce-2012-4 Kernel 3.2.0-2-686-pae i686 (32 bit) Distro Linux Mint Xfce Edition
Audio: Card-1 ATI Redwood HDMI Audio [Radeon HD 5600 Series] driver snd_hda_intel BusID: 01:00.1
Card-2 Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
MasterGT
Level 1
Level 1
 
Posts: 2
Joined: Thu Aug 09, 2012 12:23 am

Re: Sound not working in Mint 13 XFCE

Postby MasterGT on Fri Aug 17, 2012 12:40 pm

Anyone with ideas to help me with this sound problem?

I don't know Xfce well enough to know how to resolve it and there doesn't seem to be a general issue with no sound for it to be discussed here.
MasterGT
Level 1
Level 1
 
Posts: 2
Joined: Thu Aug 09, 2012 12:23 am

Re: Sound not working in Mint 13 XFCE

Postby lifeguard on Tue Sep 18, 2012 2:50 pm

I am sad. Mint has been stable for me in the past. But sound failing? No reply on forums? Sad.

(This happened to me today. Sound worked fine.)

I am installing another distro today, but in case my system details are useful to you guys:

Kernel 3.2.0-2-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
Audio: Card Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
lifeguard
Level 1
Level 1
 
Posts: 1
Joined: Tue Sep 18, 2012 2:45 pm

Re: Sound not working in Mint 13 XFCE

Postby XMice on Tue Sep 18, 2012 7:24 pm

Hey I also had no sound..
Problem was that the main output was wrong..
Go into the pulse audio settings -> configuration and disable all not used outputs like graphic card output. :)
XMice
Level 1
Level 1
 
Posts: 9
Joined: Fri Sep 14, 2012 11:56 pm

Re: Sound not working in Mint 13 XFCE

Postby traction88 on Wed Oct 03, 2012 2:23 pm

Same issue for me. Sound works on the login screen and then stops after logging in. I went into Pulse Audio Volume Control->Configuration tab and disabled the High Definition Audio Controller.
traction88
Level 1
Level 1
 
Posts: 1
Joined: Wed Oct 03, 2012 2:20 pm

Re: Sound not working in Mint 13 XFCE

Postby RayT on Wed Nov 07, 2012 4:03 am

Hi,

I had the same problem no sound after login. after scratching my head a lot i looked at the mixer in the start bar. none of the controls were setup? so i pressed "Select Controls" and got a sound slider to appear in the "ALSA Mixer" part.
No good so i selected the "OSS Mixer" and done the same,,, no good so i done the same with the "pulseaudio mixer" and lo and behold a master slider... and it had defaulted to 0% sound.. turned it up and i had sound...

Seems a bit strange to me to have 3 sets of volume controls for the sound card, and to default them as hidden. and to default the master to 0%.. but hey got there in the end..
RayT
Level 1
Level 1
 
Posts: 13
Joined: Wed Nov 07, 2012 12:52 am

Re: Sound not working in Mint 13 XFCE

Postby Flemur on Wed Nov 07, 2012 7:51 am

Try these:

$ alsamixer (make sure nothing's muted).
$ pavucontrol (same as above - you might have to install pavucontrol)

I had this, called "no_mdm_sound_fix" - (sound disappeared when MDM was removed):
$ rm -r ~/.pulse && killall pulseaudio

If those don't work, try "paprefs" and look for odd settings.

If none of those work, maybe purge the alsa and pulse packages, and reinstall....

Edit: On other Xfce installs I've had the volume-icon mute the sound, then the unmute shows it working (sound back on) but it's not - you have to unmute a channel thru pavucontrol. Linux sound is a mess.
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 804
Joined: Mon Aug 20, 2012 9:41 pm

Re: Sound not working in Mint 13 XFCE

Postby RayT on Fri Nov 09, 2012 3:38 pm

Hi all,

I have noticed something a little strange..

Every-time i boot my machine the sound is muted.
I would un-mute the sound and set it at 70%.
then when i re-boot the sound is muted again?

i have only noticed this recently while trying to watch a DVD.
and i have tested this twice to make sure its happening.

strange but true :)
RayT
Level 1
Level 1
 
Posts: 13
Joined: Wed Nov 07, 2012 12:52 am

Re: Sound not working in Mint 13 XFCE

Postby jjaythomas on Fri Nov 09, 2012 10:20 pm


Every-time i boot my machine the sound is muted.
I would un-mute the sound and set it at 70%.
then when i re-boot the sound is muted again?

try resaving session (seting session and startup) on seesion tab when have sound set where want.
The session tab on Xfce don't show everthing ran from session (the file acually a '.' dot file or exg config in /ect (I think) :roll:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Sound not working in Mint 13 XFCE

Postby RayT on Sat Nov 10, 2012 9:41 am

jjaythomas wrote:
Every-time i boot my machine the sound is muted.
I would un-mute the sound and set it at 70%.
then when i re-boot the sound is muted again?

try resaving session (seting session and startup) on seesion tab when have sound set where want.
The session tab on Xfce don't show everthing ran from session (the file acually a '.' dot file or exg config in /ect (I think) :roll:

J.Jay


Thanks J.Jay

That would make sense!
So i have quickly tried setting the sound and saving the session. re-started and unfortunately its the same master Volume 0% and muted. i agree with you that there is a good chance this is the issue so i will continue to play and see what i can do.

Anyways thanks for the suggestion.
RayT
Level 1
Level 1
 
Posts: 13
Joined: Wed Nov 07, 2012 12:52 am

Re: Sound not working in Mint 13 XFCE

Postby jjaythomas on Sun Nov 11, 2012 11:19 pm

Worth a shot (didn't work tho :cry: )

if remember pulse-audio starts as a service (system>services) and also is an auto-start app (settings>autstart and session) maybe ones over-riding other. :idea:

Try turning off in services and reboot. If not try turning on service and disble at autostart.

Maybe :mrgreen:
J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Sound not working in Mint 13 XFCE

Postby yerc on Fri Nov 16, 2012 6:32 pm

RayT wrote:
jjaythomas wrote:
Every-time i boot my machine the sound is muted.
I would un-mute the sound and set it at 70%.
then when i re-boot the sound is muted again?

try resaving session (seting session and startup) on seesion tab when have sound set where want.
The session tab on Xfce don't show everthing ran from session (the file acually a '.' dot file or exg config in /ect (I think) :roll:
J.Jay

That would make sense!
So i have quickly tried setting the sound and saving the session. re-started and unfortunately its the same master Volume 0% and muted. i agree with you that there is a good chance this is the issue so i will continue to play and see what i can do.

I'll risk appearing stupid here and ask are you running mint xfce from a livecd/usb?
If so, then you are starting "fresh" each time (but then again i don't see why you are able to save a session if it's a livecd/usb) :?
yerc
Level 1
Level 1
 
Posts: 22
Joined: Wed Mar 30, 2011 2:44 pm

Re: Sound not working in Mint 13 XFCE

Postby RayT on Sat Nov 17, 2012 12:17 pm

yerc wrote:I'll risk appearing stupid here and ask are you running mint xfce from a livecd/usb?
If so, then you are starting "fresh" each time (but then again i don't see why you are able to save a session if it's a livecd/usb) :?


Not a stupid question!
but unfortunately it is a full install !!

jjaythomas wrote:Worth a shot (didn't work tho :cry: )
if remember pulse-audio starts as a service (system>services) and also is an auto-start app (settings>autstart and session) maybe ones over-riding other. :idea:
Try turning off in services and reboot. If not try turning on service and disble at autostart.
Maybe :mrgreen:
J.Jay


Cheers i will give that a go, i will also explain a little on what exactly is happening.

If you right click on the mixer, and go into properties i can see the sound card "output" options, i have:
Intel 82801DB-ICH4 (Alsa Mixer)
SigmaTel STA9750,51 (OSS Mixer)
Playback: Built-in Audio Analog Stereo (PulseAudio Mixer)

what i have noticed so far:
1) Every time i restart the Alsa and the OSS Mixer are on 0%. not the Pulse Mixer
2) The Alsa Mixer is also muted on restart.
3) The sliders on these two seem linked together with regards to the volume level.

i have tried to save session, with no success.
i will look at what services are running next. but all i have done is install? i have not messed with the sound system at all..

I am currently just un-muting and resetting the volume each time i restart my pc and then works fine,
just finding it's a little odd thats all :?

One last one... Why are there 3 volume controls/Mixers, or is the MS equivalent to Master, Wave, CD ect ect?

Thanks for your comments and suggestions!
i find its good that i'm learning a little more about the system each time :D
RayT
Level 1
Level 1
 
Posts: 13
Joined: Wed Nov 07, 2012 12:52 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests