Linux Mint not playing well with my new computer

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Linux Mint not playing well with my new computer

Postby swiftninja on Mon Jul 30, 2012 9:37 am

I've put together a a new computer:
Motherboard: Gigabyte SKT-1155 Z77-DS3H
CPU: Core i5-3450 Processor (Ivy Bridge)
Ram:8GB (2x4GB) Corsair XMS DDR3 PC3-10
GPU: 1GB Asus GTX 550 Ti, 4104MHz GDDR5,
HDD: 1TB Seagate ST1000DM003 Barracuda 7
An old Samsung HDD (that I installed Ubuntu on before (250GB)
1x DVD rewriter
1x DVD drive
I'm trying to install Cinnamon
Now you know what I'm working with here's the problem.

When I try to install linux mint or run it from the disk it hangs just showing a flash underscore (like in terminal to show you what line you're on)

The story so far:
I first had this happen when I finished putting the PC together, I also encountered the same problem when I tried using an Ubuntu disk but it came up with an error regarding my BIOS seeing the HDDs as IDE rather than ACHI, after I changed that and Ubuntu worked (I could boot it up from the disk) but Linux Mint had the same problem (which leads me to believe it doesn't even get that far). I gave in to defeat and installed windows 7 instead, I tried installing again through windows the first part installs ok but when I restart it says finishing installation and displays the countdown but when it reachers 0 it doesn't do anything.

Since I did a bit of a rush job with the disk I figured it might have been a corrupted ISO (I didn't test the md5). I downloaded another copy did the md5 check then burnt the ISO at the lowest speed in Nero. Installed it again through windows and encountered the same problem. I thought I would be patient and give it time but it hung on the same screen for an hour and I think it's still showing the 'finishing installation' text.

How can I fix this? It's quite frustrating since there is no error message either to tell me what might be going wrong.


Edit: Just tried it on my 2009 mac book pro and it booted from the disk just fine.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Linux Mint is funded by ads and donations.
 

Re: Linux Mint not playing well with my new computer

Postby kherring7383 on Mon Jul 30, 2012 10:37 am

swiftninja, sorry to hear you're having such problems. I guess the first question I have, is the BIOS set to AHCI or IDE? IF you have the the BIOS set for AHCI mode this may be the issue since AHCI mode is usually used for Solid State Drives which it seems you don't have installed. As for the IDE part, on most new boards, setting this mode doesn't mean you drive will be degraded it is just a compatibility setting. As long as you have the drive connected to a SATA port IDE mode should work just fine. If you haven't tried it yet, set you BIOS to IDE and verify that the drive is detected and is listed as the primary boot device in the BOOT Priority section of the BIOS.
kherring7383
Level 2
Level 2
 
Posts: 53
Joined: Sun May 29, 2011 11:34 pm

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Mon Jul 30, 2012 1:57 pm

That won't fix it, when it was set to IDE Ubuntu and mint didn't work. When I tried with Ubuntu it gave me an error along the lines of it cant find a HDD.

The error Ubuntu gave is a unable to find medium containing a live file system, I solved this by changing it to AHCI so I don't think thats the issue with Mint, it doesn't even seem to get that far.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Mon Jul 30, 2012 4:32 pm

It might have to do with the way you formatted the hard drive.

Did you use the default formatting suggested by the installer?

If yes, then it probably tries to install using MBR, unless the disk was formatted to GPT. There are some issues with grub and UEFI boot. Grub is the boot loader for Linux. You may want to check which setting you have in the BIOS - to boot from UEFI or MBR.

What can happen is that you boot the DVD and install Linux Mint but with a GPT formatted disk it might try to install to boot in UEFI. Then when you boot into the installed LM it gives you - well - the famous black screen with cursor.

Installing UEFI boot can be a challenge.

Here is what I would do:

1. If you haven't got a live DVD version of Linux Mint, get it, use unetbootin (it's also available for Windows, if I'm not mistaken), and use it to prepare a bootable live USB Linux Mint stick (flash drive). No need to produce a DVD that sooner than later lands in the trash.As long as the USB stick is formatted fat32 it's fine.
2. Boot from the USB stick (choose from BIOS to boot the stick).
3. Go to the administration menu and choose gparted.
4. By default it should show you the first disk, that is /dev/sda (or /dev/hda). If that is the disk where you install, continue. Else select the disk where you want to install Linux Mint.
5. Check the partitions you have on this disk. If there is a partition formatted to fat32 and marked EFI system, you have an UEFI boot partition which points to UEFI problems.
6. If there isn't an EFI partition, try to see if gparted shows you how this disk is formatted - either MBR or GPT. Sorry I can't tell you how since I'm sitting on a Macbook now.
7. If you don't care to wipe the disk clean and install from scratch, format the entire disk to MBR (check the menus for the partition table option). If you want to try that on a disk with other operating systems installed, DON'T - it will wipe everything on the entire disk!
8. Once you formatted the disk to a MBR partition table, you can run the Linux Mint installer. You can then use the default partitioning scheme suggested by Linux Mint, or select a Custom option where you define your own partitioning scheme. In the latter case, choose /dev/sda1 512MB ext2 to mount as /boot, /dev/sda2 15GB ext4 to mount as / (root), /dev/sda3 4GB (or 8GB or more if you want to hibernate to disk) as swap, and /dev/sda4 (the rest of the drive if you don't need it for another OS, or around 30-whatever you need GB) ext4 to mount as /home.
9. When the installer is finished, reboot and boot from disk. It should work with MBR formatted disk.

Good luck!
Last edited by powerhouse on Mon Jul 30, 2012 4:49 pm, edited 2 times in total.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Mon Jul 30, 2012 4:42 pm

One more thing: I haven't used IDE setting in BIOS for many years. AHCI should be the normal setting. I assume you use SATA3 3GB or SATA3 6GB drives. Most modern motherboards and drives come with those. And they are best served with the AHCI setting.

Most motherboards have several SATA controllers for the drives. Make sure your boot drive is connected to the right controller. In my case (Asus Sabertooth X79) I have the Intel X79 controller that offers 2 SATA3 6GB connectors and 6 SATA3 3GB connectors, as well as a Marvel SATA3 6GB controller that provides 2 6GB ports. It's best to use the Intel controller for the boot drive. I think there is even a 3rd controller for eSATA drives, but those are external connectors on the rear of the board.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby austin.texas on Tue Jul 31, 2012 5:19 pm

Please tell us which linux you are trying to install.
I did the same as you recently when I installed a quad core AMD. It is working fine with AHCI. I don't have any Windows, tho.
I installed Mint 13 Cinnamon and Mint 13 Mate. Both were ok with the 3.2 kernel, but better with the 3.3 kernel.
I tried to boot with a Mint 12 install disk, and it would not boot. Same for Mint 11, Mint 10, and Mint 9. Total failure.
I am mentioning that because you may be using one of the older versions. ?
Mint 17 Cinnamon (64 bit), Quad core AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI
Microsoft-free environment since 1996

To help Linux Mint with a donation, please visit http://www.linuxmint.com/donors.php
User avatar
austin.texas
Level 9
Level 9
 
Posts: 2732
Joined: Tue Nov 17, 2009 3:57 pm
Location: at /home

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Tue Jul 31, 2012 5:23 pm

That didn't appear to work, I got the same error but with a black screen instead of a the text that was last on the screen and a blinking curser mark. It seems to freeze at the same point.

It might have to do with the way you formatted the hard drive.

Did you use the default formatting suggested by the installer?

If yes, then it probably tries to install using MBR, unless the disk was formatted to GPT. There are some issues with grub and UEFI boot. Grub is the boot loader for Linux. You may want to check which setting you have in the BIOS - to boot from UEFI or MBR.

As far as I know I shouldn't need to format my HDD for either of the ways I've tried to boot up Linux mint. The first time I tried it wasn't formatted it was right out of the box and Ubuntu loaded and worked with it fine.

When I have installed Ubuntu on my old computer through windows I didn't need to partitian the hard drive it just worked. I'm doing the same thing but it's not working for some reason.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Fri Aug 03, 2012 6:54 am

austin.texas wrote:Please tell us which linux you are trying to install.
I did the same as you recently when I installed a quad core AMD. It is working fine with AHCI. I don't have any Windows, tho.
I installed Mint 13 Cinnamon and Mint 13 Mate. Both were ok with the 3.2 kernel, but better with the 3.3 kernel.
I tried to boot with a Mint 12 install disk, and it would not boot. Same for Mint 11, Mint 10, and Mint 9. Total failure.
I am mentioning that because you may be using one of the older versions. ?

I missed this, I'm trying to install Linux Mint 13 "Maya" - Cinnamon (64-bit). The problem occurred before installing windows or using the main HDD for the first time.

Powerhouse I tried using unetbootin again but this time downloading one of the distributions through the program (mint x64 was the most up to date). I got a different error this time telling me the licence was invalid (press any key to continue) and then returned me to the main menu (boot live, boot compatability, check cd integrity)
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Fri Aug 03, 2012 6:43 pm

Licence invalid? That is the first time I hear such a thing with Linux.

I would download the main Linux Mint Maya Mate version (or Cinnamon, but I can't comment on that). Then use unetbootin and select the ISO you downloaded. Unetbootin may not give you the latest options when using the options on the top line. So go down and mark the box where you can specify a local ISO (the one you downloaded). I would download the 64 bit version.

With regard to the installer and partitioning, if you use the default option Linux Mint or Ubuntu will try to find spare space on your boot drive (if any), or if it's a new drive it will partition and format the entire drive.

With the custom option you have control over which partitions, space, and format LM or Ubuntu is using. On a fresh disk it might be easier to just let LM make the decisions, unless you need to reserve space for another OS such as Windows.

If you need to partition the disk manually under the custom option, I would use this partitioning scheme:

512 MB formatted to ext2 for /boot
15GB formatted to ext4 for /
2-4GB used as swap space (if you want to hibernate your PC, you need to have the swap space to match at least your amount of RAM, but that should only be relevant to notebooks/netbooks)
30GB and more (whatever you need for your data) formatted to ext4 for /home - if you have a 2TB drive and plan to install Windows as well, use something like 500GB-1TB for /home if you know you are going to use it, for example for multimedia content.

If you already installed an OS but want to wipe the disk to have a clean install, I'd run gparted before running the installer and wipe the disk clean and set an MBR partition table.

By the way, did you check your BIOS settings - MBR or UEFI boot? UEFI can give lots of troubles and I recommend MBR for the moment.

If you boot the live USB and run gparted, which partitions do you see on your hard drive?

You can also go to a terminal window and enter

Code: Select all
fdisk -l /dev/sda


and post the output here. (You may need to use sudo for that command.)
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Sat Aug 04, 2012 9:43 am

I would download the main Linux Mint Maya Mate version (or Cinnamon, but I can't comment on that). Then use unetbootin and select the ISO you downloaded. Unetbootin may not give you the latest options when using the options on the top line. So go down and mark the box where you can specify a local ISO (the one you downloaded). I would download the 64 bit version.
You mean like the one I mentioned in my first post? On unetbootin I have tried(all linux mint):
10_live_x64
9_live_x64
linux mint 13 cinamon (64bit)
linux mint 13 cinamon (32bit)
linux mint 13 mate (64bit)
linux mint 12 cinamon (64bit)

The partitioning stuff seems pointless if mint won't even load off the DVD/USB.

I did check and the option doesn't exist. The closest I've found is this



I tried installing the windows installer for Ubuntu (12) which got a bit further than mint but ceased up on the purple screen where I assume it starts loading the OS.

Edit: UPDATE
Still trying to install within Windows.

I installed Ubuntu 10 which installed fine but couldn't see the ethernet on my motherboard (but I could tether using my HTC Desire) thus I had no internet connection to update it to 11 or 12.
I just installed Ubuntu 10.1(.4?) and it installed and worked fine but didn't have any network access (motherboard drviers maybe).
I decided to give Mint 9 (64) a try and that installed but complained about a file missing, I installed mint 9 through windows mounting it on deamon tools lite. Which seemed to work, I'm starting to think the later versions are conflicting with something and stopping it from starting up on my computer at all.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Sat Aug 04, 2012 8:28 pm

Wow, that looks like you went through a lot of (failed) installs.

From what I gather is that the Linux Mint 13 Mate (or Cinnamon) live USB won't even boot, nor would the DVD?

Just to rule out UEFI issues, boot the PC and go into the BIOS. Make sure that the boot option is MBR, not UEFI.

I believe unetbootin takes care of formatting the USB prior to installing the system. The USB stick should be formatted to fat32 ! Check within Windows if unsure and reformat, if necessary, then reinstall on USB using unetbootin. If that doesn't work, there are other USB utilities to prepare a bootable live USB stick.

What you describe means that you don't even get the grub menu. On the other hand you managed to successfully boot into and install older versions of Ubuntu, or am I wrong? Did you use a DVD in that case?

I'm not familiar with your particular motherboard, but I've searched the Internet for your motherboard and Ubuntu and the only issues I've found are hardware related (CPU). Since you successfully installed Windows 7 i don't think it is a CPU issue. There are still other hardware related possibilities (memory, disk, graphics card or CPU internal GPU).

To rule out hardware problems, when in Windows 7, install Aida or Prime (latest versions) and let it run for 24 hours. Just make sure you got good cooling else there is a chance you fry your CPU or motherboard. At the end you should have NO errors. I had a similar story of not being able to install Linux Mint and it turned out to be faulty memory.

Other things to check are:

1. Have you got the newest BIOS release?
2. Reset the BIOS to default values and check the BIOS settings - as for the memory, enable XMP.
3. Do you have USB 2 connectors? If yes, try booting from them (instead of USB 3).
4. Where did you connect your display to? You should have a DVI and/or VGA connector for the i5 processor internal GPU on your motherboard as well as a DVI connector from your graphics card. Try switching between them to see if it makes a difference.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby rek on Sun Aug 05, 2012 8:56 am

I just built a new box and being a muddler and not a hacker, I probed the net for information before proceeding. The best information I found was in "forums.lenovo.com" the title was "configuring Linux to run on UEFI based systems where grub fails to install". There are several posts I found Illuminating, the best one from a guy in Albania. Since I avoid tinkering I chose the easy way out by connecting the hard drive to another box and installing grub with a mate 13 install. Since MS has sometimes destroyed the mbr with an update,I never install MS with Mint anymore. I use an external esata drive with an on-off switch and install MS alone on a small drive for if ever needed. With the MS drive turned off, I reconnect and boot mate ,turn on MS drive and update grub. rek
rek
Level 1
Level 1
 
Posts: 35
Joined: Sat Jul 21, 2007 10:49 am
Location: Ohio

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Tue Aug 14, 2012 5:58 pm

Sadly neither boot.

I can't actually find that in there a boot option that referes to it. The closest I found was legacy ROM support (warning big picture below)
http://i.imgur.com/St5oC.jpg

The other thing I noticed was that it mentions UEFI but that seems to have already been selected.
http://i.imgur.com/9L3wd.jpg

With the USB still plugged in, I couldn't see where I could change it to MBR

The USB is formatted in FAT32.

Yea that's right I managed to install an older version of Ubuntu, that time I used a DVD.

Just updated the BIOS to the most recent BIOS.
When the BIOS was updated it loaded the default and then windows wouldn't start up (because the drive was set to IDE rather than ACHI)
I've been using a USB2 connector that's built into the case (and connected to the motherboard via a wire)
My display is connected to my Graphics card via HDMI cable.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Wed Aug 15, 2012 8:32 am

OK, from the pictures you shared I gather the following:

1. You have selected UEFI boot in the BIOS options.

2. You are trying to boot from disk no. 1 in UEFI mode, which should be your first hard drive in your PC.

I assume you have two hard drives, two DVD/CD drives, and the USB stick which you want to boot.

After you have successfully prepared the USB stick with Linux Mint, insert it into a USB2 port (as you have done already).

Turn on the PC and press whatever key you need to press to get to the BIOS menu.

If possible, I would dump UEFI boot and choose MBR (or Legacy ROM in your option). HOWEVER, if your Windows system has been installed to boot from UEFI, you probably have to reinstall that.

So in the BIOS select "Legacy ROM" as the boot option (unless you really want UEFI). Then select the disk to boot from - it should be the last disk in your option. If your BIOS has a boot menu, open it and select the USB drive (make sure it doesn't say UEFI) and boot from that.

If Linux Mint doesn't boot, there are several points to (re)check:

1. I would select AHCI for the disks, not IDE (in the BIOS).
2. Recheck the BIOS to make sure you boot from USB stick !!! Check your motherboard manual to find out how to enter the boot menu. In the boot menu select the USB drive (in my BIOS it clearly reads "USB..." and some manufacturer info).
3. Check that your USB stick is bootable - put it into another PC / notebook and boot from USB - if it boots, your stick is fine.
4. Make sure "Legacy ROM" is selected in the boot options menu (and not UEFI). Even if you later want to use UEFI, let's make sure the damn USB stick boots - so it's best to take the UEFI variable out of the game. It just complicates matters.

If you managed to boot from the Linux Mint live USB stick, have a look at this link: http://www.ibm.com/developerworks/linux/library/l-gpt/index.html. Even if you want to use MBR partition table it gives some good background and advise.

Important: Your Windows may have been installed using the UEFI boot option. If you select "Legacy ROM" in the BIOS your Windows may not boot. You can always revert the above BIOS settings, so let's focus on getting the USB stick to boot, and later worry about how to make everything work together.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Wed Aug 15, 2012 2:54 pm

Trying it now.

I seem to have already set it to legacy Rom mode, I might have changed that after updating the BIOS or it was a default value. Windows boots in both EFI and Legacy. For further clarity my computer is already set to ACHI, none of the operating systems start when it is set to IDE.

1. You have selected UEFI boot in the BIOS options.
I haven't selected that of my own free will. The disk drive always appears as UEFI

2. You are trying to boot from disk no. 1 in UEFI mode, which should be your first hard drive in your PC.
Without the USB plugged in the boot order is DVD Rw>DVD drvie> 1TB Seagate>old Samsung HDD

If possible, I would dump UEFI boot and choose MBR (or Legacy ROM in your option). HOWEVER, if your Windows system has been installed to boot from UEFI, you probably have to reinstall that.
I've selected legacy Rom and it still fails to boot.

2. Recheck the BIOS to make sure you boot from USB stick !!! Check your motherboard manual to find out how to enter the boot menu. In the boot menu select the USB drive (in my BIOS it clearly reads "USB..." and some manufacturer info).
F12 for boot menu, definitely entered the USB this time. The past times it appeared I was accessing it as a UEFI USB hard disk. I choose the Sandisk cruzier blade this time.


Still not booting but it gets further, which is a plus I guess... Below are some pictures of trying to boot from the USB as opposed to UEFI USB Hard disk. Also there are pictures of my BIOS settings.

The BIOS settings (Big pictures!)
http://i.imgur.com/ioGAp.png Note: Boot option 2 is my HDD when the USB and DVD drvies are empty it goes straight there

http://i.imgur.com/UNxF6.png

http://i.imgur.com/eh94Z.png

Also I just noticed it says UFEI at the top.

When I boot using the USB drive directly I get this
http://i.imgur.com/8XhF7.jpg

It starts and you get the normal scrolling text flying by and then it freezes here:
http://i.imgur.com/4mnbj.jpg

For the time I've written this post It has been frozen there.

3. Check that your USB stick is bootable - put it into another PC / notebook and boot from USB - if it boots, your stick is fine.
Just checked it on the mac I mentioned earlier. Pressing the option button makes it appear as a EFI hard disk, after selecting it the machine booted into Mint just fine (only took around 3 minutes as well!)
Last edited by swiftninja on Sun Sep 23, 2012 12:27 pm, edited 2 times in total.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Wed Aug 15, 2012 5:33 pm

swiftninja, you repeatedly posted the same picture (BIOS screen shot). Can you edit your post?

Now to the points you answered:

AHCI (or whatever) - good, it shouldn't be IDE.

"Windows boots in both EFI and legacy": I suspect it always boots in UEFI mode on your system, since disk 1 is identified by the BIOS as UEFI drive (see below).

1. You have selected UEFI boot in the BIOS options.
I haven't selected that of my own free will. The disk drive always appears as UEFI


As you wrote in your reply, you updated the BIOS and you or the update probably selected "Legacy ROM". Keep it at that for the moment.

2. You are trying to boot from disk no. 1 in UEFI mode, which should be your first hard drive in your PC.
Without the USB plugged in the boot order is DVD Rw>DVD drvie> 1TB Seagate>old Samsung HDD


OK, I suspect that Windows is installed on the 1TB Seagate drive that is identified by the BIOS as "uefi"? Right? If I remember correctly, when you install Windows 7 from DVD on an UEFI capable PC it should default to UEFI installation. In any case, your BIOS identifies the disk as UEFI disk, which means it has a GPT partition table and a fat32 EFI (or efi) partition which holds a filename.efi bootloader file. The file structure in this partition is something like /EFI/efi/microsoft/ with the .efi file in the microsoft folder. Anyway, you can check that later once you successfully boot Linux Mint. An UEFI capable motherboard is able to read GPT partition table and the EFI partition and load the OS using the .efi file specific for the OS.

At least now you are trying to boot in legacy mode (as opposed to the UEFI mode you used before).

I would like to see the other screen shots, especially for the boot sequence, since it might give some clues to what's wrong.

Here are some other tips that may help:

1. Disconnect all DVD drives. There may be a problem with one or both of them, or with the way they are connected (the ports you use on the motherboard). You can always hook them up later.

2. Check the SATA ports you used to connect the Seagate and the "old" hard drive. Here are the specs copied from the Gigabyte website:

2 x SATA 6Gb/s connectors (SATA3 0/1) supporting up to 2 SATA 6Gb/s devices
3 x SATA 3Gb/s connectors (SATA2 2/3/4) supporting up to 3 SATA 3Gb/s devices
1 x mSATA connector

Check that the Seagate drive is connected to the SATA3 0 (the first 6Gb/s) port, the other hard drive to SATA3 1 (the second 6Gb/s) port, or to the SATA2 2 port (the 3Gb/s port). Connect the DVDs to SATA2 3 and 4 later on.

3. If I'm not mistaken, your CPU has it's own GPU? At some point during boot it may switch to your CPU internal GPU, or vice versa if you connected your monitor to the internal GPU. Have a look at this post http://forums.linuxmint.com/viewtopic.php?f=42&t=109298, perhaps it provides some clues. Look for the "nomodeset" boot option.

Check your BIOS to see which GPU is selected. I'm totally unfamiliar with HDMI, but you may want to try to connect your screen using a DVI connector.

But first of all let us have the screen shots! They may give a much better clue.
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Re: Linux Mint not playing well with my new computer

Postby swiftninja on Thu Aug 16, 2012 5:58 pm

I've edited the post with the correct screen shots.

The UEFI is a version of the USB drive Cruzer blade, I think the BIOS emulates it as a HDD. In the third screenshot you can see all the devices and what I think are the SATA port numbers, ST1000DM003 is my 1TB drive with Windows installed on it; I'll open her up and check properly in the morning.
swiftninja
Level 1
Level 1
 
Posts: 8
Joined: Mon Jul 30, 2012 9:12 am

Re: Linux Mint not playing well with my new computer

Postby powerhouse on Thu Aug 16, 2012 9:00 pm

The last 2 screen shots are still the BIOS screen shots. Please update them.

I would like to see the screen shots from when it starts booting. Booting from USB in legacy mode, did you get a Grub menu?
Asus Sabertooth X79, i7 3930K CPU, 8x4GB Kingston DDR3 RAM, Noctua NH-D14 CPU cooler, Sapphire 7770 GPU, PNY Quadro 2000 GPU, Asus Xonar Essence STX, Sandisk Extreme 120GB SSD + various HD, Corsair 500R case, SeaSonic 660W Gold X PS
powerhouse
Level 5
Level 5
 
Posts: 641
Joined: Thu May 03, 2012 3:54 am

Linux Mint is funded by ads and donations.
 

Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 11 guests