Libre Office - Spell Check not working [SOLVED]

Questions about applications and software
Forum rules
Before you post please read how to get help

Libre Office - Spell Check not working [SOLVED]

Postby caf4926 on Fri Aug 24, 2012 10:41 am

In Mint 13 KDE _64 (other ver. not tested)

Spell check isn't working properly.
Auto correct will work as it does, on some words.
But miss spelled words do not get picked up as you type.

Anyone?
Last edited by caf4926 on Fri Aug 24, 2012 10:46 pm, edited 1 time in total.
Image
Mint Maya
User avatar
caf4926
Level 7
Level 7
 
Posts: 1792
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Linux Mint is funded by ads and donations.
 

Re: Libre Office - Spell Check not working

Postby kc1di on Fri Aug 24, 2012 12:53 pm

hi caf4926,

I have not noticed any problem here on 64 bit Cinnamon version so I suspect it has something to do with KDE and maybe missing
Dictionaries.
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
LinuxMint 17.1 Cinnamon/Mate
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Image
User avatar
kc1di
Level 7
Level 7
 
Posts: 1787
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Libre Office - Spell Check not working

Postby Beardedragon on Fri Aug 24, 2012 1:00 pm

Code: Select all
sudo apt-get install myspell-en-us

Could use Synaptic or Aptitude or change languages.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64
User avatar
Beardedragon
Level 4
Level 4
 
Posts: 349
Joined: Sat Jan 29, 2011 3:37 am

Re: Libre Office - Spell Check not working

Postby caf4926 on Fri Aug 24, 2012 1:42 pm

myspell-en-gb

Thank you

\strange it wasn't installed
Image
Mint Maya
User avatar
caf4926
Level 7
Level 7
 
Posts: 1792
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Libre Office - Spell Check not working

Postby Beardedragon on Fri Aug 24, 2012 3:47 pm

Little details get left out. Be sure to change the Subject line in the first post to read [solved] Along side the original "Libre Office - Spell Check not working" so other users may benefit from your experience.
Robert Collard, Madison, WI
HP s5710f, 2x AMD Athlon II 260@3.2Ghz, 3GB RAM, 640GB HD
Debian 7.1 Wheezy 3,2,0-4 Xfce 4.10 AMD-64
LMDE 3.10.5-1 Xfce 4.10 AMD-64
SalineOS 2.0 3.2.0-4 Xfce 4.8 AMD64
User avatar
Beardedragon
Level 4
Level 4
 
Posts: 349
Joined: Sat Jan 29, 2011 3:37 am

Re: Libre Office - Spell Check not working [SOLVED]

Postby JigglyPuff on Thu Jan 17, 2013 1:11 pm

It worked for me and cured that very annoying problem.

Thank you! :)
JigglyPuff
Level 1
Level 1
 
Posts: 17
Joined: Sun Dec 04, 2011 10:26 am

Re: Libre Office - Spell Check not working

Postby Colonel Panic on Sat Feb 15, 2014 4:25 am

Beardedragon wrote:
Code: Select all
sudo apt-get install myspell-en-us

Could use Synaptic or Aptitude or change languages.


Thanks for this! I had (but no longer have) the same problem. I also had to install myspell-en-gb as I live in the UK.

Cheers,

CP .
Colonel Panic
Level 2
Level 2
 
Posts: 56
Joined: Sat Jan 30, 2010 9:01 pm

Re: Libre Office - Spell Check not working [SOLVED]

Postby Imach on Mon Jul 21, 2014 1:43 pm

It did the trick for me also on Mint 17 LMDE.

Thank you!!
Imach
Level 1
Level 1
 
Posts: 1
Joined: Mon Jul 21, 2014 1:39 pm

Re: Libre Office - Spell Check not working

Postby Brendan3 on Wed Jan 28, 2015 12:05 am

Beardedragon wrote:
Code: Select all
sudo apt-get install myspell-en-us

Could use Synaptic or Aptitude or change languages.


I am running LibreOffice 4.2.7.2 on Linux Mint 17.1 Rebecca and had to modify this a bit to get it to work for me.

Instead of:
Code: Select all
sudo apt-get install myspell-en-us


I used:
Code: Select all
sudo apt-get install hunspell-en-ca


Thank you for the information!
Brendan3
Level 1
Level 1
 
Posts: 1
Joined: Tue Jan 27, 2015 11:22 pm

Re: Libre Office - Spell Check not working [SOLVED]

Postby BW2 on Fri Apr 17, 2015 4:45 pm

LibreOffice version 4.2.7.2 (Spell Check)

Before using apt-get ect Which I was going to do, try the most obvious way first!

1< Open/Start LibreOffice Writer
2> Type some words in the blank page, some correct and other words with spelling mistakes.
3> If there is NO squiggly lines under the mistakes then move on to point # >4. If the typos are marked as errors then the spell application works.
4> Select [Tools] from the Menu.
5> From the Tools menu select [Language].
6> With the Language option highlighted, choose the top option on the right [For Selection].
7> After highlighting For Selection, choose from the choices on the right side - [English (Canada)] or English (USA). If this not your preferred language then select MORE.
8> Now we once again need to select Tools from the Menu, followed by Language then this time select [For Paragraph].
9> After highlighting For Paragraph, you are again faced with the same options on the right as noted in point #7. [Choose English (Canada)] or English (USA). If this not your preferred language then select MORE.
10> For the third and final time from the Tools menu select [Language].
11> With Language highlighted select [For all Text].
12> After highlighting For all Text, you are again faced with the same options on the right as noted in point #7. [Choose English (Canada)] or English (USA). If this not your preferred language then select MORE.
13> If you have chosen either [Choose English (Canada)] or English (USA), you should now see the spelling errors on your page.
_____________________________________________________________________________________________________________________________________________________________________________________

Step A> Menu / Tools/ Language/ For Selection/ Choose English (Canada).
Step B> Menu / Tools/ Language/ For Paragraph/ Choose English (Canada).
Step C> Menu / Tools/ Language/ For all Text/ Choose English (Canada).

Your final choice on Steps A,B,&C. may be English USA.
If you choose another language other then Canadian or USA English then you must down load a new language!

I hope this works for you, it really is straight forward once you start. Just be sure to assign the same language for each option For Selection | For Paragraph | For all Text.
BW2
Level 1
Level 1
 
Posts: 1
Joined: Fri Apr 17, 2015 3:26 pm

Re: Libre Office - Spell Check not working [SOLVED]

Postby NChewie on Sat Apr 18, 2015 5:21 pm

...or you can cut out a few steps from point 3 onwards by using CTRL-A to select all the text, then looking at the language shown as the middle (fourth from left) entry on the bottom of the window. [Note that CTRL-A sometimes behaves strangely and does not select all of the text within some tables and Frames]
If it is showing your language... then you don't have to reset it. If it is showing the wrong language, you can right-click on the language shown (or on Multiple Languages if your selection had ... multiple languages) and select the language you want.

To check if the language that is set for your default documents is capable of spell-checking, use Tools-Options-Language Settings-Languages and see if there is a little tick with (ABC) beside the chosen language. For example, I live in Ireland but use English(UK) as it has the spell-checker, while English(Ireland) does not.
NChewie
Level 2
Level 2
 
Posts: 56
Joined: Wed Oct 15, 2014 8:46 am
Location: Ireland

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: shiznatix and 32 guests