Cinnamon + ATI drivers = slowdown

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Cinnamon + ATI drivers = slowdown

Postby sepul on Mon Aug 13, 2012 9:44 am

running mint 13 - cinnamon edition.

I have tried (installed) both amd/ati proprietary included in mint "additional drivers" and also the latest one from the amd website (12.6). both of them make graphic updates slower than before and cpu usage of cinnamon process very high. especially when window updates occur.

does anybody else have this problem ? what is the workaround ?
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Linux Mint is funded by ads and donations.
 

Re: Cinnamon + ATI drivers = slowdown

Postby kelebek333 on Sun Aug 19, 2012 4:07 pm

You can try to enable Tear Free on CCC.

Image
Image
User avatar
kelebek333
Level 2
Level 2
 
Posts: 50
Joined: Sat Jun 25, 2011 11:57 am
Location: Turkey

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Thu Aug 23, 2012 8:45 am

"tear free" is now on.
the window movement/transitions and animations are now smooth.
but the main problem with high cpu usage still remains. especially when window updates/redraws are needed.
cinnamon is almost always the most cpu consuming app in the list.

here is some examples (on ATI 5750 + intel core2 quad cpu):
running glxgears (60fps): glxgears=100% cpu, cinnamon 92%,... all the time
moving around in the cinnamon's main menu: cinnamon - 200~240% cpu
moving a single nautilus window around on the desktop: 148% cpu
a single terminal window is open (with blinking cursor) : 36% cpu
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby kelebek333 on Thu Aug 23, 2012 11:11 am

Are you try to install manuel installation.

You can install following.

1. You must remove driver from repo version.

Code: Select all
sudo /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get autoremove
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg


After reboot your PC.

2 . Install ATI driver from website.

Code: Select all
mkdir amd-driver-12-6
cd amd-driver-12-6
wget -c www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
chmod +x amd-driver-installer-12-6-x86.x86_64.run
sudo sh amd-driver-installer-12-6-x86.x86_64.run
sudo amdconfig --initial -f


After installation reboot your PC.
Image
User avatar
kelebek333
Level 2
Level 2
 
Posts: 50
Joined: Sat Jun 25, 2011 11:57 am
Location: Turkey

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Fri Aug 24, 2012 4:37 am

Uninstalled and reinstalled those stuff as u told, but didn't help
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby kelebek333 on Sat Aug 25, 2012 3:00 am

I think that, it's a driver problem. You can try to install 12.8 version.

Firstly uninstall driver as foolwing.

Code: Select all
sudo /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get autoremove
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg


Then install ATI 12.8 version driver.

Code: Select all
mkdir amd-driver-12-8
cd amd-driver-12-8
wget -O amd-driver-installer-12-8-x86.x86_64.zip http://goo.gl/HUyH4
unzip amd-driver-installer-12-8-x86.x86_64.zip
chmod +x amd-driver-installer-8.982-x86.x86_64.run
sudo sh amd-driver-installer-8.982-x86.x86_64.run
sudo aticonfig --initial -f
Image
User avatar
kelebek333
Level 2
Level 2
 
Posts: 50
Joined: Sat Jun 25, 2011 11:57 am
Location: Turkey

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Sat Aug 25, 2012 7:14 am

installed 12.8 drivers. no change, still the same
I think the problem is somehow with cinnamon not playing well with amd drivers.
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby kelebek333 on Sun Aug 26, 2012 4:32 am

If you added extensions or applets on cinnamon, you can try to return default all settings.
For this, use cinnamon settings applet or following code.

Code: Select all
gsettings reset-recursively org.cinnamon
Image
User avatar
kelebek333
Level 2
Level 2
 
Posts: 50
Joined: Sat Jun 25, 2011 11:57 am
Location: Turkey

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Sun Aug 26, 2012 12:26 pm

reset the settings, again, no success.
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby kelebek333 on Tue Aug 28, 2012 2:36 am

Did you try to change icons, GTK+ and Cinnamon Themes.

Then, press ALT+F2 type r and run for refesh Cinnamon.
Image
User avatar
kelebek333
Level 2
Level 2
 
Posts: 50
Joined: Sat Jun 25, 2011 11:57 am
Location: Turkey

Re: Cinnamon + ATI drivers = slowdown

Postby weboide on Tue Aug 28, 2012 2:17 pm

I have the exact same issue on a fresh install of Mint 13 and Cinnamon.
weboide
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 28, 2012 2:16 pm

Re: Cinnamon + ATI drivers = slowdown

Postby chinux23 on Tue Aug 28, 2012 7:30 pm

I have the exact same problem. I am running i7 930 with ati 5970 with proprietary drivers. The cinnamon always takes about 40% of CPU usage in idle. The ui looks really nice, but it feels laggy. To me, this is one last thing that prevent me from migrating. Any solutions?
chinux23
Level 1
Level 1
 
Posts: 1
Joined: Tue Aug 28, 2012 7:09 pm

Re: Cinnamon + ATI drivers = slowdown

Postby weboide on Wed Aug 29, 2012 7:50 am

My workaround was to go back to open source radeon drivers. Just remove fglrx or fglrx-updates and reboot. If you have a multi-display setup, you can set it up in the built-in-Mint Displays settings.
weboide
Level 1
Level 1
 
Posts: 2
Joined: Tue Aug 28, 2012 2:16 pm

Re: Cinnamon + ATI drivers = slowdown

Postby grumpy old man on Fri Aug 31, 2012 10:07 am

weboide wrote:My workaround was to go back to open source radeon drivers.


That worked for me, thank you.
User avatar
grumpy old man
Level 1
Level 1
 
Posts: 1
Joined: Fri Aug 31, 2012 10:02 am

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Sat Sep 01, 2012 9:45 am

chinux23 wrote:I have the exact same problem. I am running i7 930 with ati 5970 with proprietary drivers. The cinnamon always takes about 40% of CPU usage in idle. The ui looks really nice, but it feels laggy. To me, this is one last thing that prevent me from migrating. Any solutions?

yeah, default opensource drivers works, but they only support opengl2.1. I need more advanced driver features like opengl3,4+ support and better graphics performance which the official drivers only provide.
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby nickjhs on Mon Sep 03, 2012 7:43 pm

sepul wrote:
chinux23 wrote:I have the exact same problem. I am running i7 930 with ati 5970 with proprietary drivers. The cinnamon always takes about 40% of CPU usage in idle. The ui looks really nice, but it feels laggy. To me, this is one last thing that prevent me from migrating. Any solutions?

yeah, default opensource drivers works, but they only support opengl2.1. I need more advanced driver features like opengl3,4+ support and better graphics performance which the official drivers only provide.



Yep I have the same issue here. I have a Phenom 11 quad 965 and a radeon 6870. I have noticed cores one and three at or close to 100% whilst practically idle, generally they sit around the 40 to 50% mark. (just chromium and system monitor open). Moving windows around the desktop is very laggy even with "tear free" option.
nickjhs
Level 1
Level 1
 
Posts: 1
Joined: Sat Sep 01, 2012 7:29 pm

Re: Cinnamon + ATI drivers = slowdown

Postby sagarthegreat1 on Thu Sep 06, 2012 11:50 pm

confirming the presence of the issue:
tried these drivers:
1)ATI/AMD proprietary FGLRX drivers(post release updates)
2)ATI/AMD proprietary FGLRX drivers
3)amd-driver-installer-12.6-legacy-x86.x86_64 (downloaded from amd site)
all of these lead to very laggy graphic performance, like when one tries to run CRYSIS on onboard graphics.
The only driver that works relatively smooth is the open-source radeon, provided by default in mint13.
sagarthegreat1
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 30, 2011 9:57 am

Re: Cinnamon + ATI drivers = slowdown

Postby Cerule on Fri Sep 07, 2012 12:43 pm

Maybe worth trying Kde? Dunno if it's the desktop but I have Mint 13 kde Ati 4550 hd with core2duo 2.8 ghz and typically about 5% cpu load when idle. Using ati's propriety drivers. Videos do have tearing if "Tear free desktop" is turned off but no problems when turned on.
User avatar
Cerule
Level 1
Level 1
 
Posts: 24
Joined: Sat Sep 01, 2012 1:44 pm

Re: Cinnamon + ATI drivers = slowdown

Postby sepul on Fri Sep 07, 2012 2:08 pm

Switched to mate. Very stable, no problems with amd drivers and very practical
Waiting for cinnamon to get more stable ...
sepul
Level 1
Level 1
 
Posts: 11
Joined: Mon Mar 05, 2012 12:36 pm

Re: Cinnamon + ATI drivers = slowdown

Postby Staffy on Tue Sep 11, 2012 2:17 pm

Switched to mate. Very stable, no problems with amd drivers and very practical
Waiting for cinnamon to get more stable ...


Same here tried every fix I could find the only fix that works is to change to somethimg else. I have tried KDE and XFCE and non of them have the same issues, so logic says it isn't the drivers.

I'll keep my eyes on cinnamon to see if this gets fixed as I liked the feel of it.
Staffy
Level 1
Level 1
 
Posts: 8
Joined: Wed Dec 21, 2011 8:29 am

Linux Mint is funded by ads and donations.
 
Next

Return to Cinnamon

Who is online

Users browsing this forum: qbektrix and 5 guests