Volume goes up/down by itself, Linux Mint 13 64-bit MATE

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Volume goes up/down by itself, Linux Mint 13 64-bit MATE

Postby Pikiwedia on Sat Sep 15, 2012 7:16 am

Hi, as the title says, I'm having issues with the volume randomly going up and down by itself. It works fine for a few minutes, then it starts going up and down by itself, sometimes just a few seconds apart. It's not a new issue as it's been happening ever since I did a fresh install of Linux Mint 13 a few months ago, and this is happening in both web-browsers, games and applications. I have tried things such as sudo dpkg-reconfigure alsa-base, as well as adding the line "options snd-hda-intel model=auto" at the end of my /etc/modprobe.d/alsa-base.conf, but unfortunately to no avail.

My graphics-cards is a Nvidia GeForce 8600 GS.

Some additional information that might be useful:

Code: Select all
cat /proc/asound/cards
 0 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xbfffc000 irq 66


Code: Select all
lspci | grep Audio
80:01.0 Audio device: VIA Technologies, Inc. VT8237A/VT8251 HDA Controller (rev 10)


Code: Select all
head -n 1 /proc/asound/card0/codec*
Codec: Realtek ALC888


Code: Select all
/etc/modprobe.d/alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-hda-intel model=auto


Any help is greatly appreciated!
Case Fractal Design Define R4 | CPU i5 3570k @3.4Ghz | MB ASUS P8Z77-V PRO | RAM Corsair VENGEANCE LP 8GB | PSU Fractal Design Newton R3 600W 80+ Platinum | Speakers Creative Gigabyte T3 | Monitor Samsung UE32ES6715U |
Pikiwedia
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 15, 2012 6:39 am

Linux Mint is funded by ads and donations.
 

Re: Volume goes up/down by itself, Linux Mint 13 64-bit MATE

Postby Pikiwedia on Fri Feb 01, 2013 10:13 am

It's been several months now, and the problem has not gone away.

I recently built a new computer with the ASUS P8Z77-V PRO motherboard, and other components (but I still have the same hdd). I have no issues on W7, nor when using the headphone-out on my volume-control from my speakers, Creative T3.

Does anyone know what can be done to fix this?
Case Fractal Design Define R4 | CPU i5 3570k @3.4Ghz | MB ASUS P8Z77-V PRO | RAM Corsair VENGEANCE LP 8GB | PSU Fractal Design Newton R3 600W 80+ Platinum | Speakers Creative Gigabyte T3 | Monitor Samsung UE32ES6715U |
Pikiwedia
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 15, 2012 6:39 am

Re: Volume goes up/down by itself, Linux Mint 13 64-bit MATE

Postby Fixitmanarizona on Thu May 30, 2013 6:05 am

Did you try
sudo dpkg-reconfigure linux-sound-base
instead?
Doubt that's it though, not if you're having issues with speakers and not headphones.
Variable output or something, messing up the speakers themselves due to an unstable output from... who knows, your guess is as good as mine. Not sure what that "blacklist" is in the code.
Fixitman
Fixitmanarizona
Level 1
Level 1
 
Posts: 18
Joined: Fri Jul 13, 2012 9:51 am


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: the lid and 3 guests