No Internet in Virtual Box

Connection sharing, Firewall, Samba..etc
Forum rules
Before you post please read this

No Internet in Virtual Box

Postby vimal0212 on Tue Jun 05, 2012 1:52 pm

I just installed Linux Mint 13 and installed Virtual Box latest version.
My pc is connected to Internet and I can access websites.
But I cant access network in Virtual Box client operating systems.
I was used VB in Ubuntu 10.04 and no problem with Internet.
Give me a solution to access Internet inside VB?
User avatar
vimal0212
Level 1
Level 1
 
Posts: 12
Joined: Tue May 29, 2012 11:01 pm
Location: India

Linux Mint is funded by ads and donations.
 

Re: No Internet in Virtual Box

Postby DrHu on Tue Jun 05, 2012 2:15 pm

Start with the regular troubleshooting (virtualbox uses the host OS network card for outside(internet) access)).

Code: Select all
inxi -N
ifconfig
netstat -r
route
--etc etc

And you don't say whether wireless or wired

The default mode is NAT (Network Address Translation), which is the normal way an internal LAN connects to the internet via an ISP connection, and should be the same way on your Linux host (or windows host)
--if the internet works on the host OS, it should without any attention also work on the virtual box guest OS..

A bit of an explanation, but also discussing bridged mode for the nic (Network Interface card), a mode that is sometinmes needed for other types of data transfer..
http://www.howtogeek.com/howto/4922/wee ... t-edition/
    The VirtualBox NAT adapter is great, especially for laptop users—the guest VM always has access to the internet regardless of where your laptop is connected to.
Last edited by DrHu on Fri Oct 26, 2012 4:31 pm, edited 3 times in total.
User avatar
DrHu
Level 16
Level 16
 
Posts: 6624
Joined: Wed Jun 17, 2009 8:20 pm

Re: No Internet in Virtual Box

Postby Total_Blue on Wed Jun 06, 2012 3:01 am

vimal0212 wrote:I just installed Linux Mint 13 and installed Virtual Box latest version.
My pc is connected to Internet and I can access websites.
But I cant access network in Virtual Box client operating systems.
I was used VB in Ubuntu 10.04 and no problem with Internet.
Give me a solution to access Internet inside VB?


Are you using NAT or Bridged? For some reason, I could not get NAT to work, but it worked for me using Bridge.
Total_Blue
Level 1
Level 1
 
Posts: 49
Joined: Wed Sep 07, 2011 5:01 pm

Re: No Internet in Virtual Box

Postby pba on Thu Jun 07, 2012 1:50 pm

I have a similar problem.
On top of a linux mint 13 there is VirtualBox (4.1.16) running linux mint 13.
The linux mint 13 inside the box has networking issues. It is configured using NAT and gets internally an IP address in the 10... net. However, there is no upstream dns server configured (/var/run/nm-dns-dnsmasq.conf is empty), which results in connection refused errors from dnsmasq. This is regardless of the setting in VirtualBox whether to expect ubuntu or a generic linux. Manually resolving with 10.0.2.2 (the dns server of VirtualBox) works flawlessly.

Any help appreciated.
pba
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 07, 2012 1:37 pm

Re: No Internet in Virtual Box

Postby OrthoSteven on Fri Jun 08, 2012 2:59 pm

This is very strage, both of my Virtualbox sytems (XP & Centos) can no longer connect to the interent. I know for a fact my XP guest could when I initially installed LinuxMint 13.

Changed both network connections to be bridged (from NAT) and it started working. I've had these guests running on the last 3 releases of Linux Mint & Ubuntu and they have always worked fine. Not sure what changed, but both guests can access the internet now.
Maya Cinnamon 64-bit
OrthoSteven
Level 1
Level 1
 
Posts: 9
Joined: Sun Aug 14, 2011 9:54 pm

Re: No Internet in Virtual Box

Postby AmitT on Thu Jun 14, 2012 4:44 am

OrthoSteven wrote:This is very strage, both of my Virtualbox sytems (XP & Centos) can no longer connect to the interent. I know for a fact my XP guest could when I initially installed LinuxMint 13.

Changed both network connections to be bridged (from NAT) and it started working. I've had these guests running on the last 3 releases of Linux Mint & Ubuntu and they have always worked fine. Not sure what changed, but both guests can access the internet now.

Same problem here.
Just changed it to "bridged" and it works now.
AmitT
Level 1
Level 1
 
Posts: 2
Joined: Thu Jun 14, 2012 4:41 am

Re: No Internet in Virtual Box

Postby vimal0212 on Thu Jun 14, 2012 5:41 am

Yes I changed NAT to Bridge. Now it works.
Thank you all of you.

AmitT wrote:
OrthoSteven wrote:This is very strage, both of my Virtualbox sytems (XP & Centos) can no longer connect to the interent. I know for a fact my XP guest could when I initially installed LinuxMint 13.

Changed both network connections to be bridged (from NAT) and it started working. I've had these guests running on the last 3 releases of Linux Mint & Ubuntu and they have always worked fine. Not sure what changed, but both guests can access the internet now.

Same problem here.
Just changed it to "bridged" and it works now.
User avatar
vimal0212
Level 1
Level 1
 
Posts: 12
Joined: Tue May 29, 2012 11:01 pm
Location: India

Re: No Internet in Virtual Box

Postby rielph on Fri Jun 15, 2012 2:36 am

Same thing on me, I have a newly installed Linux Mint 13 as host then I installer Oracle Virtualbox and installed Linux Mint 13 also as my guest OS. The host is connecting via on my wifi-wifi router I have no issues on browsing, but I can't access the internet from the guest OS, I can't ping the host OS, and the websites. I also tried using NAT and Bridged still I can't connect to the internet. Please help. Thank you
rielph
Level 1
Level 1
 
Posts: 1
Joined: Thu Jun 14, 2012 11:02 pm

Re: No Internet in Virtual Box

Postby Matti L on Fri Jun 29, 2012 2:48 pm

I think the reason connecting to the internet in VirtualBox doesn't work in Ubuntu 12.04 is described here:
https://forums.virtualbox.org/viewtopic.php?f=7&t=49519

Using NAT you can change the guest DNS to whatever you want (eg, Google Public DNS: 8.8.8.8 ) and you should be able to surf the net like usual again.
Matti L
Level 2
Level 2
 
Posts: 62
Joined: Sat Jun 04, 2011 9:30 am
Location: Finland

Re: No Internet in Virtual Box

Postby fallen.star on Mon Aug 13, 2012 8:45 pm

Hey, anyone?

I have no internet in virtualbox host mint 13 guest xp pro, wireless atheros card.

I have tried all the options in vbox's network; NAT, bridged, Internal, Host-only, unchecking the cable connected box; still nothing.

Bridged gives me the connected but limited or no connectivity bubble.

Please make it better :oops:
fallen.star
Level 1
Level 1
 
Posts: 4
Joined: Sun Aug 12, 2012 7:39 pm

Re: No Internet in Virtual Box

Postby cleobrag on Sat Sep 01, 2012 12:05 am

Found a Simple Solution to the Connectivity Problem in Virtualbox:
1. Set the Network setting to NAT in Virtualbox settings for WinXP.
2. After booting into the virtual XP machine, go to Properties of the Network Adapter
(right click on My Network Places, Properties, right click on Local Area Connection, Properties).
In the General tab, go to Properties of Internet Protocol (TCP/IP), and insert the following DNS server addresses:
208.67.222.222
208.67.220.220

(OpenDNS configuration)
3. Now full internet connectivity is established.
Simple yet efficient!
cleobrag
Level 1
Level 1
 
Posts: 1
Joined: Fri Aug 31, 2012 11:55 pm

Re: No Internet in Virtual Box

Postby JustDoIt on Mon Sep 17, 2012 2:53 pm

That's right!!

Just set as NAT and then in your virtual xp machine change dns to 208.67.222.222, 208.67.220.220 (or maybe you can use google dns 8.8.8.8 and 8.8.6.6) :D

Greetings from Peru!
JustDoIt
Level 1
Level 1
 
Posts: 5
Joined: Mon Sep 17, 2012 2:49 pm

Re: No Internet in Virtual Box

Postby RobertLM78 on Wed Sep 19, 2012 4:19 pm

For what it's worth, I'm having the same difficulty. Only started popping up with Maya. Lisa VM's let me connect no problem. The whole situation is really disappointing in the end, because I haven't been able to play around with different distros like I was able to do just a few months ago. :(
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 166
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: No Internet in Virtual Box

Postby Mechphisto on Thu Oct 25, 2012 7:29 pm

cleobrag wrote:Found a Simple Solution to the Connectivity Problem in Virtualbox:
1. Set the Network setting to NAT in Virtualbox settings for WinXP.
2. After booting into the virtual XP machine, go to Properties of the Network Adapter
(right click on My Network Places, Properties, right click on Local Area Connection, Properties).
In the General tab, go to Properties of Internet Protocol (TCP/IP), and insert the following DNS server addresses:
208.67.222.222
208.67.220.220

(OpenDNS configuration)
3. Now full internet connectivity is established.
Simple yet efficient!


Worked for me! Thanks!
Mechphisto
Level 1
Level 1
 
Posts: 16
Joined: Sat Jun 12, 2010 11:49 am

Re: No Internet in Virtual Box

Postby RobertLM78 on Fri Oct 26, 2012 4:19 pm

Mechphisto wrote:
cleobrag wrote:Found a Simple Solution to the Connectivity Problem in Virtualbox:
1. Set the Network setting to NAT in Virtualbox settings for WinXP.
2. After booting into the virtual XP machine, go to Properties of the Network Adapter
(right click on My Network Places, Properties, right click on Local Area Connection, Properties).
In the General tab, go to Properties of Internet Protocol (TCP/IP), and insert the following DNS server addresses:
208.67.222.222
208.67.220.220

(OpenDNS configuration)
3. Now full internet connectivity is established.
Simple yet efficient!


Worked for me! Thanks!

Too bad that's for a Window$ XP VM :(
Dell Dimension 4600i, ATI Rage 128, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Dell Latitude D400, Intel Graphics, 1 GB RAM, Linux Mint 13 32-bit, MATE edition
Gateway DX4860, Sapphire Radeon HD 5450, 6 GB RAM, Linux Mint 13 64-bit, MATE edition
User avatar
RobertLM78
Level 3
Level 3
 
Posts: 166
Joined: Sat Apr 28, 2012 4:19 am
Location: US

Re: No Internet in Virtual Box

Postby cwsnyder on Sat Oct 27, 2012 3:16 pm

You can change to Google DNS or OpenDNS servers in your network manager application in whatever Linux/BSD version you install as well as you can in Windows XP. If you have problems doing so in a particular VM, you need to get peculiar instructions from the exact version you are trying to install in a VM.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: No Internet in Virtual Box

Postby yonnie on Sun Jan 06, 2013 2:02 pm

I don't see a [solved] on this topic so I'm assuming this is still open.

After battling with this all day and now on second day with trying to get vista to run on virtual box in LM14, I found a youtube which was a great help (I closed the link and can't find it again, sorry). Turn off the OS running in VBox, select it, (in case you have more than 1), go to settings in the VB manager, choose network, choose bridged-mode instead of NAT, choose the adapter that has "desktop" in the description. Click on OK. Start the OS and it (network) should start working. Hope this helps a few people and saves some time.
You have your way. I have my way. As for the right way, the correct way, and the only way, it does not exist.”
- Friedrich Nietzsche
User avatar
yonnie
Level 2
Level 2
 
Posts: 80
Joined: Mon Jan 03, 2011 12:18 am

Re: No Internet in Virtual Box

Postby patey on Wed Jan 16, 2013 5:40 am

An alternative to manually entering DNS settings is to run this in a terminal:

Code: Select all
VBoxManage modifyvm "VM name" --natdnshostresolver1 on


This way it will work with whatever DNS your host is currently using.

Source:
https://forums.virtualbox.org/viewtopic.php?f=7&t=49519
http://www.virtualbox.org/manual/ch09.html#nat_host_resolver_proxy
patey
Level 1
Level 1
 
Posts: 14
Joined: Mon Jul 23, 2012 8:17 am

Re: No Internet in Virtual Box

Postby polymath257 on Sun Jan 27, 2013 8:13 pm

I'm on a Mint 14 host and Bodhi guest. The host has a wireless usb stick. Using NAT, the guest obtained a IP address in the 10.0.. range, but was unable to connect to the net.

Using the bridged option allowed connection.

But I wanted to find a way to use NAT and still connect. I was able to do this by using Network Manager and editing the wired connection of the guest.

Under IPv4 settings, choose either 'Manual' mode (if you want a static address) or choose 'Automatic (DHCP) addresses only'.

In either case, provide the DNS servers of choice (I chose the google servers). If necessary, disable then re-enable networking to force a change. This is essentially the same trick as above for Win VMs.

Now the guest connects through NAT.
polymath257
Level 1
Level 1
 
Posts: 2
Joined: Tue Feb 21, 2012 11:02 am

Re: No Internet in Virtual Box

Postby xc1427 on Mon Aug 12, 2013 8:28 pm

JustDoIt wrote:That's right!!
Just set as NAT and then in your virtual xp machine change dns to 208.67.222.222, 208.67.220.220 (or maybe you can use google dns 8.8.8.8 and 8.8.6.6) :D
Greetings from Peru!

WORKS FOR ME!
I have Mint 13 as host OS and Win 7 as guest OS. The host OS has internet access via a WIFI connection.
Networking Mode is NAT but didn't work. Changing DNS server lets win 7 (guest) obtain Internet access!
xc1427
Level 1
Level 1
 
Posts: 3
Joined: Mon Aug 12, 2013 4:48 am

Linux Mint is funded by ads and donations.
 

Return to Other networking topics

Who is online

Users browsing this forum: No registered users and 4 guests