LMDE and Wine 1.5.5

Write tutorials and howtos in here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

LMDE and Wine 1.5.5

Postby georage on Tue Sep 18, 2012 8:59 am

How to get a recent Wine unstable running on LMDE. This is for 32-bit installs.

1) sudo apt-get install libc6 libc6-dev

2) The ALSA library will need to be downloaded from this link
http://ftp.us.debian.org/debian/pool/ma ... 4_i386.deb

3) Right-click that ALSA deb when it downloads and install it with GDebi package installer.

4) Download all the i386 packages at http://dev.carbon-project.org/debian/wine-unstable/

5) Terminal to the download folder used in Step 4, then sudo dpkg -i libwine*.deb

6) sudo dpkg -i wine-bin-unstable*.deb

7) In your LMDE menu, go to Applications/System Tools/Wine Configuration. Wine will ask to install Gecko (for web browsers). You don’t need it for Windows games, but it will automatically install if you like.

8 ) Right click any Windows .exe, go to Open With, select Wine.

9) Enjoy!
Last edited by georage on Tue Sep 18, 2012 7:38 pm, edited 1 time in total.
georage
Level 1
Level 1
 
Posts: 2
Joined: Tue Sep 18, 2012 8:57 am

Linux Mint is funded by ads and donations.
 

Re: LMDE and Wine 1.5.5

Postby zerozero on Tue Sep 18, 2012 11:28 am

[moved here]

couple questions: :wink:
- is this on 32bit or 64bit?
- point 2: do you need 25-4 exactly?
Code: Select all
zerozero@wine ~ $ apt policy libasound2
libasound2:
  Installed: 1.0.25-3
  Candidate: 1.0.25-3
  Version table:
 *** 1.0.25-3 0
        500 http://mirror.rts-informatique.fr/linuxmint/debian/incoming/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE and Wine 1.5.5

Postby georage on Tue Sep 18, 2012 7:36 pm

This is for 32-bit. I will edit my initial post.

For 64-bit, I believe you can just download the 64-bit packages in Step 4 and download the 64-bit ALSA library in Step 2.

You should be OK with any recent libasound2, but I have not tested it. But post if you learn otherwise.
georage
Level 1
Level 1
 
Posts: 2
Joined: Tue Sep 18, 2012 8:57 am

Re: LMDE and Wine 1.5.5

Postby pinin on Mon Dec 03, 2012 10:59 am

Thank you, it worked on my amd64 too.
For real newbies like me, there's one step missing (easy to guess, but i missed it at first): 4) Download all the i386 (or amd64) packages AND source file.
Sounds dumb, but this is my first time on linux ;)
pinin
Level 1
Level 1
 
Posts: 1
Joined: Sun Dec 02, 2012 11:58 am


Return to Tutorials / Howtos

Who is online

Users browsing this forum: No registered users and 2 guests