UPDATE PACK 5 FEEDBACK THREAD

deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb-src http://debian.linuxmint.com/incoming testing main contrib non-free
Forum rules
Before you post please read this

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Trapper on Thu Sep 20, 2012 10:50 am

Monsta wrote:I've managed to somewhat improve font quality with a simple script which I've posted here. Need a few testers now to confirm it works not only for me. :)


I reverted back to my original /etc/fonts, ensured that it still gave me poor rendering, ran your script and now the fonts render the same as they did when I replaced /etc/fonts with the ubuntu package. Decent rendering. I have Subpixel enabled in my smooth font rendering settings and Slight enabled in Hinting settings of Appearance Preferences/Fonts. Works to my liking. I'll probably just keep it this way.

This sure does make me wonder why Debian can't just up a do this rather than keep settling for crap font display for years. ???????

I appreciate your little script and I get to keep 2.9.0-6 by using it. If I run into any difficulties I will let you know. As of right now, it's just fine.
Trapper
Level 3
Level 3
 
Posts: 183
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Linux Mint is funded by ads and donations.
 

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Trapper on Thu Sep 20, 2012 11:05 am

LexMK wrote:I have the regular LMDE, using the default repository. Today the updater tried to update 1.301 packages, install 150 new ones and remove 21, yet the UP5 hasn't been released yet. What's happening?


Update Pack 5 2012.09.17
Trapper
Level 3
Level 3
 
Posts: 183
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby zerozero on Thu Sep 20, 2012 11:26 am

clem wrote:The new ones can certainly be used, but the problem with pinning them is that it makes it hard for people to follow testing or that it can create problems when upgrading.

also compiling is almost impossible with the pinning and the patched lib. most of the programs we try to compile depend on upstream libcairo2 and/or fontconfig.

edit: this topic viewtopic.php?f=201&t=94378&hilit=+font#p544283 has a couple ideas about font rendering.
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby LexMK on Thu Sep 20, 2012 11:58 am

Trapper wrote:
LexMK wrote:I have the regular LMDE, using the default repository. Today the updater tried to update 1.301 packages, install 150 new ones and remove 21, yet the UP5 hasn't been released yet. What's happening?


Update Pack 5 2012.09.17


I thought it wasn't released yet. Should check better next time.
They usually post something on http://www.linuxmint.com/start/debian/ when a new version rolls out, this time they didn't. Or they're waiting the new .iso to post?
Asus eee 1225B AMD E450 with Radeon 6320
User avatar
LexMK
Level 2
Level 2
 
Posts: 50
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Monsta on Thu Sep 20, 2012 12:02 pm

LexMK wrote:Today the updater tried to update 1.301 packages, install 150 new ones and remove 21, yet the UP5 hasn't been released yet.

Actually, it has been released. It's just the main linuxmint.com page that didn't get the last two posts from blog.linuxmint.com for some reason. :?
So check http://blog.linuxmint.com/?p=2170 - this is the release announcement. :)

zerozero wrote:this topic viewtopic.php?f=201&t=94378&hilit=+font#p544283 has a couple ideas about font rendering.

Wow... it seems like I've reinvented the wheel while doing my little font research :lol: But I'm glad to see that the filelist is the same there, it makes me think I haven't missed anything.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Trapper on Thu Sep 20, 2012 12:08 pm

LexMK wrote:They usually post something on http://www.linuxmint.com/start/debian/ when a new version rolls out, this time they didn't. Or they're waiting the new .iso to post?


'Somewhere', I read yesterday where it was going to be a while before an ISO would be available. There was even a comment that it 'maybe' would not even be until UP6, dependent on what's happening there. I 'think' that's sort of what I read and I 'think' it was Clem speaking but I am really not sure, so don't take stock in that. I cannot remember if that was somewhere in this thread or another one.
Trapper
Level 3
Level 3
 
Posts: 183
Joined: Sat Dec 03, 2011 12:21 pm
Location: Sebring, Florida USA

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby zerozero on Thu Sep 20, 2012 12:14 pm

Monsta wrote:Wow... it seems like I've reinvented the wheel while doing my little font research :lol: But I'm glad to see that the filelist is the same there, it makes me think I haven't missed anything.

so taking from that topic and the confirmation of your research :wink: the secret is
The difference with the old /etc/fonts folder and the new one are five links in /etc/fonts/conf.d/ pointing to ../conf.avant/ it's these links:

lrwxrwxrwx 1 root root 31 Feb 19 20:57 10-antialias.conf -> ../conf.avail/10-antialias.conf
lrwxrwxrwx 1 root root 29 Feb 19 20:57 10-hinting.conf -> ../conf.avail/10-hinting.conf
lrwxrwxrwx 1 root root 36 Feb 19 20:57 10-hinting-slight.conf -> ../conf.avail/10-hinting-slight.conf
lrwxrwxrwx 1 root root 43 Feb 19 20:57 11-lcd-filter-lcddefault.conf -> ../conf.avail/11-lcd-filter-lcddefault.conf
lrwxrwxrwx 1 root root 42 Feb 19 20:57 53-monospace-lcd-filter.conf -> ../conf.avail/53-monospace-lcd-filter.conf
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby ptruchon on Thu Sep 20, 2012 1:46 pm

sobrus wrote: I can see fglrx 12.6 in repository already! You're really fast :) Thank you!


Oops... Not working for me. I'm stuck in CLI mode now. Here is my Xorg.0.log file:

Code: Select all
[   492.284]
X.Org X Server 1.12.1.902 (1.12.2 RC 2)
Release Date: 2012-05-19
[   492.284] X Protocol Version 11, Revision 0
[   492.284] Build Operating System: Linux 3.2.0-2-amd64 x86_64 Debian
[   492.284] Current Operating System: Linux asus-f6v-lmde 3.2.0-3-amd64 #1 SMP Thu Jun 28 09:07:26 UTC 2012 x86_64
[   492.284] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-3-amd64 root=UUID=552c8e3a-66a7-468f-8eaf-b5cc54aea0af ro quiet
[   492.284] Build Date: 20 May 2012  08:57:17AM
[   492.284] xorg-server 2:1.12.1.902-1 (Cyril Brulebois <kibi@debian.org>)
[   492.284] Current version of pixman: 0.26.0
[   492.285]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   492.285] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   492.285] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Sep 20 10:22:29 2012
[   492.285] (==) Using config file: "/etc/X11/xorg.conf"
[   492.285] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   492.285] (==) ServerLayout "aticonfig Layout"
[   492.285] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   492.285] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   492.285] (**) |   |-->Device "aticonfig-Device[0]-0"
[   492.285] (==) Automatically adding devices
[   492.285] (==) Automatically enabling devices
[   492.285] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[   492.285]    Entry deleted from font path.
[   492.285] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[   492.285]    Entry deleted from font path.
[   492.285] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[   492.285]    Entry deleted from font path.
[   492.285] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[   492.285]    Entry deleted from font path.
[   492.285] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[   492.285]    Entry deleted from font path.
[   492.285] (==) FontPath set to:
   /usr/share/fonts/X11/misc,
   /usr/share/fonts/X11/Type1,
   /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
   built-ins
[   492.285] (==) ModulePath set to "/usr/lib/xorg/modules"
[   492.285] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[   492.285] (II) Loader magic: 0x7f064f45cae0
[   492.285] (II) Module ABI versions:
[   492.285]    X.Org ANSI C Emulation: 0.4
[   492.285]    X.Org Video Driver: 12.0
[   492.285]    X.Org XInput driver : 16.0
[   492.285]    X.Org Server Extension : 6.0
[   492.286] (--) PCI:*(0:1:0:0) 1002:95c4:1043:19e2 rev 0, Mem @ 0xd0000000/268435456, 0xfdef0000/65536, I/O @ 0x0000c000/256, BIOS @ 0x????????/131072
[   492.286] (II) Open ACPI successful (/var/run/acpid.socket)
[   492.286] (II) "extmod" will be loaded by default.
[   492.286] (II) "dbe" will be loaded by default.
[   492.286] (II) "glx" will be loaded by default.
[   492.286] (II) "record" will be loaded by default.
[   492.286] (II) "dri" will be loaded by default.
[   492.286] (II) "dri2" will be loaded by default.
[   492.286] (II) LoadModule: "extmod"
[   492.287] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   492.287] (II) Module extmod: vendor="X.Org Foundation"
[   492.287]    compiled for 1.12.1.902, module version = 1.0.0
[   492.287]    Module class: X.Org Server Extension
[   492.287]    ABI class: X.Org Server Extension, version 6.0
[   492.287] (II) Loading extension SELinux
[   492.287] (II) Loading extension MIT-SCREEN-SAVER
[   492.287] (II) Loading extension XFree86-VidModeExtension
[   492.287] (II) Loading extension XFree86-DGA
[   492.287] (II) Loading extension DPMS
[   492.287] (II) Loading extension XVideo
[   492.287] (II) Loading extension XVideo-MotionCompensation
[   492.287] (II) Loading extension X-Resource
[   492.287] (II) LoadModule: "dbe"
[   492.287] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   492.287] (II) Module dbe: vendor="X.Org Foundation"
[   492.287]    compiled for 1.12.1.902, module version = 1.0.0
[   492.287]    Module class: X.Org Server Extension
[   492.287]    ABI class: X.Org Server Extension, version 6.0
[   492.287] (II) Loading extension DOUBLE-BUFFER
[   492.287] (II) LoadModule: "glx"
[   492.287] (II) Loading /usr/lib/xorg/modules/linux/libglx.so
[   492.287] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   492.287]    compiled for 6.9.0, module version = 1.0.0
[   492.288] (II) Loading extension GLX
[   492.288] (II) LoadModule: "record"
[   492.288] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   492.288] (II) Module record: vendor="X.Org Foundation"
[   492.288]    compiled for 1.12.1.902, module version = 1.13.0
[   492.288]    Module class: X.Org Server Extension
[   492.288]    ABI class: X.Org Server Extension, version 6.0
[   492.288] (II) Loading extension RECORD
[   492.288] (II) LoadModule: "dri"
[   492.288] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   492.288] (II) Module dri: vendor="X.Org Foundation"
[   492.288]    compiled for 1.12.1.902, module version = 1.0.0
[   492.288]    ABI class: X.Org Server Extension, version 6.0
[   492.288] (II) Loading extension XFree86-DRI
[   492.288] (II) LoadModule: "dri2"
[   492.288] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   492.288] (II) Module dri2: vendor="X.Org Foundation"
[   492.288]    compiled for 1.12.1.902, module version = 1.2.0
[   492.288]    ABI class: X.Org Server Extension, version 6.0
[   492.288] (II) Loading extension DRI2
[   492.288] (II) LoadModule: "fglrx"
[   492.289] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[   492.304] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[   492.304]    compiled for 1.4.99.906, module version = 8.98.2
[   492.304]    Module class: X.Org Video Driver
[   492.304] (II) Loading sub module "fglrxdrm"
[   492.304] (II) LoadModule: "fglrxdrm"
[   492.304] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   492.305] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   492.305]    compiled for 1.4.99.906, module version = 8.98.2
[   492.305] (II) AMD Proprietary Linux Driver Version Identifier:8.98.2
[   492.305] (II) AMD Proprietary Linux Driver Release Identifier: 8.982.13                             
[   492.305] (II) AMD Proprietary Linux Driver Build Date: Jul 19 2012 20:59:44
[   492.305] (++) using VT number 7

[   492.310] (WW) Falling back to old probe method for fglrx
[   492.315] (II) Loading PCS database from /etc/ati/amdpcsdb
[   492.315] (EE) No supported AMD display adapters were found
[   492.315] (EE) No devices detected.
[   492.315]
Fatal server error:
[   492.315] no screens found
[   492.315]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   492.315] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   492.315]


On the partition I didn't update yet, I see these lines instead of "No supported AMD display..."
Code: Select all
[   492.310] (WW) Falling back to old probe method for fglrx
[          ] (II) Loading PCS database from /etc/ati/amdpcsdb
...


I tried to reinstall the drivers (the way that I usually would re-install them. See http://forums.linuxmint.com/viewtopic.php?f=187&t=109005&start=80#p617784)

Not sure where to go from there...
ptruchon
Level 1
Level 1
 
Posts: 22
Joined: Sun Nov 20, 2011 10:25 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby franburstall on Thu Sep 20, 2012 7:03 pm

I have also experienced font problems after UP5, mainly in chrome. These were solved after following this post. Long story short: put something in ~/.fonts.conf to adjust hinting and anti-aliasing. After restarting the session, everything is beautiful again.

Everything feels a little faster post UP5 as well...
franburstall
Level 1
Level 1
 
Posts: 1
Joined: Sat Oct 01, 2011 7:17 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Monsta on Fri Sep 21, 2012 4:52 am

Well, now that the font issue is (almost?) resolved, I'd like to point out that a minor issue with attempting to mount the same tmpfs twice is still present in UP5.

EDIT: It may have something to do with bug 679523 which has been fixed only in the end of June. The updated package got to Testing only on the 1st of September (see the news section here), that's why we still have 2.88dsf-22.1 here in LMDE. Will probably have to wait for UP6. :)
Last edited by Monsta on Fri Sep 21, 2012 5:51 am, edited 1 time in total.
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby LexMK on Fri Sep 21, 2012 5:42 am

http://www.freeimagehosting.net/a543y

I just finished installing UP5, and this happened. There are only 2436 packages in the software manager and the window themes are all messed up. Also there's no reduce button, just the close window one. What happened? And how can I fix this?
Asus eee 1225B AMD E450 with Radeon 6320
User avatar
LexMK
Level 2
Level 2
 
Posts: 50
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby killer de bug on Fri Sep 21, 2012 5:55 am

LexMK wrote:http://www.freeimagehosting.net/a543y

I just finished installing UP5, and this happened. There are only 2436 packages in the software manager and the window themes are all messed up. Also there's no reduce button, just the close window one. What happened? And how can I fix this?



Did you install mint-meta-debian-cinnamon after upgrading ?

If not, do it.

And check that you have uninstalled mint-x-theme and installed mint-themes
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1860
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby sobrus on Fri Sep 21, 2012 6:14 am

zerozero wrote:
Monsta wrote:Wow... it seems like I've reinvented the wheel while doing my little font research :lol: But I'm glad to see that the filelist is the same there, it makes me think I haven't missed anything.

so taking from that topic and the confirmation of your research :wink: the secret is
The difference with the old /etc/fonts folder and the new one are five links in /etc/fonts/conf.d/ pointing to ../conf.avant/ it's these links:

lrwxrwxrwx 1 root root 31 Feb 19 20:57 10-antialias.conf -> ../conf.avail/10-antialias.conf
lrwxrwxrwx 1 root root 29 Feb 19 20:57 10-hinting.conf -> ../conf.avail/10-hinting.conf
lrwxrwxrwx 1 root root 36 Feb 19 20:57 10-hinting-slight.conf -> ../conf.avail/10-hinting-slight.conf
lrwxrwxrwx 1 root root 43 Feb 19 20:57 11-lcd-filter-lcddefault.conf -> ../conf.avail/11-lcd-filter-lcddefault.conf
lrwxrwxrwx 1 root root 42 Feb 19 20:57 53-monospace-lcd-filter.conf -> ../conf.avail/53-monospace-lcd-filter.conf


If solution is that simple, then it's not a problem at all, but I wonder if LMDE team could make small additional package with such files/script to create symlinks automatically every update, or add it to some existing lmde-specific package.
Last edited by sobrus on Fri Sep 21, 2012 6:17 am, edited 2 times in total.
sobrus
Level 2
Level 2
 
Posts: 87
Joined: Thu Aug 30, 2012 1:36 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby LexMK on Fri Sep 21, 2012 6:14 am

killer de bug wrote:
LexMK wrote:http://www.freeimagehosting.net/a543y

I just finished installing UP5, and this happened. There are only 2436 packages in the software manager and the window themes are all messed up. Also there's no reduce button, just the close window one. What happened? And how can I fix this?



Did you install mint-meta-debian-cinnamon after upgrading ?

If not, do it.

And check that you have uninstalled mint-x-theme and installed mint-themes


When I tried to install mint-meta-debian-cinnamon, this happened (Translated from Italian):

Code: Select all
Some packages cannot be installed. This means that
an impossible situation was requested or, if a distribution still in development
is being used, that some of the requested packages
are not created yet or were removed from Incoming.
The following information may help to solve the problem:


The following packages have unsatisfied dependencies:
 mint-meta-debian-cinnamon : Dipende: aptoncd but cannot be installed
                             Dipende: ttf-liberation but cannot be installed
                             Dipende: xdg-user-dirs-gtk but cannot be installed
                             Dipende: gnome-session-fallback but cannot be installed
                             Dipende: gir1.2-gnomedesktop-3.0 but cannot be installed
E: Impossible fix this problem, there are blocked damaged packages.
Asus eee 1225B AMD E450 with Radeon 6320
User avatar
LexMK
Level 2
Level 2
 
Posts: 50
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby killer de bug on Fri Sep 21, 2012 6:32 am

Can you please show me you sources.list ?

Inxi -R
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1860
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby LexMK on Fri Sep 21, 2012 6:35 am

killer de bug wrote:Can you please show me you sources.list ?

Inxi -R


Code: Select all
deb http://packages.linuxmint.com debian main upstream import
deb http://packages.linuxmint.com/linuxmint/debian/latest testing main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/security testing/updates main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/multimedia testing main non-free


....and that's strange because during the installation it asked me to change mirror, but it seems it didn't happen. That may be the cause of the reduced package number in the Software Manager too.
Asus eee 1225B AMD E450 with Radeon 6320
User avatar
LexMK
Level 2
Level 2
 
Posts: 50
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby killer de bug on Fri Sep 21, 2012 6:41 am

LexMK wrote:
killer de bug wrote:Can you please show me you sources.list ?

Inxi -R


Code: Select all
deb http://packages.linuxmint.com debian main upstream import
deb http://packages.linuxmint.com/linuxmint/debian/latest testing main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/security testing/updates main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/multimedia testing main non-free


....and that's strange because during the installation it asked me to change mirror, but it seems it didn't happen. That may be the cause of the reduced package number in the Software Manager too.


deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

Isn't this supposed to be the good ones ? I have a doubt and I can't access to my sources.list right now !
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1860
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby Monsta on Fri Sep 21, 2012 6:45 am

LexMK wrote:
Code: Select all
deb http://packages.linuxmint.com debian main upstream import
deb http://packages.linuxmint.com/linuxmint/debian/latest testing main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/security testing/updates main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/multimedia testing main non-free


Now I wonder how you even managed to get 1301 updates because 3 of 4 lines should yield error 404. The correct version is:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free


LexMK wrote:....and that's strange because during the installation it asked me to change mirror, but it seems it didn't happen.

That's not a problem, just run mint-choose-debian-mirror for another try. Actually, you'll probably have to do it anyway since the main mirror is still overloaded :D

killer de bug wrote:I have a doubt and I can't access to my sources.list right now !

Thanks to zerozero, we have this useful thread where you can find the right sources list. :)
Monsta
Level 8
Level 8
 
Posts: 2494
Joined: Fri Aug 19, 2011 3:46 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby LexMK on Fri Sep 21, 2012 6:59 am

Monsta wrote:
LexMK wrote:
Code: Select all
deb http://packages.linuxmint.com debian main upstream import
deb http://packages.linuxmint.com/linuxmint/debian/latest testing main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/security testing/updates main contrib non-free
deb http://packages.linuxmint.com/linuxmint/debian/latest/multimedia testing main non-free


Now I wonder how you even managed to get 1301 updates because 3 of 4 lines should yield error 404. The correct version is:
Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free


LexMK wrote:....and that's strange because during the installation it asked me to change mirror, but it seems it didn't happen.

That's not a problem, just run mint-choose-debian-mirror for another try. Actually, you'll probably have to do it anyway since the main mirror is still overloaded :D

killer de bug wrote:I have a doubt and I can't access to my sources.list right now !

Thanks to zerozero, we have this useful thread where you can find the right sources list. :)


Doing that fixed the problem, and right now it's installing the meta-cinnamon files. All 38.000+ packages are there again.
Still I wonder why it didn't change the mirror during the installation.
The one I choose then was http://mirror.rts-informatique.fr/linuxmint/debian, but now I changed it to http://debian.lth.se/lmde - 106Kbps
Asus eee 1225B AMD E450 with Radeon 6320
User avatar
LexMK
Level 2
Level 2
 
Posts: 50
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Postby killer de bug on Fri Sep 21, 2012 8:24 am

LexMK wrote:Doing that fixed the problem, and right now it's installing the meta-cinnamon files. All 38.000+ packages are there again.
Still I wonder why it didn't change the mirror during the installation.
The one I choose then was http://mirror.rts-informatique.fr/linuxmint/debian, but now I changed it to http://debian.lth.se/lmde - 106Kbps



You should probably check that the upgrade went fine despite your wrong sources.list.

Code: Select all
apt-get dist-upgrade
If I have seen further it is by standing on the shoulders of giants. [Isaac Newton]
User avatar
killer de bug
Level 7
Level 7
 
Posts: 1860
Joined: Tue Jul 08, 2008 1:49 pm
Location: Austria

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Linux Mint Debian Incoming

Who is online

Users browsing this forum: No registered users and 2 guests