Mint-meta-debian-mate package missing (SOLVED)

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Mint-meta-debian-mate package missing (SOLVED)

Postby Fornhamfred on Sat Sep 22, 2012 3:17 am

I have just updated a friends machine with Update 5 but found that the mint-meta package has not been downloaded. I reloaded synaptic but the package is not available.

Will this cause any problems and if so how do I get the package please.
Last edited by Fornhamfred on Mon Sep 24, 2012 2:00 pm, edited 1 time in total.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Linux Mint is funded by ads and donations.
 

Re: Mint-meta-debian-mate package missing

Postby DeJooL on Sat Sep 22, 2012 5:37 am

DeJooL
Level 1
Level 1
 
Posts: 1
Joined: Tue Sep 18, 2012 6:28 am

Re: Mint-meta-debian-mate package missing

Postby Fornhamfred on Sat Sep 22, 2012 7:54 am

Thanks

I have noted that you should install the meta pack and have tried but it is not downloaded into apt from the repository. My question is why not and if I cannot install it will it cause any problems?
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Mint-meta-debian-mate package missing

Postby zerozero on Sat Sep 22, 2012 11:51 am

can you please post the output of
Code: Select all
inxi -r
and
Code: Select all
apt policy mint-meta-debian-mate

or a quick search in synaptic (assuming the repos are correct) for mint meta should show this
Image
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mint-meta-debian-mate package missing

Postby mockturtl on Sat Sep 22, 2012 12:01 pm

mint-meta-debian-mate (and -cinnamon) has an unresolvable pidgin-facebook dependency.

I think it will be fixed soon. In the meantime, you can install sid's package (32-bit 64-bit) and mint-meta-debian-mate will install normally.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: Mint-meta-debian-mate package missing

Postby Fornhamfred on Sat Sep 22, 2012 12:08 pm

The outputs are

epos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.lth.se/lmde/latest testing main contrib non-free
deb http://debian.lth.se/lmde/latest/security testing/updates main contrib non-free
deb http://debian.lth.se/lmde/latest/multimedia testing main non-free
Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
deb http://dl.google.com/linux/chrome/deb/ stable main

mint-meta-debian-mate:
Installed: (none)
Candidate: 2012.09.14
Version table:
2012.09.14 0
700 http://packages.linuxmint.com/ debian/main i386 Packages

There is not mint-meta-debian-mate package listed in synaptic.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Mint-meta-debian-mate package missing

Postby zerozero on Sat Sep 22, 2012 12:10 pm

yep, as opposed to that other system where pidgin-facebook came from UP4, here i can't install the meta-packages either
Code: Select all
amadeu@amadeu ~ $ apt install mint-meta-debian-cinnamon
[sudo] password for amadeu:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mint-meta-debian-cinnamon : Depends: pidgin-facebookchat but it is not installable
E: Unable to correct problems, you have held broken packages.
amadeu@amadeu ~ $
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mint-meta-debian-mate package missing

Postby zerozero on Sat Sep 22, 2012 12:43 pm

Fornhamfred wrote:[...]
epos: Active apt sources in file: /etc/apt/sources.list
deb http://packages.linuxmint.com/ debian main upstream import
[...]
correct

Fornhamfred wrote:[...]
mint-meta-debian-mate:
Installed: (none)
Candidate: 2012.09.14
Version table:
2012.09.14 0
[...]
it's there

Fornhamfred wrote:There is not mint-meta-debian-mate package listed in synaptic.
so synaptic is broken, look closer please :D
zerozero
Level 16
Level 16
 
Posts: 6471
Joined: Tue Jul 07, 2009 2:29 pm

Re: Mint-meta-debian-mate package missing

Postby Monsta on Mon Sep 24, 2012 9:05 am

Guys... can anyone please explain the logic of two metapackages for DEs depending on some stuff for a social network? :shock: :D

(not to mention that the needed package is not even in the same Update Pack)
Monsta
Level 8
Level 8
 
Posts: 2389
Joined: Fri Aug 19, 2011 3:46 am

Re: Mint-meta-debian-mate package missing

Postby mockturtl on Mon Sep 24, 2012 1:57 pm

Monsta wrote:Guys... can anyone please explain the logic of two metapackages for DEs depending on some stuff for a social network? :shock: :D
Pidgin should support popular chat servers (skype, twitter, ...). Facebook might rub against DFSG, even though it's an open protocol.

You don't seem to need the pidgin-facebookchat package for pidgin to connect to a facebook account. I think the dependency can be dropped without loss of functionality.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 437
Joined: Sat Oct 09, 2010 8:51 pm

Re: Mint-meta-debian-mate package missing

Postby Fornhamfred on Mon Sep 24, 2012 2:00 pm

Zero

I have just managed to connect to my friends machine and apt showed no broken packages. I did however once again do a reload and the package appeared this time.

It has now been installed and all is fine.

Out of interest, i have installed LMDE mate on another of my machines and after the first update the package did not show in synaptic. However after another reload it appeared. It seems as though this package is being held back. I am using linuxmint-fr and my friends machine is using Italy.

Thanks for the help.
Fornhamfred
Level 6
Level 6
 
Posts: 1134
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Mint-meta-debian-mate package missing

Postby Monsta on Tue Sep 25, 2012 10:38 am

mockturtl wrote:Pidgin should support popular chat servers (skype, twitter, ...). Facebook might rub against DFSG, even though it's an open protocol.

Oh BTW, mint-meta-debian-xfce doesn't even depend on pidgin (not to mention the facebook chat). How come? :)
Monsta
Level 8
Level 8
 
Posts: 2389
Joined: Fri Aug 19, 2011 3:46 am

Re: Mint-meta-debian-mate package missing (SOLVED)

Postby Monsta on Fri Dec 21, 2012 4:18 am

Looks like that facebookchat dependency is still there in UP6 (mint-meta-debian-mate 2012.12.11.1).
Monsta
Level 8
Level 8
 
Posts: 2389
Joined: Fri Aug 19, 2011 3:46 am

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 2 guests