LMDE BREAKAGES - tracking TESTING

Post your update and upgrade related errors here
Forum rules
Before you post please read this

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby yoav on Sat Sep 22, 2012 3:51 pm

Thanks!
yoav
Level 1
Level 1
 
Posts: 7
Joined: Thu Sep 20, 2012 10:31 am

Linux Mint is funded by ads and donations.
 

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby narendra.d on Wed Sep 26, 2012 9:32 pm

I needs some help.

My system is triple boot with LMDE (tracking Testing and installed ages ago) along with Crunchbang Waldorf and WinXP.

The issue is with the time setting going haywire every so often almost on every reboot. The RTC clock is set to UTC and the WinXP has its registry edited to read RTC as UTC. Auto update of time on WinXP is disabled. My time zone is Asia/Kolkatta. Crunchbang displays the time right always and does have ntp installed.

Its LMDE that is displaying the time wrong at almost every reboot. And writes the wrong time to the RTC. I have ntp installed, so the time corrects itself when connected to the net. I don't understand where the system is going wrong. I have tried dpkg-reconfigure tzdata, hwclock --systohc --utc and tried deleting the /etc/adjtime file as well, but to no effect.

My LMDE had most Mint stuff removed quite a while back and then some were reinstalled including mint-update and the pin priority in the /etc/preferences file was 500 for both mint and debian repos. Now everything is as per the original setting as it were meant to be for LMDE tracking Debian Testing. I use Gnome 3 and Gnome Classic if it matters, but have openbox installed as well but rarely use.. Are there multiple packages that are controlling time setting in my system because of the above.

How do i correct this? I would like to correct this in LMDE as thats where any goof up from my side might have happened and also because its the primary OS.. Is it possible other OS's are responsible? If yes, what to do and where?
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby mockturtl on Thu Oct 04, 2012 10:04 pm

apt-listbugs catches #689519

Subject: libapt-pkg4.12: SIGSEGV when used by apt-get or aptitude
Date: Wed, 3 Oct 2012 15:55:48 +0200


I don't know about you, but I don't like "segfault" and "APT" in the same sentence.
Code: Select all
$ sudo aptitude hold libapt-pkg4.12

The current version has been running a few days on my other laptop, and I haven't noticed trouble, so maybe it's nothing. :?:
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Thu Oct 04, 2012 10:27 pm

:shock: i already have the bugger (but it seems that is behaving well so far)
Code: Select all
zerozero@deb-kde ~/Documents $ sudo apt-get install kde-icons-crystal
[sudo] password for zerozero:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libcrypto++9 librados2 librbd1
Use 'apt-get autoremove' to remove them.
Recommended packages:
  kdebase
The following NEW packages will be installed:
  kde-icons-crystal
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,558 kB of archives.
After this operation, 3,490 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ testing/main kde-icons-crystal all 3.7-3 [1,558 kB]
Fetched 1,558 kB in 1s (813 kB/s)             
Selecting previously unselected package kde-icons-crystal.
(Reading database ... 216943 files and directories currently installed.)
Unpacking kde-icons-crystal (from .../kde-icons-crystal_3.7-3_all.deb) ...
Setting up kde-icons-crystal (3.7-3) ...
zerozero@deb-kde ~/Documents $ apt policy libapt-pkg4.12
libapt-pkg4.12:
  Installed: 0.9.7.5
  Candidate: 0.9.7.5
  Version table:
 *** 0.9.7.5 0
        500 http://ftp.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby jackmetal on Fri Oct 05, 2012 3:24 am

Narendra.d, I've actually noticed the same issue. I boot into Windows 7 and the time is correct, I boot back into LMDE and the time is off (by 4 hours for me, every time - my TZ is EST). Luckily, I don't boot into Windows very often, so I don't really think about it but your post reminded me. ;-)

I'd like to resolve it too. Hopefully one of the LMDE gurus can point us in a direction to help solve it. I'll let you know if I run across anything.


narendra.d wrote:I needs some help.

My system is triple boot with LMDE (tracking Testing and installed ages ago) along with Crunchbang Waldorf and WinXP.

The issue is with the time setting going haywire every so often almost on every reboot. The RTC clock is set to UTC and the WinXP has its registry edited to read RTC as UTC. Auto update of time on WinXP is disabled. My time zone is Asia/Kolkatta. Crunchbang displays the time right always and does have ntp installed.

Its LMDE that is displaying the time wrong at almost every reboot. And writes the wrong time to the RTC. I have ntp installed, so the time corrects itself when connected to the net. I don't understand where the system is going wrong. I have tried dpkg-reconfigure tzdata, hwclock --systohc --utc and tried deleting the /etc/adjtime file as well, but to no effect.

My LMDE had most Mint stuff removed quite a while back and then some were reinstalled including mint-update and the pin priority in the /etc/preferences file was 500 for both mint and debian repos. Now everything is as per the original setting as it were meant to be for LMDE tracking Debian Testing. I use Gnome 3 and Gnome Classic if it matters, but have openbox installed as well but rarely use.. Are there multiple packages that are controlling time setting in my system because of the above.

How do i correct this? I would like to correct this in LMDE as thats where any goof up from my side might have happened and also because its the primary OS.. Is it possible other OS's are responsible? If yes, what to do and where?
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby mockturtl on Fri Oct 05, 2012 4:18 pm

jackmetal wrote:Narendra.d, I've actually noticed the same issue. I boot into Windows 7 and the time is correct, I boot back into LMDE and the time is off (by 4 hours for me, every time - my TZ is EST). Luckily, I don't boot into Windows very often, so I don't really think about it but your post reminded me. ;-)
I don't quite remember how I fixed it. I fiddled with the BIOS clock, changing from local time to GMT, or the other way around.

Installing ntp and opening port 123 in the firewall fixed my GNOME panel time.

With Windows displaying the wrong time, a manual NTP sync worked, so I set a task to trigger it at startup.
Image
User avatar
mockturtl
Level 4
Level 4
 
Posts: 442
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby voss749 on Fri Oct 05, 2012 9:19 pm

BostonPeng wrote:Qapla'! It turned out the phrase that paid was
Code: Select all
sudo apt-get install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig --reinstall
I can't tell y'all how nice it is to be back up and running with the GUI.

Note to self: Stop upgrading with sudo apt-fast dist-upgrade. Apt-get seems to work more reliably, especially with the testing repos.


THANK YOU! You saved my ass! I had the same problem. Im guessing for future reference to reinstall the nvidia drivers before I reboot after any new kernel install.
voss749
Level 2
Level 2
 
Posts: 54
Joined: Tue Feb 23, 2010 12:10 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby narendra.d on Sat Oct 06, 2012 3:12 am

@jackmetal and @mockturti: Thanks for responding.
My BIOS clock is already set to UTC. Both LMDE and Crunchbang have ntp installed, but I only can see LMDE writing the time to the BIOS clock during shutdown, and still get the time wrong at every boot. The time is off by varying degrees, from more than 5 1/2 hours (I am +5 1/2 hts from UTC) to about a Hour and half. I am thinking its LMDE that needs to be fixed. I did try deleting the /etc/adjtime file as well, thinking that it might be the cause, but didnt help.

Any more help from the experts on this forum please.
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Sat Oct 06, 2012 9:15 am

voss749 wrote:
BostonPeng wrote:Qapla'! It turned out the phrase that paid was
Code: Select all
sudo apt-get install nvidia-kernel-dkms nvidia-glx build-essential nvidia-settings nvidia-xconfig --reinstall
I can't tell y'all how nice it is to be back up and running with the GUI.

Note to self: Stop upgrading with sudo apt-fast dist-upgrade. Apt-get seems to work more reliably, especially with the testing repos.


THANK YOU! You saved my ass! I had the same problem. Im guessing for future reference to reinstall the nvidia drivers before I reboot after any new kernel install.

That's a lesson I learned the hard way. Glad I could help you solve your issue.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby squeezy on Sat Oct 06, 2012 9:26 am

voss749 wrote:THANK YOU! You saved my ass! I had the same problem. Im guessing for future reference to reinstall the nvidia drivers before I reboot after any new kernel install.


Now that you've got the driver installed using dkms, it'll be rebuilt automatically on kernel upgrades. dkms = Dynamic Kernel Module Support :D
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby voss749 on Sat Oct 06, 2012 5:53 pm

squeezy wrote:
voss749 wrote:THANK YOU! You saved my ass! I had the same problem. Im guessing for future reference to reinstall the nvidia drivers before I reboot after any new kernel install.


Now that you've got the driver installed using dkms, it'll be rebuilt automatically on kernel upgrades. dkms = Dynamic Kernel Module Support :D


I had DKMS, I still had to rerun it.
voss749
Level 2
Level 2
 
Posts: 54
Joined: Tue Feb 23, 2010 12:10 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby BostonPeng on Sun Oct 07, 2012 8:52 am

voss749 wrote:
squeezy wrote:
voss749 wrote:THANK YOU! You saved my ass! I had the same problem. Im guessing for future reference to reinstall the nvidia drivers before I reboot after any new kernel install.


Now that you've got the driver installed using dkms, it'll be rebuilt automatically on kernel upgrades. dkms = Dynamic Kernel Module Support :D


I had DKMS, I still had to rerun it.

I had the same issue some time back, which is why I make a point to always manually update the drivers after updating my kernel and before rebooting.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
User avatar
BostonPeng
Level 5
Level 5
 
Posts: 619
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Chris M on Tue Oct 09, 2012 12:27 pm

narendra.d wrote:@jackmetal and @mockturti: Thanks for responding.
My BIOS clock is already set to UTC. Both LMDE and Crunchbang have ntp installed, but I only can see LMDE writing the time to the BIOS clock during shutdown, and still get the time wrong at every boot. The time is off by varying degrees, from more than 5 1/2 hours (I am +5 1/2 hts from UTC) to about a Hour and half. I am thinking its LMDE that needs to be fixed. I did try deleting the /etc/adjtime file as well, thinking that it might be the cause, but didnt help.

Any more help from the experts on this forum please.


I'm not sure if this excellent thread got buried or not, but this was a real nice one: Hacking LMDE

HTD wrote:Wait, something's wrong with the clock. If you use another OS like Windows or Ubuntu, setting hardware clock to UTC is not a good idea, so:

Code: Select all
sed -r 's/^UTC=yes/UTC=no/ig' /etc/default/rcS | sudo tee /etc/default/rcS
sudo apt-get install ntp


This will disable UTC time and enable synchronizing with ntp servers. Set the time from panel. Reboot... WAIT, not yet!

Reboot is pretty broken now, it just reloads the kernel, skipping GRUB, so...

Code: Select all
sudo apt-get remove kexec-tools


...should fix the problem. Now we can

Code: Select all
sudo reboot


It's been a while since the above was posted, but that solution should still be good.
Chris M
Level 2
Level 2
 
Posts: 86
Joined: Mon Nov 29, 2010 10:01 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby squeezy on Tue Oct 09, 2012 12:59 pm

voss749 wrote:I had DKMS, I still had to rerun it.


Hmmm, never had a problem with DKMS working properly for me.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby squeezy on Tue Oct 09, 2012 1:02 pm

Chris M wrote:I'm not sure if this excellent thread got buried or not, but this was a real nice one: Hacking LMDE

HTD wrote:Wait, something's wrong with the clock. If you use another OS like Windows or Ubuntu, setting hardware clock to UTC is not a good idea, so:

Code: Select all
sed -r 's/^UTC=yes/UTC=no/ig' /etc/default/rcS | sudo tee /etc/default/rcS


It's been a while since the above was posted, but that solution should still be good.


Setting UTC options in /etc/default/rcS was deprecated sometime ago. I don't know if it still works as a legacy setting. The current method for setting UTC is to edit /etc/adjtime and change the last line to read either UTC or LOCAL.
squeezy
Level 5
Level 5
 
Posts: 567
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby narendra.d on Wed Oct 10, 2012 9:05 am

squeezy wrote:Setting UTC options in /etc/default/rcS was deprecated sometime ago. I don't know if it still works as a legacy setting. The current method for setting UTC is to edit /etc/adjtime and change the last line to read either UTC or LOCAL.



Thank You Chris M and squeezy. I know that time settings are now managed in /etc/adjtime. I do not know if putting anything in /etc/default/rcS will matter (just checked: there is nothing time related in rcS.).

I will go thru the post linked by Chris M and see if it makes sense to me and get back with any Q's or feedback.

Thanks once again.
narendra.d
Level 2
Level 2
 
Posts: 54
Joined: Thu Mar 24, 2011 9:36 am

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby Chris M on Wed Oct 10, 2012 11:50 am

narendra.d wrote:
squeezy wrote:Setting UTC options in /etc/default/rcS was deprecated sometime ago. I don't know if it still works as a legacy setting. The current method for setting UTC is to edit /etc/adjtime and change the last line to read either UTC or LOCAL.



Thank You Chris M and squeezy. I know that time settings are now managed in /etc/adjtime. I do not know if putting anything in /etc/default/rcS will matter (just checked: there is nothing time related in rcS.).

I will go thru the post linked by Chris M and see if it makes sense to me and get back with any Q's or feedback.

Thanks once again.


Thanks squeezy for that info. My guess is that the old solution won't cut it since setting UTC options in /etc/default/rcS was deprecated. You could ask HTD via PM if he has another set of commands that can be run. Maybe its not needed and all you have to do is edit /etc/adjtime and re-boot. Don't know. Maybe squeezy can suggest something more robust. But good luck. It's been a while since I have fresh installed LMDE and had to deal with it.
Chris M
Level 2
Level 2
 
Posts: 86
Joined: Mon Nov 29, 2010 10:01 pm

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby jackmetal on Fri Oct 19, 2012 7:27 am

I've edited my adjtime file a while back, but I haven't booted into Windows since then. :-) I plan to boot into Windows sometime today to test. I'll let you know how it goes (hopefully that fixed it).

Now.....If I can just figure out why my battery is lasting half the time in LMDE as opposed to Windows, I'll be perfect.. In Windows my dual battery setup lasts 8-10 hours, in LMDE it's only last around 4.5... A real bummer, but I'm sure it's something to do with my particular laptop (HP 8460p), since I don't remember it happening with the old 8440p laptop. :-(


narendra.d wrote:
squeezy wrote:Setting UTC options in /etc/default/rcS was deprecated sometime ago. I don't know if it still works as a legacy setting. The current method for setting UTC is to edit /etc/adjtime and change the last line to read either UTC or LOCAL.



Thank You Chris M and squeezy. I know that time settings are now managed in /etc/adjtime. I do not know if putting anything in /etc/default/rcS will matter (just checked: there is nothing time related in rcS.).

I will go thru the post linked by Chris M and see if it makes sense to me and get back with any Q's or feedback.

Thanks once again.
-----
LMDE - The ONLY way to go
w/Debian Testing & Debian SID Repo's
User avatar
jackmetal
Level 2
Level 2
 
Posts: 53
Joined: Sun Apr 24, 2011 8:02 am

Re: LMDE BREAKAGES - tracking TESTING - updated 1/11/12

Postby lahirdenganselamat on Thu Nov 01, 2012 5:10 am

gdebi upgrade from 0.8.5 to 0.8.6 make gdebi un-usable

Code: Select all
aragorn@aragorn-1215b ~/Linux $ sudo gdebi-kde ia32-crossover_11.3.1-1_amd64.deb
Traceback (most recent call last):
  File "/usr/bin/gdebi-kde", line 67, in <module>
    help=unicode(_("Run non-interactive (dangerous!)"),"UTF-8"))
TypeError: decoding Unicode is not supported


Downgrade to 0.8.5 using gdebi from UP repo make it works again
ASUS 1215B AMD E-350 with Linux Mint 15 KDE, Precise Puppy, and Saluki
User avatar
lahirdenganselamat
Level 4
Level 4
 
Posts: 437
Joined: Mon Oct 17, 2011 10:30 pm
Location: Yogyakarta

Re: LMDE BREAKAGES - tracking TESTING - updated 15 May

Postby zerozero on Thu Nov 01, 2012 1:40 pm

as you can see here http://www.mail-archive.com/debian-bugs ... 74765.html :lol: gdebi-gtk is not affected.
/joking.

tks for reporting it and we will see a fix sooner because of that :wink:

tbh i only now realized
Code: Select all
zerozero@deb-kde ~/Downloads $ sudo gdebi cinnamon-themes_2012.10.20_all.deb
[sudo] password for zerozero:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Building data structures... Done
Building data structures... Done


Cinnamon themes
 A collection of the best themes available for Cinnamon.
Do you want to install the software package? [y/N]:N

zerozero@deb-kde ~/Downloads $ sudo gdebi-kde cinnamon-themes_2012.10.20_all.deb
Traceback (most recent call last):
  File "/usr/bin/gdebi-kde", line 67, in <module>
    help=unicode(_("Run non-interactive (dangerous!)"),"UTF-8"))
TypeError: decoding Unicode is not supported
 
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6489
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests