Linux sees mic, program doesnt.

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Linux sees mic, program doesnt.

Postby douggiephresh on Wed Oct 10, 2012 12:40 pm

"Sound" sees my Logitech g35 headset. It sees the headphones and it sees the microphone. I can even test them inside of "Sound". However, I am trying to use Rosetta Stone via Wine and it doesnt detect my microphone. What would be the reasons? It worked in windows.
douggiephresh
Level 1
Level 1
 
Posts: 14
Joined: Tue Oct 09, 2012 6:33 pm

Linux Mint is funded by ads and donations.
 

Re: Linux sees mic, program doesnt.

Postby Flemur on Wed Oct 10, 2012 12:51 pm

Try running
$ winecfg
and check the Audio tab.

If that doesn't help, you might need pulseaudio*, or its absence...
http://wiki.winehq.org/Sound :
"Some users have suggested disabling or removing PulseAudio as a workaround for Wine-related sound issues." (but not recomended).

* I do all my audio thru wine and so far I've always had to install pulseaudio to get "what you hear" recording to work (with or without wine), tho that doesn't address the microphone issue.
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 756
Joined: Mon Aug 20, 2012 9:41 pm

Re: Linux sees mic, program doesnt.

Postby stratus_ss on Wed Oct 10, 2012 12:56 pm

Its probably something you need to set in winecfg.

You have to do the same thing for USB keys, you have to add them into winecfg
stratus_ss
Level 4
Level 4
 
Posts: 270
Joined: Fri May 25, 2012 5:22 pm

Re: Linux sees mic, program doesnt.

Postby douggiephresh on Wed Oct 10, 2012 2:20 pm

how do i check winecfg?
douggiephresh
Level 1
Level 1
 
Posts: 14
Joined: Tue Oct 09, 2012 6:33 pm

Re: Linux sees mic, program doesnt.

Postby douggiephresh on Wed Oct 10, 2012 2:26 pm

Ok i got into wineconfig through the menu. I put all audio options to G35 headset. rosetta stone still doesnt see my mic. It worked in windows so i dont think its a rosetta stone problem. tried removiing pulse audio, didnt work. this is how i have wine configured http://imgur.com/ba1rL
douggiephresh
Level 1
Level 1
 
Posts: 14
Joined: Tue Oct 09, 2012 6:33 pm

Re: Linux sees mic, program doesnt.

Postby Flemur on Wed Oct 10, 2012 4:44 pm

Linux sound is a pain - adding wine makes a real PITA.

I just noticed that my "record what you hear" thru wine wasn't working anymore...sigh. Various versions of wine seem to have different sound problems. (Here: wine-1.5.14 and pulseaudio 1.1)

Here's what I did to fix it, and FWIW you might try the same or something similar:

- install/enable pulseaudio
- install "pavucontrol" (small program).
- another thing to check is "alsamixer", mostly to see that nothing's muted. You should already have it.

- while using the mic & program, try the various settings on pavucontrol (I had to change the Config/Profile value to various values - then the recording worked, then I set it back to where it started - analog stereo duplex - and it still worked....bigger sigh).
Anyway, pavucontrol has settings for mics.

- winecfg shows my driver as "winepulse.drv"; the devices have a choice of Pulseaudo or "System Default" - they're all Default (just checked: "Pulseaudio" works, too). My recording program (audition w/wine) has a device/driver choice of "Pulseaudio" or "Wave Mapper", and they both work (wine probably points Wave Mapper - and "Default" - to Pulseaudio). My playing program - foobar under wine - is set to Pulseaudio but "Primary Sound Driver" works too.

Summary: I think the secret lies in having pulse and pavucontrol, having wine use winepulse.drv, and fooling around with pavucontrol until your mic works....wish I had something smarter to tell you!
Mint 17/Xfce/fluxbox & Mint 16/Xfce/fluxbox
User avatar
Flemur
Level 5
Level 5
 
Posts: 756
Joined: Mon Aug 20, 2012 9:41 pm

Re: Linux sees mic, program doesnt.

Postby linux248 on Tue Jan 01, 2013 12:19 am

I am running Wine 1.5.20, Mint 14, and Rosetta Stone Version 3.3.5 and found a fairly simple solution for the microphone problem that has worked on various systems:

1) Open Wine Configuration to the Libraries tab
2) Enter "winepulse.drv" in the override section. Accept the warning.
3) Edit the newly added override and set it to "disabled"
4) Apply the changes.
linux248
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 31, 2012 11:54 pm

Re: Linux sees mic, program doesnt.

Postby dookov on Tue May 13, 2014 2:38 pm

Google brought me here.
This solution worked for me!
Using Wine 1.7.18, with Rosetta Stone 3.4.7

Belated thanks!
dookov
Level 1
Level 1
 
Posts: 4
Joined: Mon Jun 11, 2012 3:54 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: borgward and 3 guests