Odd/inconsistent audio behavior between global/app volume

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read how to get help

Odd/inconsistent audio behavior between global/app volume

Postby sandroid on Sat Oct 13, 2012 9:38 pm

Hi all,

<cliché>long time lurker, first time poster</cliché>

I just installed LMDE on my desktop for the first time. It was previously running ubuntu 10.10, and since last month, 12.04. On Ubuntu, Audio worked as I expected it to. Audio *quality* is absolutely fine on LMDE, the issue is that when I set the global volume, it gets reset by banshee (others too, but banshee is the one where I'm fiddling most often) whenever I adjust the volume there. It makes it difficult to manage the sound level, especially because the rate of increase/decrease is different on both, and there's a little bit of an offset. One will show mute while the other one still has 3-8% volume.

I can't really describe the behavior better than this. It simply seems that application volume control is crossed with global volume output or something, it's making it annoying to be honest. I'll have volume at one level, turn on banshee and it's quiet (because it's showing volume at near zero). The moment I touch it's volume lever, the speakers are about to explode. I really want LMDE to work, Ubuntu's unity interface just won't do it for me - It's why I held on to 10.10 for so long.

Has anyone ever experienced this behavior, and/or anyone have some tips on how I can improve this? I'm very comfortable fiddling with the system, I just never bothered tinkering with my OS because I just wanted something that worked, and until now it always did. However, right now I'm looking for any suggestions or alternatives to the default audio (pulseaudio it looks like) system LMDE uses. If someone could at least explain why it would work one way on Ubuntu, and differently on LMDE, it would certainly help me narrow down the scope of my problem I imagine.

My system is a mini-itx fully integrated board with an intel core2duo CPU. The board is a zotac gf9300-g-e, and the audio/video is powered by nvidia's mobile GF9300 chipset, I'm assuming this detail may prove helpful.

TIA
sandroid
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 29, 2012 10:48 pm

Linux Mint is funded by ads and donations.
 

Re: Odd/inconsistent audio behavior between global/app volum

Postby sandroid on Sat Oct 13, 2012 11:05 pm

OK, so I did some further bungling around. Tried that suggestion of killing off pulseaudio and reverting to alsa. Worked better, but... it seems that the volume is far lower when using only alsa. I haven't fiddled with alsamixer to see if something could have been done.

I then reinstalled pulseaudio, now it seems there are more audio devices available, and it turns out that the standard volume control on "Nvidia HDA" which is the default device, is the **MONO** channel, and not the true master. There is a master channel that works as you would expect under "Playback: Built-in Audio Analog stereo (PulseAudio Mixer) though.

Any thoughts? I'm going to revert back to alsa for now.
sandroid
Level 1
Level 1
 
Posts: 2
Joined: Sat Sep 29, 2012 10:48 pm

Re: Odd/inconsistent audio behavior between global/app volum

Postby Lewdsquirrel on Sat Oct 20, 2012 10:15 pm

Hi sandroid,
Always had this problem with LMDE (using Amarok). I used to uninstall everything related to "Pulseaudio" to fix the problem, just keeping Alsa. Searched for a long time (and multiple times) about this issue but didn't find much about this particular problem, until one (lucky) day I found an info in a pulseaudio discussion forum. They were talking about the "flat-volumes" mode in the pulseaudio settings.
To make a long story short, here is the fix (found here http://forums.debian.net/viewtopic.php?f=16&t=12497&start=45):
"Problem #2: Changing volume per application does not work. (For example changing the volume icon in Rhythmbox makes the system volume change).
To fix this just change a setting in /etc/pulse/daemon.conf about flat volumes.
1. Open a root terminal and run:
nano /etc/pulse/daemon.conf

2. Change the line that says "; flat-volumes = yes" to "flat-volumes = no".
flat-volumes = no

3. Press CTRL+X to save the file and then reboot."


This info wasn't easy to find, but it fixed my problem, hope it will fix yours.
Image
Lewdsquirrel
Level 1
Level 1
 
Posts: 8
Joined: Thu Dec 11, 2008 12:50 pm


Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests