[Solved] Problem Muting/Unmuting Sound Linux Mint 13 KDE

Forum rules
Before you post please read how to get help

[Solved] Problem Muting/Unmuting Sound Linux Mint 13 KDE

Postby blue_bullet on Sun Oct 14, 2012 4:05 pm

qdbus org.kde.kmix /kmix/KMixWindow/actions/mute com.trolltech.Qt.QAction.trigger

I use the above command in a Rexx script to mute (midnight) and unmute (7 am) sounds via cron. My wife complains about our computers making all these noises from incoming emails when she is trying to get some shut eye. The command works equally well in CLI using Linux Mint 12 KDE 64 bit but does not work in Linux Mint 13 KDE 64 bit. I get the following error message when I issue the above command from a terminal session or in the Rexx routine:

Error: org.freedesktop.DBus.Error.UnknownInterface
No such interface 'com.trolltech.Qt.QAction' at object path '/kmix/KMixWindow/actions/mute'

I have stayed at LM 12 on my desktop so it continues to work properly on that machine. On one of my laptops I have LM 13 and LM 12 installed. It still works on LM 12 there but not on LM 13. Does anyone have an idea where I might look to see what is missing and how to put it back? All installs are KDE 64 bit version.

I can mute and unmute via the Kmix gui but not using qdbus in Linux Mint 13 KDE 64 bit.

Running KDE 4.9.2 on LM 13.
Last edited by blue_bullet on Sat Oct 20, 2012 2:31 pm, edited 1 time in total.
User avatar
blue_bullet
Level 2
Level 2
 
Posts: 54
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana

Linux Mint is funded by ads and donations.
 

Re: Problem Muting/Unmuting Sound Linux Mint 13 KDE

Postby blue_bullet on Sat Oct 20, 2012 2:27 pm

For anyone possibly interested the problem was solved by bcooksley, an admin in kde.forums.org. His response to my question (same as the one posed here):

It seems the interface got renamed... which is technically a SC/BC breakage - and should not have happened...
As for fixing your script, just replace com.trolltech.Qt.QAction.trigger with org.qtproject.Qt.QAction.trigger and it should now work again (there is no difference between the two - it is purely a naming change, and you can blame the Qt Developers).

To assist us here - please provide the output of "kmix --version".

System Settings and Device Actions KCM maintainer

Quote Report this post
blue_bullet
Registered Member

Posts
3
Karma
0

My response on the kde forum after implementing bcooksley's solution:
Re: Understanding kmix
Fri Oct 19, 2012 8:45 pm
bcooksley,
rob@shelby:~$ kmix --version
Qt: 4.8.2
KDE Development Platform: 4.9.2
KMix: 4.2

Thank you for the information. I have made the change to my script and it is now working in Linux Mint 13 KDE. I have had to change my script to check the version of Linux Mint being run since the com.trolltech is required for Linux Mint 12 KDE and org.qtproject is required in Linux Mint 13 KDE. Such is life. I also learned when I went back to test the change in Linux Mint 12 that the command "amixer sget Master > toggle_mute.txt" does not work properly (whereas it does in Linux Mint 13). toggle_mute.txt looks like this:

Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 64 [100%] [0.00dB] [on]

I parse the last line looking for the word "[on]" or "[off]" to decide what to do toggle wise. In Linux Mint 12 amixer has the last word as "[on]" even if volume is muted. I don't think it used to work that way but I may be wrong. At any rate piping the output using amixer now works as it should in Linux Mint 13 and the last line will have the word "on" or "off" depending on status of the volume (not muted or muted).
Guess I just need to move on to Linux Mint 13 KDE on all my machines.

Thank you again for your help here. My problem is fixed. My wife will be happy. I can hear her now when I explain this "Yes, Dear. Whatever..."
User avatar
blue_bullet
Level 2
Level 2
 
Posts: 54
Joined: Wed May 11, 2011 8:45 pm
Location: NW Montana


Return to KDE

Who is online

Users browsing this forum: No registered users and 4 guests