notification-daemon position - 2 monitors

notification-daemon position - 2 monitors

Postby drcasper on Mon May 14, 2012 10:52 am

After LMDE upgrade and MATE setup, the notification bubble appears based on what screen the cursor is.

So it will appear on the first or on the second monitor. Is there a way to fix this position on Display:0 or hard code the x-position?
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Linux Mint is funded by ads and donations.
 

Re: notification-daemon position - 2 monitors

Postby drcasper on Mon Oct 15, 2012 5:15 am

anyone?
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Re: notification-daemon position - 2 monitors

Postby irishwoody on Mon Oct 15, 2012 11:18 am

Not really an answer but for single screen under mate


I use this for Mate..
mate-notification-properties applicatio can set the position on a single screen..

perhaps someone else can elaborate on dual screen

I have seen a recent how to
http://www.webupd8.org/2012/10/get-ubun ... ns-to.html

THat might help

Woody
irishwoody
Level 1
Level 1
 
Posts: 42
Joined: Wed May 09, 2012 5:50 am

Re: notification-daemon position - 2 monitors

Postby drcasper on Tue Oct 16, 2012 6:27 am

This is so annoying, who in the right mind would make the notification jump from display to display based on cursor focus and not make the option to disable it!
I guess it was a good idea at the time :(

Less features is a feature, gnome3 style
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Re: notification-daemon position - 2 monitors

Postby drcasper on Thu Nov 15, 2012 4:51 am

I solved this by installing Colibri and removing mate-notification.

kde-notification-colibri can be placed on a desired screen and position on that screen.

systemsettings for kde will be needed so Colibri can be configured.

systemsettings-> Application and System Notification-> Colibri Notification

I had to add /usr/bin/colibri in startup applications so it loads on startup.

Possible Issue:
- Guake will not start cause mate-notification is missing, but only initially.

Code: Select all
sudo kate /usr/bin/guake

and comment out the line 653:

Code: Select all
 notification = pynotify.Notification(
                _('Guake!'),
                _('Guake is now running,\n'
                  'press <b>%s</b> to use it.') % label, filename)
#notification.show()


so for those with more then one screen this is nice work around

Colibri is in LMDEs repo.

binary: http://kde-apps.org/content/show.php/Colibri?content=117147
Image
User avatar
drcasper
Level 2
Level 2
 
Posts: 71
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina


Return to Others

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests