No sound, LMDE update 5 in VirtualBox

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

No sound, LMDE update 5 in VirtualBox

Postby swordfish on Mon Sep 24, 2012 6:12 am

I run LMDE in Virtualbox. Sound worked well until I installed update pack 5, but now I have no sound. I have looked at the pulseaudio settings and there is nothing obviously wrong. The pulseaudio volume monitor shows that music is playing, but there is nothing coming out on the speakers. As the problem started with the update to Mint, I assume that something changed in Mint is the problem, but I don't know what to look for.

I had the following message in /var/log/messages before and after the update, so I assume it is not suspicious
Code: Select all
Sep 24 10:50:33 virtual-mint pulseaudio[2891]: [pulseaudio] alsa-util.c: Disabling timer-based scheduling because running inside a VM.


There are also some messages about measured clock being rejected, but that was the same before the update as well.

Any thoughts on how to debug this would be welcome.
swordfish
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 02, 2011 6:10 am

Linux Mint is funded by ads and donations.
 

Re: No sound, LMDE update 5 in VirtualBox

Postby swordfish on Tue Oct 02, 2012 10:29 am

Code: Select all
$ inxi -SAxc 0
System:    Host virtual-mint Kernel 3.2.0-3-686-pae i686 (32 bit) Distro Linux Mint Debian Edition
Audio:     Card Intel 82801AA AC'97 Audio Controller driver snd_intel8x0 at ports d100 d200 BusID: 00:05.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
swordfish
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 02, 2011 6:10 am

Re: No sound, LMDE update 5 in VirtualBox

Postby kdceddj on Tue Oct 02, 2012 12:38 pm

same issue here
Code: Select all
$inxi -SAxc 0
System:    Host edsvbox Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Audio:     Card Intel 82801AA AC'97 Audio Controller driver snd_intel8x0 at ports d100 d200 BusID: 00:05.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
kdceddj
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 02, 2012 12:35 pm

Re: No sound, LMDE update 5 in VirtualBox

Postby kdceddj on Tue Oct 02, 2012 12:46 pm

ok, got the audio working on my mint virtual machine on virtualbox.
Menu -> Preferences -> Volume Control
Change the device in the dropdown to SigmaTel... (OSS Mixer)
Change the Master volume in the Playback tab (the default was 0)
kdceddj
Level 1
Level 1
 
Posts: 2
Joined: Tue Oct 02, 2012 12:35 pm

Re: No sound, LMDE update 5 in VirtualBox

Postby fusion71 on Sat Oct 06, 2012 2:28 am

I had the same problem after update 5 in virtualbox.

To solve the issue, I installed Pulseaudio volume control (pavucontrol) with the Software Manager. After installation, open PulseAudio Volume Control. Click on the Output Devices tab and change the port from "Analog Mono Output/Amplifier" to "LFE on Separate Mono Output/Amplifier".

Hope this helps someone :)
fusion71
Level 1
Level 1
 
Posts: 2
Joined: Mon Aug 08, 2011 8:12 am

Re: No sound, LMDE update 5 in VirtualBox

Postby swordfish on Tue Oct 16, 2012 8:40 am

fusion71 wrote:I had the same problem after update 5 in virtualbox.

To solve the issue, I installed Pulseaudio volume control (pavucontrol) with the Software Manager. After installation, open PulseAudio Volume Control. Click on the Output Devices tab and change the port from "Analog Mono Output/Amplifier" to "LFE on Separate Mono Output/Amplifier".

Hope this helps someone :)


That works for me.

Thanks very much.
swordfish
Level 1
Level 1
 
Posts: 12
Joined: Tue Aug 02, 2011 6:10 am

Re: No sound, LMDE update 5 in VirtualBox

Postby number61971 on Tue Oct 16, 2012 9:36 pm

fusion71 wrote:I had the same problem after update 5 in virtualbox.

To solve the issue, I installed Pulseaudio volume control (pavucontrol) with the Software Manager. After installation, open PulseAudio Volume Control. Click on the Output Devices tab and change the port from "Analog Mono Output/Amplifier" to "LFE on Separate Mono Output/Amplifier".

Hope this helps someone :)

This worked for me, too. I don't know how you knew this is what would fix it, but THANK YOU!
User avatar
number61971
Level 1
Level 1
 
Posts: 10
Joined: Mon Oct 03, 2011 12:00 pm

Re: No sound, LMDE update 5 in VirtualBox

Postby kwatson512 on Sat Nov 03, 2012 8:48 am

Finally, a solution! Worked for me too. Thank you!
Mint 16 64-bit Cinnamon, Lenovo ThinkPad T430s, 8GB RAM
kwatson512
Level 4
Level 4
 
Posts: 200
Joined: Sun Apr 20, 2008 7:16 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 3 guests