SOLVED "Open Containing Folder" issue with Firefox Download

Forum rules
Before you post please read this

SOLVED "Open Containing Folder" issue with Firefox Download

Postby yerc on Wed Oct 17, 2012 6:36 pm

Instead of Thunar, Nautilus now opens when i choose "Open Containing Folder" in Download window of Firefox.
This I noticed after installing gnome-systems-tool to be able to do admin tasks from within gui.
I can't seem to find any entry in "Firefox, Preferences, Applications, Action" that might change this behaviour.

How do I get this to default back to Thunar?

UPDATE:
It appears that Firefox (currently 16.0.1 in Mint 13 XFCE) has Nautilus or equivalent gnome apps hard coded for its file manager. Some googling indicates that this is an old issue.

Answer 1 in http://www.tinyguru.com/superuser/qid454568.html has the workaround and, for me, fixes the (annoying) Firefox behaviour that has been carried over to Mint 13 XFCE. I have been using Mint 9 Fluxbox until now and it does not have this issue - another proof of the quality of Mint 9 Fluxbox (and why I'm hoping that it continues beyond 9). For Mint 13 XFCE, oversight?
Attachments
Screenshot.png
Screenshot.png (23.17 KiB) Viewed 3092 times
Last edited by yerc on Fri Oct 19, 2012 1:39 am, edited 1 time in total.
yerc
Level 1
Level 1
 
Posts: 22
Joined: Wed Mar 30, 2011 2:44 pm

Linux Mint is funded by ads and donations.
 

Re: Nautilus hijacks "Open Containing Folder" option of Fire

Postby jjaythomas on Wed Oct 17, 2012 8:38 pm

Not much help of specifics... But
for FFs configs/variables enter 'about:config in Firefox's address bar.!

J.Jay
P.S. I only used to change very specific things pertaining to 'left-handed tablet use' "BE CAREFUL!!!
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: Nautilus hijacks "Open Containing Folder" option of Fire

Postby yerc on Fri Oct 19, 2012 1:44 am

jjaythomas wrote:Not much help of specifics... But
for FFs configs/variables enter 'about:config in Firefox's address bar.!


hey jjaythomas,

thanks for your suggestion.
i looked as well in about:config, but my limited knowledge of the language in that page means i didn't find any fix there.

Master google helped me though, as detailed in my OP :-)

btw, have you had a chance to check 'about:config' and is there something there that might fix the issue?
yerc
Level 1
Level 1
 
Posts: 22
Joined: Wed Mar 30, 2011 2:44 pm

Re: SOLVED "Open Containing Folder" issue with Firefox Downl

Postby jjaythomas on Fri Oct 19, 2012 11:57 am

Sorry I looked a little in 'about:configs' couldn't find anything :oops:

Is this a straight 'Xfce' or do you have mate/gnome or any other 'DE or WM' installed? :?:

Try total uninstall of 'FF' use synaptic will full uninstall option. then reboot (so FF & configs totally gone) then reinstall FF, (may need to install language pack first :wink: )

J.Jay

Edit if all else fails uninstall nautilus and/or nautilus-data.
(watch what else gets deleated as dependent on) :wink:
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: SOLVED "Open Containing Folder" issue with Firefox Downl

Postby DrHu on Fri Oct 19, 2012 1:02 pm

http://browsers.about.com/od/aboutconfi ... erList.htm
--in about: config you can set the download folder

I might also be examining Mozilla's knowledge base (you can use ctrl F to search the web page for an item/word )
--if you want to see the functions/options and any tweaks that Mozilla comments on, also the firefox forums are available..

I also like to check with arch Linux, which has a lot of customization and therefor a lot of information in regards to system setups/settings and applications ..
https://wiki.archlinux.org/index.php/Firefox
    The query I used was Firefox containing folders..
    --gets me the arch Linux link above, and on a read-through I it containing the info you found in regards to kde/dolphin containing folders
User avatar
DrHu
Level 16
Level 16
 
Posts: 6911
Joined: Wed Jun 17, 2009 8:20 pm

Re: SOLVED "Open Containing Folder" issue with Firefox Downl

Postby jjaythomas on Fri Oct 19, 2012 4:16 pm

--in about: config you can set the download folder


Yes that one changes where yo want to put 'downloads' but don't you still have to tell (folder permissions?) what FM to use?

J.Jay

Edit Is setting>preferred applications utility tab, file manager set to thunar??
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Re: SOLVED "Open Containing Folder" issue with Firefox Downl

Postby yerc on Fri Oct 19, 2012 5:36 pm

jjaythomas wrote:Sorry I looked a little in 'about:configs' couldn't find anything :oops:
Is this a straight 'Xfce' or do you have mate/gnome or any other 'DE or WM' installed? :?:

No other DE or WM here.

Try total uninstall of 'FF' use synaptic will full uninstall option. then reboot (so FF & configs totally gone) then reinstall FF, (may need to install language pack first :wink: )
Edit if all else fails uninstall nautilus and/or nautilus-data.
(watch what else gets deleated as dependent on)


Not necessary as I have found a workaround. Refer back to original post.
yerc
Level 1
Level 1
 
Posts: 22
Joined: Wed Mar 30, 2011 2:44 pm

Re: SOLVED "Open Containing Folder" issue with Firefox Downl

Postby Laugh2 on Sat Aug 16, 2014 6:05 pm

I couldn't get the above to work for me in Mint 13 64-bit MATE with Firefox 31.0. (It continued to open the Banshee player for any and all files or folders.)

However, I opened "Control Centre/Preferred Applications/System" and set the File Manager to "MATE file manager". This solved the problem. :D
Laugh2
Level 1
Level 1
 
Posts: 17
Joined: Fri Aug 16, 2013 4:01 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 5 guests