[SOLVED] LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Post your update and upgrade related errors here
Forum rules
Before you post please read this

[SOLVED] LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby gstanfield on Sat Oct 13, 2012 9:58 pm

Last night, I tried to update/upgrade one of my systems with 1300+ packages, which, from all the reading I've been doing, I believe turned out to be UP5.

System: old Dell (single core CPU days), SATA drive, ATI Radeon HD video card. Nothing special.

This started life with Window$ XP, but when that died the slow M$ death, it got a new harddrive and Ubuntu. When that drive died, it was upgraded to LM 10 or 11, but then upgraded again to LMDE/Gnome2. With UP4, it got Gnome3 and a bunch of headaches until I got it working. All was good until UP5 last night.

Everything seemed to go well with the upgrade - I don't remember seeing anything bad going by as it updated things. But, when I rebooted, I got a blank screen with a flashing cursor in the upper left corner, and nothing else. I researched the issue the best I could on my other machine, and found that a "workaround" to get back to "usable" was to remove the xorg.conf file. That did work, but left me with the "fallback" configuration - no Gnome3 which my family has now become accustomed to seeing on this machine.

I've searched through the forums, but haven't found anything that has been able to help me with my situation. I think it is something with xorg.conf, but I don't know how to troubleshoot it. When I run the aticonfig --initial command, the base xorg.conf is created, and it is very similar to the one I had in place before UP5, just missing an "InputDevice" section with Generic Keyboard & kbd driver settings.

Looking at other posts, inxi seems to be something needed, so here are two of those:
Code: Select all
inxi -SxxxGxF
System:    Host mysystem Kernel 3.2.0-3-486 i686 (32 bit) Distro Linux Mint Debian Edition
CPU:       Single core Intel Pentium 4 (-UP-) cache 1024 KB flags (nx sse sse2 sse3) bmips 5586.13 clocked at 2793.068 MHz
Graphics:  Card Advanced Micro Devices [AMD] nee ATI RV620 LE [Radeon HD 3450] X.Org 1.12.1.902 Res: 1280x1024@0.0hz
           GLX Renderer N/A GLX Version N/A Direct Rendering N/A
Audio:     Card-1 Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver snd_intel8x0 at ports ec00 e8c0 BusID: 00:1e.2
           Card-2 Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series] driver snd_hda_intel BusID: 01:00.1
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card Intel 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller driver e100 v: 3.5.24-k2-NAPI at port ccc0 BusID: 03:08.0
Disks:     HDD Total Size: 1080.2GB (7.4% used) 1: /dev/sda WDC_WD1002FAEX 1000.2GB
           2: /dev/sdb WDC_WD800JD 80.0GB
Partition: ID:/ size: 25G used: 8.7G (37%) fs: rootfs ID:/ size: 25G used: 8.7G (37%) fs: ext4
           ID:/home size: 400G used: 21G (6%) fs: ext4 ID:swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap
Info:      Processes 146 Uptime 42 min Memory 605.4/3040.9MB Runlevel 2 Client Shell inxi 1.4.23

Code: Select all
inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ debian main upstream import
           deb http://mirror.rts-informatique.fr/linuxmint/debian/latest testing main contrib non-free
           deb http://mirror.rts-informatique.fr/linuxmint/debian/latest/security testing/updates main contrib non-free
           deb http://mirror.rts-informatique.fr/linuxmint/debian/latest/multimedia testing main non-free
           Active apt sources in file: /etc/apt/sources.list.d/opera.list
           deb http://deb.opera.com/opera/ stable non-free #Opera Browser (final releases)

I'm lost as to why this happened, and what to do to correct it. I did end up on the AMD support site, and downloaded and installed the latest ATI driver set: ati-driver-installer-9-3-x86_64.run, but I wonder whether that was appropriate, since I believe I'm still on 32 bit. I'm not beyond moving to MATE or Cinnamon, if that would be an easier path, but for some reason, the issue seems more to me like a system issue and not so much a DM issue.
Last edited by gstanfield on Thu Oct 18, 2012 7:24 pm, edited 1 time in total.
gstanfield
Level 1
Level 1
 
Posts: 4
Joined: Fri Oct 07, 2011 8:18 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby gstanfield on Tue Oct 16, 2012 7:49 pm

Well, I was hoping that following suggestions in some of the other posts I've read about rolling back changes piece by piece might change something. Unfortunately, it seems that the "Package > Force Version..." suggested in Synaptic's package properties is not available for most or all of the changes applied with the last "upgrade".

I'm fresh out of ideas. Anyone able to help, or point me in some good direction? Please?
gstanfield
Level 1
Level 1
 
Posts: 4
Joined: Fri Oct 07, 2011 8:18 pm

Re: LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby zerozero on Tue Oct 16, 2012 8:24 pm

see this please (ketoth's post) >> viewtopic.php?f=198&t=114712&p=638706#p638706
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby gstanfield on Tue Oct 16, 2012 10:42 pm

Thanks for that zerozero.

Did the purge (had to manually remove one .so that wouldn't leave nicely) and the reinstall, and the box came back up, but Gnome3 still didn't look right. In fact nothing had changed.

I tried to run aticonfig --initial, but that gave me the "aticonfig is currently not installed" message due to it being part of the fglrx-driver package.

I replaced the xorg.conf file in hopes that it would do the trick, and rebooted, and got back to the same black screen with a flashing white cursor in the upper left corner (that eventually stopped flashing).

I removed the xorg.conf and rebooted, and now I'm back to the non-Gnome3 (fallback) configuration.

Found more help on making sure the card is initializing and kernel modesetting is enabled - dmesg | grep drm - everything looked good there.
Code: Select all
dmesg | grep drm
[   16.830253] [drm] Initialized drm 1.1.0 20060810
[   16.923144] [drm] radeon kernel modesetting enabled.
[   16.924951] [drm] initializing kernel modesetting (RV620 0x1002:0x95C5 0x1787:0x2002).
[   16.924988] [drm] register mmio base: 0xDFDF0000
[   16.924991] [drm] register mmio size: 65536
[   16.925565] [drm] Detected VRAM RAM=512M, BAR=256M
[   16.925570] [drm] RAM width 64bits DDR
[   16.925700] [drm] radeon: 512M of VRAM memory ready
[   16.925704] [drm] radeon: 512M of GTT memory ready.
[   16.925721] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[   16.925724] [drm] Driver supports precise vblank timestamp query.
[   16.925807] [drm] radeon: irq initialized.
[   16.925813] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   16.927304] [drm] Loading RV620 Microcode
[   17.058476] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[   17.092288] [drm] ring test succeeded in 1 usecs
[   17.092432] [drm] radeon: ib pool ready.
[   17.092508] [drm] ib test succeeded in 0 usecs
[   17.097673] [drm] Radeon Display Connectors
[   17.097678] [drm] Connector 0:
[   17.097680] [drm]   DVI-I
[   17.097682] [drm]   HPD1
[   17.097686] [drm]   DDC: 0x7e40 0x7e40 0x7e44 0x7e44 0x7e48 0x7e48 0x7e4c 0x7e4c
[   17.097689] [drm]   Encoders:
[   17.097691] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   17.097694] [drm]     DFP2: INTERNAL_KLDSCP_LVTMA
[   17.097696] [drm] Connector 1:
[   17.097698] [drm]   DIN
[   17.097700] [drm]   Encoders:
[   17.097702] [drm]     TV1: INTERNAL_KLDSCP_DAC2
[   17.097704] [drm] Connector 2:
[   17.097706] [drm]   DVI-I
[   17.097708] [drm]   HPD2
[   17.097711] [drm]   DDC: 0x7e50 0x7e50 0x7e54 0x7e54 0x7e58 0x7e58 0x7e5c 0x7e5c
[   17.097714] [drm]   Encoders:
[   17.097716] [drm]     CRT2: INTERNAL_KLDSCP_DAC2
[   17.097718] [drm]     DFP1: INTERNAL_UNIPHY
[   17.098322] [drm] Internal thermal controller with fan control
[   17.098851] [drm] radeon: power management initialized
[   17.197452] [drm] fb mappable at 0xC0142000
[   17.197457] [drm] vram apper at 0xC0000000
[   17.197459] [drm] size 5242880
[   17.197462] [drm] fb depth is 24
[   17.197464] [drm]    pitch is 5120
[   17.200996] fbcon: radeondrmfb (fb0) is primary device
[   17.201609] fb0: radeondrmfb frame buffer device
[   17.201612] drm: registered panic notifier
[   17.201624] [drm] Initialized radeon 2.12.0 20080528 for 0000:01:00.0 on minor 0


Looks like fglrx packages are not installed:
Code: Select all
dpkg -l '*fglrx*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                              Version                           Description
+++-=================================-=================================-==================================================================================
un  fglrx-driver                      <none>                            (no description available)
un  fglrx-glx                         <none>                            (no description available)
un  libfglrx                          <none>                            (no description available)
un  libgl1-fglrx-glx                  <none>                            (no description available)


locate fglrx, however, shows a whole lot of artifacts left behind. Don't know if I should just remove them or not.
Code: Select all
locate fglrx
/etc/alternatives/glx--fglrx_drv.so
/etc/default/fglrx-atieventsd
/etc/init.d/fglrx-atieventsd
/etc/modprobe.d/blacklist-fglrx.conf
/etc/modprobe.d/fglrx-driver.conf
/etc/profile.d/ati-fglrx.sh
/etc/rc0.d/K01fglrx-atieventsd
/etc/rc1.d/K01fglrx-atieventsd
/etc/rc2.d/S19fglrx-atieventsd
/etc/rc3.d/S19fglrx-atieventsd
/etc/rc4.d/S19fglrx-atieventsd
/etc/rc5.d/S19fglrx-atieventsd
/etc/rc6.d/K01fglrx-atieventsd
/usr/X11R6/lib/modules/dri/fglrx_dri.so
/usr/bin/fglrxinfo
/usr/lib/fglrx
/usr/lib/libfglrx_dm.a
/usr/lib/libfglrx_dm.so.1.0
/usr/lib/i386-linux-gnu/fglrx
/usr/lib/i386-linux-gnu/libfglrx_dm.so.1.0
/usr/lib/i386-linux-gnu/dri/fglrx_dri.so
/usr/lib/xorg/modules/drivers/fglrx_drv.so
/usr/lib/xorg/modules/extensions/fglrx
/usr/lib/xorg/modules/extensions/fglrx/fglrx-libglx.so
/usr/share/fglrx
/usr/share/ati/fglrx-install.log
/usr/share/ati/fglrx-uninstall.sh
/usr/share/bug/fglrx-atieventsd
/usr/share/bug/fglrx-control
/usr/share/bug/fglrx-driver
/usr/share/bug/fglrx-glx
/usr/share/bug/fglrx-modules-dkms
/usr/share/bug/glx-alternative-fglrx
/usr/share/bug/libfglrx
/usr/share/bug/libfglrx-amdxvba1
/usr/share/bug/libgl1-fglrx-glx
/usr/share/doc/fglrx-atieventsd
/usr/share/doc/fglrx-control
/usr/share/doc/fglrx-driver
/usr/share/doc/fglrx-glx
/usr/share/doc/fglrx-modules-dkms
/usr/share/doc/glx-alternative-fglrx
/usr/share/doc/libfglrx
/usr/share/doc/libfglrx-amdxvba1
/usr/share/doc/libgl1-fglrx-glx
/usr/share/doc-base/fglrx-driver
/usr/share/lintian/overrides/fglrx-atieventsd
/usr/share/lintian/overrides/fglrx-control
/usr/share/lintian/overrides/fglrx-driver
/usr/share/lintian/overrides/fglrx-modules-dkms
/usr/share/lintian/overrides/glx-alternative-fglrx
/usr/share/lintian/overrides/libfglrx
/usr/share/lintian/overrides/libfglrx-amdxvba1
/usr/share/lintian/overrides/libgl1-fglrx-glx
/usr/share/man/man1/fglrx_xgamma.1x.gz
/usr/share/man/man1/fglrxinfo.1x.gz
/usr/share/man/man4/fglrx.4x.gz
/usr/src/fglrx-8.92
/usr/src/ati/fglrx_sample_source.tgz
/usr/src/fglrx-8.92/2.6.x
/usr/src/fglrx-8.92/Makefile
/usr/src/fglrx-8.92/dkms.conf
/usr/src/fglrx-8.92/drm.h
/usr/src/fglrx-8.92/drmP.h
/usr/src/fglrx-8.92/drm_compat.h
/usr/src/fglrx-8.92/drm_os_linux.h
/usr/src/fglrx-8.92/drm_proc.h
/usr/src/fglrx-8.92/fglrxko_pci_ids.h
/usr/src/fglrx-8.92/firegl_public.c
/usr/src/fglrx-8.92/firegl_public.h
/usr/src/fglrx-8.92/kcl.c
/usr/src/fglrx-8.92/kcl.h
/usr/src/fglrx-8.92/kcl_acpi.c
/usr/src/fglrx-8.92/kcl_acpi.h
/usr/src/fglrx-8.92/kcl_agp.c
/usr/src/fglrx-8.92/kcl_agp.h
/usr/src/fglrx-8.92/kcl_config.h
/usr/src/fglrx-8.92/kcl_debug.c
/usr/src/fglrx-8.92/kcl_debug.h
/usr/src/fglrx-8.92/kcl_io.c
/usr/src/fglrx-8.92/kcl_io.h
/usr/src/fglrx-8.92/kcl_ioctl.c
/usr/src/fglrx-8.92/kcl_ioctl.h
/usr/src/fglrx-8.92/kcl_iommu.c
/usr/src/fglrx-8.92/kcl_iommu.h
/usr/src/fglrx-8.92/kcl_osconfig.h
/usr/src/fglrx-8.92/kcl_pci.c
/usr/src/fglrx-8.92/kcl_pci.h
/usr/src/fglrx-8.92/kcl_str.c
/usr/src/fglrx-8.92/kcl_str.h
/usr/src/fglrx-8.92/kcl_type.h
/usr/src/fglrx-8.92/kcl_wait.c
/usr/src/fglrx-8.92/kcl_wait.h
/usr/src/fglrx-8.92/libfglrx_ip.a
/usr/src/fglrx-8.92/make.sh
/usr/src/fglrx-8.92/2.6.x/Makefile
/var/cache/apt/archives/fglrx-atieventsd_1%3a11-8-1_i386.deb
/var/cache/apt/archives/fglrx-atieventsd_1%3a12-2-2_i386.deb
/var/cache/apt/archives/fglrx-atieventsd_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/fglrx-control_1%3a11-8-1_i386.deb
/var/cache/apt/archives/fglrx-control_1%3a12-2-2_i386.deb
/var/cache/apt/archives/fglrx-control_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/fglrx-driver_1%3a11-8-1_i386.deb
/var/cache/apt/archives/fglrx-driver_1%3a12-2-2_i386.deb
/var/cache/apt/archives/fglrx-driver_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/fglrx-glx_1%3a11-8-1_i386.deb
/var/cache/apt/archives/fglrx-glx_1%3a12-2-2_i386.deb
/var/cache/apt/archives/fglrx-glx_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/fglrx-modules-dkms_1%3a11-8-1_i386.deb
/var/cache/apt/archives/fglrx-modules-dkms_1%3a12-2-2_i386.deb
/var/cache/apt/archives/fglrx-modules-dkms_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/glx-alternative-fglrx_0.1.91_i386.deb
/var/cache/apt/archives/glx-alternative-fglrx_0.2.1_i386.deb
/var/cache/apt/archives/glx-alternative-fglrx_0.2.2_i386.deb
/var/cache/apt/archives/libfglrx-amdxvba1_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/libfglrx_1%3a12-2-2_i386.deb
/var/cache/apt/archives/libfglrx_1%3a12-6+point-1_i386.deb
/var/cache/apt/archives/libgl1-fglrx-glx_1%3a12-2-2_i386.deb
/var/cache/apt/archives/libgl1-fglrx-glx_1%3a12-6+point-1_i386.deb
/var/lib/dpkg/info/fglrx-atieventsd.conffiles
/var/lib/dpkg/info/fglrx-atieventsd.list
/var/lib/dpkg/info/fglrx-atieventsd.md5sums
/var/lib/dpkg/info/fglrx-atieventsd.postinst
/var/lib/dpkg/info/fglrx-atieventsd.postrm
/var/lib/dpkg/info/fglrx-atieventsd.preinst
/var/lib/dpkg/info/fglrx-atieventsd.prerm
/var/lib/dpkg/info/fglrx-control.list
/var/lib/dpkg/info/fglrx-control.md5sums
/var/lib/dpkg/info/fglrx-control.postinst
/var/lib/dpkg/info/fglrx-control.postrm
/var/lib/dpkg/info/fglrx-driver.conffiles
/var/lib/dpkg/info/fglrx-driver.config
/var/lib/dpkg/info/fglrx-driver.list
/var/lib/dpkg/info/fglrx-driver.md5sums
/var/lib/dpkg/info/fglrx-driver.postinst
/var/lib/dpkg/info/fglrx-driver.postrm
/var/lib/dpkg/info/fglrx-driver.preinst
/var/lib/dpkg/info/fglrx-driver.prerm
/var/lib/dpkg/info/fglrx-driver.templates
/var/lib/dpkg/info/fglrx-glx.list
/var/lib/dpkg/info/fglrx-glx.md5sums
/var/lib/dpkg/info/fglrx-modules-dkms.list
/var/lib/dpkg/info/fglrx-modules-dkms.md5sums
/var/lib/dpkg/info/fglrx-modules-dkms.postinst
/var/lib/dpkg/info/fglrx-modules-dkms.prerm
/var/lib/dpkg/info/glx-alternative-fglrx.list
/var/lib/dpkg/info/glx-alternative-fglrx.md5sums
/var/lib/dpkg/info/glx-alternative-fglrx.postinst
/var/lib/dpkg/info/glx-alternative-fglrx.prerm
/var/lib/dpkg/info/glx-alternative-fglrx.triggers
/var/lib/dpkg/info/libfglrx-amdxvba1:i386.list
/var/lib/dpkg/info/libfglrx-amdxvba1:i386.md5sums
/var/lib/dpkg/info/libfglrx-amdxvba1:i386.postinst
/var/lib/dpkg/info/libfglrx-amdxvba1:i386.postrm
/var/lib/dpkg/info/libfglrx-amdxvba1:i386.shlibs
/var/lib/dpkg/info/libfglrx:i386.list
/var/lib/dpkg/info/libfglrx:i386.md5sums
/var/lib/dpkg/info/libfglrx:i386.postinst
/var/lib/dpkg/info/libfglrx:i386.postrm
/var/lib/dpkg/info/libfglrx:i386.preinst
/var/lib/dpkg/info/libfglrx:i386.shlibs
/var/lib/dpkg/info/libfglrx:i386.templates
/var/lib/dpkg/info/libgl1-fglrx-glx:i386.list
/var/lib/dpkg/info/libgl1-fglrx-glx:i386.md5sums
/var/lib/dpkg/info/libgl1-fglrx-glx:i386.postinst
/var/lib/dpkg/info/libgl1-fglrx-glx:i386.postrm
/var/lib/dpkg/info/libgl1-fglrx-glx:i386.shlibs
/var/lib/dpkg/triggers/register-glx-alternative-fglrx
/var/lib/update-rc.d/fglrx-atieventsd


I ran a sudo dpkg-reconfigure xserver-xorg, and that seemed to go well - no response but the prompt.

Next was sudo apt-get install --reinstall xserver-xorg-core which again went well.

Then I rebooted, GDM came up but looked different with a black background around the logins. I logged in, and got an "Aw snap!" message, forcing me to log out again. I have three "session" settings in GDM now - 1. System Default (broken Gnome), 2. Gnome (broken), and 3. Gnome Classic (fallback mode again). Needless to say, option 3 is the only one working at this point.

The helps say that xorg.conf is no longer needed since KMS is available. Much of the "help" I found was on an Ubuntu page (sorry) - https://help.ubuntu.com/community/RadeonDriver - but the commands worked, and it did show that my video card is supposed to be supported.

Since I've gone through all this and still haven't found a good solution, I'm thinking about switching to a less intensive DM, like Cinnamon or MATE, but don't know if they are good, stable options. Any thoughts as to whether it is worth "fixing" Gnome3, or if the Cinnamon or MATE would be a better option? My wife has gotten used to Gnome3 (from Gnome2), but if Cinnamon or MATE would get things working again (this fallback is barely workable), I'll start looking in that direction. Please - let me know your thoughts...
gstanfield
Level 1
Level 1
 
Posts: 4
Joined: Fri Oct 07, 2011 8:18 pm

Re: LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby zerozero on Wed Oct 17, 2012 6:05 am

hi,
unfortunately i have no experience with amd at all, can give just some pointers here:
- cinnamon uses the same underlying technology that gnome-shell uses: both DE's require good graphics stack and working 3D capability (the latest cinnamon available in romeo see here how to install it has a 2D session- might be an option)
- mate will work with or without 3D acceleration (meaning that you don't need proprietary drivers and the open-source are more than enough for the job)
- the basic question is that ati deprecated all the cards bellow the 5000
zerozero
Level 16
Level 16
 
Posts: 6474
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE/Gnome3 xorg.conf issue post UP5 upgrade

Postby gstanfield on Thu Oct 18, 2012 7:21 pm

Thanks zerozero!

I ended up going down the MATE install path. It isn't perfect, but at least the computer is usable again. Guess I'm going to have to upgrade the box, or at least the card. And how to rid myself of Gnome3 without destroying things. And I'm nervous about updating the other box with UP5 (it has LMDE/XFCE now)...maybe I'll wait a while...

Anyway, thanks again for the suggestions and pointers.
gstanfield
Level 1
Level 1
 
Posts: 4
Joined: Fri Oct 07, 2011 8:18 pm


Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests