problem with installing/dependencies... libc-bin libc6

Post your update and upgrade related errors here
Forum rules

Not able to install .. please help

Postby phuchungbhutia on Tue Oct 16, 2012 3:38 am

when i try to install anything like
wine, lxde, conky, etc it asks for aptget -f install
but then it doesnt work



sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libc-bin libc6
Suggested packages:
glibc-doc
The following packages will be upgraded:
libc-bin libc6
2 upgraded, 0 newly installed, 0 to remove and 1103 not upgraded.
2 not fully installed or removed.
Need to get 0 B/5,066 kB of archives.
After this operation, 872 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libc-bin libc6
Install these packages without verification [y/N]? y
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 151679 files and directories currently installed.)
Preparing to replace libc-bin 2.13-27 (using .../libc-bin_2.15-0ubuntu10.2_i386.deb) ...
Unpacking replacement libc-bin ...
dpkg: error processing /var/cache/apt/archives/libc-bin_2.15-0ubuntu10.2_i386.deb (--unpack):
trying to overwrite '/usr/sbin/validlocale', which is also in package locales 2.13-27
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.15-0ubuntu10.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
phuchungbhutia
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 16, 2012 3:35 am

Linux Mint is funded by ads and donations.
 

Re: Not able to install .. please help

Postby bluefish on Tue Oct 16, 2012 12:01 pm

Hi,
you already tried
Code: Select all
sudo dpkg --configure -a
?
bluefish
bluefish
Level 1
Level 1
 
Posts: 9
Joined: Sat Sep 22, 2012 6:29 am
Location: Berlin,Germany

Re: Not able to install .. please help

Postby phuchungbhutia on Fri Oct 19, 2012 4:45 am

still error

sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of libc6-dev:
libc6-dev depends on libc6 (= 2.15-0ubuntu10.2); however:
Version of libc6 on system is 2.13-27.
dpkg: error processing libc6-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
libc-dev-bin depends on libc6 (>> 2.15); however:
Version of libc6 on system is 2.13-27.
dpkg: error processing libc-dev-bin (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libc6-dev
libc-dev-bin
phuchungbhutia
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 16, 2012 3:35 am

problem with installing/dependencies... libc-bin libc6

Postby phuchungbhutia on Fri Oct 19, 2012 4:55 am

i must have asked in ewrong section here:
viewtopic.php?f=198&t=114923


getting this error while installing conky, lxde, etc
sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libc-bin libc6
Suggested packages:
glibc-doc
The following packages will be upgraded:
libc-bin libc6
2 upgraded, 0 newly installed, 0 to remove and 1103 not upgraded.
2 not fully installed or removed.
Need to get 0 B/5,066 kB of archives.
After this operation, 872 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libc-bin libc6
Install these packages without verification [y/N]? y
Reading changelogs... Done
Preconfiguring packages ...
(Reading database ... 151679 files and directories currently installed.)
Preparing to replace libc-bin 2.13-27 (using .../libc-bin_2.15-0ubuntu10.2_i386.deb) ...
Unpacking replacement libc-bin ...
dpkg: error processing /var/cache/apt/archives/libc-bin_2.15-0ubuntu10.2_i386.deb (--unpack):
trying to overwrite '/usr/sbin/validlocale', which is also in package locales 2.13-27
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.15-0ubuntu10.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
phuchungbhutia
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 16, 2012 3:35 am

Re: problem with installing/dependencies... libc-bin libc6

Postby zerozero on Fri Oct 19, 2012 5:17 am

first things first :)
can you please give us the output of
Code: Select all
inxi -Sr
we will see the update issues after

Edit: also i merged both topics, if you think a topic is misplaced please reported to the team (use the ! on the top of the post)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

Re: problem with installing/dependencies... libc-bin libc6

Postby phuchungbhutia on Wed Oct 31, 2012 4:42 am

Code: Select all
  inxi -Sr
System:    Host server Kernel 3.2.0-2-486 i686 (32 bit) Distro Linux Mint Xfce Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb [arch=amd64,i386] [arch=amd64,i386] http://packages.linuxmint.com/ maya main upstream import
           deb [arch=amd64,i386] [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb [arch=amd64,i386] [arch=amd64,i386] http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb [arch=amd64,i386] [arch=amd64,i386] http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb [arch=amd64,i386] [arch=amd64,i386] http://archive.canonical.com/ubuntu/ precise partner
           deb [arch=amd64,i386] [arch=amd64,i386] http://packages.medibuntu.org/ precise free non-free
           deb [arch=amd64,i386] [arch=amd64,i386] http://edevelop.org/pkg-e/ubuntu edgy e17
           deb-src http://edevelop.org/pkg-e/ubuntu edgy e17
           Active apt sources in file: /etc/apt/sources.list.d/google.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
phuchungbhutia
Level 1
Level 1
 
Posts: 4
Joined: Tue Oct 16, 2012 3:35 am

Re: problem with installing/dependencies... libc-bin libc6

Postby zerozero on Wed Oct 31, 2012 6:20 am

this is a really mess, sorry to say :shock:
you are using lmde-xfce Kernel 3.2.0-2-486 i686 (32 bit) Distro Linux Mint Xfce Edition but at the same time using the maya/precise repos.
at this point (because we don't know if/which updates went through successfully) i can only recommend to reinstall and this time you either get
LMDE-XFCE >> http://www.linuxmint.com/edition.php?id=101
MAYA XFCE >> http://www.linuxmint.com/edition.php?id=113
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6521
Joined: Tue Jul 07, 2009 2:29 pm

Linux Mint is funded by ads and donations.
 

Return to Update/Upgrade Issues

Who is online

Users browsing this forum: No registered users and 3 guests