<SOLVED> How to disable huge black notification windows?

Forum rules
Before you post please read this

<SOLVED> How to disable huge black notification windows?

Postby eaglesgift on Fri Sep 28, 2012 9:22 am

Sorry if this is a real noob question but I am not sure what they are called so I had no luck searching for an answer. I would like to get rid of the enormous black notification windows with white text that pop-up on the upper right hand side of the screen when you connect to the internet, unplug the ac adapter, receive an instant message when the chat screen is minimised etcetera.

If anybody knows what I am talking about, is there a simple way to disable them?

Thanks
Last edited by eaglesgift on Fri Sep 28, 2012 12:28 pm, edited 1 time in total.
eaglesgift
Level 1
Level 1
 
Posts: 6
Joined: Thu Sep 06, 2012 7:16 am

Linux Mint is funded by ads and donations.
 

AW: How to disable huge black notification windows?

Postby teilnehmer on Fri Sep 28, 2012 10:50 am

Regarding chat I believe there's an option in chat options wether you want events to trigger a notification or not. Check the settings for your chat program, it might be in there.
I don't know how to generally disable them altogether, though.
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 98
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: How to disable huge black notification windows?

Postby DrHu on Fri Sep 28, 2012 11:04 am

You might be able to overide it, I think you are talking about the pop-up notification box (the colors depend on your desktop theme), which appears for a specific few seconds: I get mine for mounting usb flash drives etc and a wireless network connection/availability
--it is a system wide application alert, which I mentally am able to ignore

However you might be able to overide its operation via a gnome applet
http://linux.softpedia.com/get/Desktop- ... 3650.shtml
--if not then the advanced configuration of the desktop which is available within xfce should direct you to some item, I might search for notification or systray or popup..


I am not on that system right now, so I can't search for the data specifically..
User avatar
DrHu
Level 16
Level 16
 
Posts: 6783
Joined: Wed Jun 17, 2009 8:20 pm

Re: How to disable huge black notification windows?

Postby eaglesgift on Fri Sep 28, 2012 11:19 am

Hi, thanks to both of you for your replies. Yes I'm talking about the rectangular notification windows that pop up for a few seconds; only sometimes (as with power manager) they keep popping up and seem reticent to go away.

I've been looking through the Settings editor for Xfconf but I can't see any likely candidates in there. I'm sure it must be in there somewhere though.

I'm using Pidgin and I can't find anywhere to turn off notifications in there either. Maybe I am just having a bad day. I'll keep looking and try that GNotify app as well.

Cheers
eaglesgift
Level 1
Level 1
 
Posts: 6
Joined: Thu Sep 06, 2012 7:16 am

Re: How to disable huge black notification windows?

Postby eaglesgift on Fri Sep 28, 2012 11:44 am

OK, I found how to turn them off in Pidgin: tools > plugins, then uncheck the libnotify popup box. For the Xfce power manager it's >preferences and uncheck the Show notifications to notify about the battery state box. Couldn't see any way to turn the Internet connection one off.

From some more googling it seems that notify-osd is responsible for these notification bubbles and you can disable them all by renaming the "/usr/share/dbus-1/services/org.freedesktop.Notifications.service" file (adding .disabled to the end was suggested)

Hope that might be of some use to anybody else that doesn't like them. I haven't tried to disable them all as the power manager and the chat ones were the only ones that were bothering me so I can't vouch for that method.

There's nothing particularly wrong with them but if you are having a discreet chat when you aren't supposed to be, the last thing you need is a huge bubble appearing with a message from somebody! :)

Thanks for your time again

Cheers

EDIT: Should I change the title of the thread to solved or would it be better for me to try changing that file name and testing it first? (Perhaps nobody's really interested lol)

EDIT2: Well, as I've got nothing better to do, I renamed the file as suggested and after a reboot it worked. At least I'm happy :)
Last edited by eaglesgift on Fri Sep 28, 2012 12:24 pm, edited 1 time in total.
eaglesgift
Level 1
Level 1
 
Posts: 6
Joined: Thu Sep 06, 2012 7:16 am

AW: How to disable huge black notification windows?

Postby teilnehmer on Fri Sep 28, 2012 12:16 pm

Hello secretive messenger,

glad things worked out for you! :)

Jan
User avatar
teilnehmer
Level 2
Level 2
 
Posts: 98
Joined: Sat May 14, 2011 4:19 am
Location: Germany

Re: How to disable huge black notification windows?

Postby eaglesgift on Fri Sep 28, 2012 12:26 pm

Thanks Jan, I guess I should have looked a bit harder first.
eaglesgift
Level 1
Level 1
 
Posts: 6
Joined: Thu Sep 06, 2012 7:16 am

Re: <SOLVED> How to disable huge black notification windows?

Postby jjaythomas on Fri Oct 19, 2012 9:29 pm

Forgot about this one.... needed also in LMDE-Xfce

can't totally disable notafications
But Can in LMDE atleast
install package 'xfce-notifyd' then have a GUI in *settings>notifications* where can set to show to only one(1) second. Can also use opacity (opposite transparency) to hide it (tho still their). :wink:

J.Jay
jjaythomas
Level 5
Level 5
 
Posts: 597
Joined: Sun Mar 07, 2010 12:52 pm

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 0 guests