wireless not 100%

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

wireless not 100%

Postby myrjon1 on Sun Oct 21, 2012 7:48 pm

win 7 hard wired and wireless are appro 50 kbps (speedtest.net)
liinux mint and some other versions get approx 50kbps wired and only 23 kbps approx (speedtest.net)
i only use wireless ,and the router is only 5 feet from my desk!
Is there a way to tweak any settings? »



HP Pavilion dv7-3162nr Entertainment Notebook PC
quailcom athero ar9285 802.11b/g/n
myrjon1
Level 2
Level 2
 
Posts: 62
Joined: Thu Dec 23, 2010 10:07 am

Linux Mint is funded by ads and donations.
 

Re: wireless not 100%

Postby rockcreektech on Sun Oct 21, 2012 8:15 pm

Have you tried this:

http://www.unixmen.com/resolve-slow-connexion-when-using-wifi-in-ubuntu-1104-natty-narwhal/


Read through the comments at the bottom of the page if you don't have success with the three methods and Good Luck!
rockcreektech
Level 1
Level 1
 
Posts: 10
Joined: Sun Oct 21, 2012 6:14 pm
Location: I'm not sure where I am, but I know where my towel is.

Re: wireless not 100%

Postby myrjon1 on Mon Oct 22, 2012 4:55 pm

rockcreektech i tryed all on link (same proob)
myrjon1
Level 2
Level 2
 
Posts: 62
Joined: Thu Dec 23, 2010 10:07 am

Re: wireless not 100%

Postby rockcreektech on Mon Oct 22, 2012 8:52 pm

I really expected the "nohwcrypt=1" trick to fix it for you. Did you get any error messages as you entered each command that might have indicated something didn't go as planned?

Could you run the following commands from the command line one at a time and post the results in "code" tags:

Code: Select all
cat /etc/lsb-release; uname -a
lspci -nnk | grep -iA2 net
iwconfig
rfkill list all
lsmod
rockcreektech
Level 1
Level 1
 
Posts: 10
Joined: Sun Oct 21, 2012 6:14 pm
Location: I'm not sure where I am, but I know where my towel is.

Re: wireless not 100%

Postby myrjon1 on Tue Oct 23, 2012 6:26 pm

when i did sudo -s gksu gedit /etc/modprobe.d/ath9k.conf the page was empty so i added options ath9k nohwcrypt=1to file.......



Code: Select all
chris@chris-HP-Pavilion-dv7-Notebook-PC ~ $ cat /etc/lsb-release; uname -aDISTRIB_ID=LinuxMint
DISTRIB_RELEASE=13
DISTRIB_CODENAME=maya
DISTRIB_DESCRIPTION="Linux Mint 13 Maya"
Linux chris-HP-Pavilion-dv7-Notebook-PC 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 athlon i386 GNU/Linux


Code: Select all
hris@chris-HP-Pavilion-dv7-Notebook-PC ~ $ lspci -nnk | grep -iA2 net
08:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
   Subsystem: Hewlett-Packard Company U98Z062.10 802.11bgn Wireless Half-size Mini PCIe Card [103c:303f]
   Kernel driver in use: ath9k
--
09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
   Subsystem: Hewlett-Packard Company Device [103c:3638]
   Kernel driver in use: r8169

Code: Select all
chris@chris-HP-Pavilion-dv7-Notebook-PC ~ $ iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"toby star" 
          Mode:Managed  Frequency:2.452 GHz  Access Point: 20:AA:4B:C7:54:58   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-39 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:212   Missed beacon:0

eth0      no wireless extensions.

Code: Select all
chris@chris-HP-Pavilion-dv7-Notebook-PC ~ $ rfkill list all
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Code: Select all
chris@chris-HP-Pavilion-dv7-Notebook-PC ~ $ lsmod
Module                  Size  Used by
pci_stub               12550  1
vboxpci                22882  0
vboxnetadp             13328  0
vboxnetflt             27211  0
vboxdrv               252189  3 vboxpci,vboxnetadp,vboxnetflt
snd_hda_codec_hdmi     31775  1
rfcomm                 38139  0
bnep                   17830  2
bluetooth             158438  10 rfcomm,bnep
parport_pc             32114  0
ppdev                  12849  0
joydev                 17393  0
binfmt_misc            17292  1
hp_wmi                 13652  0
sparse_keymap          13658  1 hp_wmi
uvcvideo               67203  0
videodev               86588  1 uvcvideo
snd_hda_codec_idt      60251  1
snd_seq_midi           13132  0
snd_rawmidi            25424  1 snd_seq_midi
snd_hda_intel          32765  4
snd_hda_codec         109562  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
psmouse                87140  0
ir_lirc_codec          12739  0
lirc_dev               18700  1 ir_lirc_codec
snd_pcm                80845  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi_event     14475  1 snd_seq_midi
serio_raw              13027  0
ir_mce_kbd_decoder     12681  0
ir_sony_decoder        12462  0
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
ir_jvc_decoder         12459  0
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
ir_rc6_decoder         12459  0
k10temp                12990  0
ir_rc5_decoder         12459  0
snd_timer              28931  2 snd_pcm,snd_seq
arc4                   12473  2
sp5100_tco             13495  0
i2c_piix4              13093  0
snd                    62064  18 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_rawmidi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_seq,snd_seq_device,snd_timer
rc_rc6_mce             12454  0
ir_nec_decoder         12459  0
radeon                729591  3
ath9k                 117425  0
ene_ir                 18019  0
ttm                    65344  1 radeon
rc_core                21263  10 ir_lirc_codec,ir_mce_kbd_decoder,ir_sony_decoder,ir_jvc_decoder,ir_rc6_decoder,ir_rc5_decoder,rc_rc6_mce,ir_nec_decoder,ene_ir
video                  19068  0
drm_kms_helper         45466  1 radeon
mac80211              436455  1 ath9k
ath9k_common           13781  1 ath9k
ath9k_hw              391523  2 ath9k,ath9k_common
drm                   197692  5 radeon,ttm,drm_kms_helper
ath                    19387  3 ath9k,ath9k_common,ath9k_hw
soundcore              14635  1 snd
mac_hid                13077  0
i2c_algo_bit           13199  1 radeon
snd_page_alloc         14115  2 snd_hda_intel,snd_pcm
cfg80211              178679  3 ath9k,mac80211,ath
hp_accel               25728  0
wmi                    18744  1 hp_wmi
shpchp                 32325  0
lis3lv02d              19268  1 hp_accel
input_polldev          13648  1 lis3lv02d
lp                     17455  0
parport                40930  3 parport_pc,ppdev,lp
usbhid                 41906  0
hid                    77367  1 usbhid
r8169                  56321  0
myrjon1
Level 2
Level 2
 
Posts: 62
Joined: Thu Dec 23, 2010 10:07 am

Re: wireless not 100%

Postby rockcreektech on Tue Oct 23, 2012 9:52 pm

Type the following command into a terminal without rebooting and check your speed again:

Code: Select all
sudo iwconfig wlan0 rate 54M


If it does seem to fix it, we'll work on making it permanent.

Also I noticed you're still running kernel version 3.2.0-23. Is there any specific reason for not upgrading to the latest kernel? If not, you might want to trying doing the following as well:

Code: Select all
sudo apt-get update
sudo apt-get dist-upgrade
rockcreektech
Level 1
Level 1
 
Posts: 10
Joined: Sun Oct 21, 2012 6:14 pm
Location: I'm not sure where I am, but I know where my towel is.

Re: wireless not 100%

Postby myrjon1 on Wed Oct 24, 2012 5:29 pm

rockcreektech i did the -get update
and dist-upgrade, did
sudo iwconfig wlan0 rate 54M
and had no change
myrjon1
Level 2
Level 2
 
Posts: 62
Joined: Thu Dec 23, 2010 10:07 am

Re: wireless not 100%

Postby myrjon1 on Sun Oct 28, 2012 10:13 am

tryed different solutions and no luck// any help ?
myrjon1
Level 2
Level 2
 
Posts: 62
Joined: Thu Dec 23, 2010 10:07 am

Re: wireless not 100%

Postby rockcreektech on Sat Dec 08, 2012 3:14 pm

Sorry I've taken so long to respond. I've been transitioning into a new job, and I'm not sure if I'm coming or going. I'm afraid I've exhausted the extent of my knowledge on this subject, but there is a thread on the Ubuntu forums for addressing wireless issues on Ubuntu. Not sure if he'll help with Linux Mint, but it might be worth a try. You can find the thread here:

http://ubuntuforums.org/forumdisplay.php?f=336

Instructions for using the thread are here:

http://ubuntuforums.org/showthread.php?p=6183681

Sorry I couldn't get this fixed for you. If anyone else wants to chime in feel free. Hope you find a solution and can post it back here when you do!
rockcreektech
Level 1
Level 1
 
Posts: 10
Joined: Sun Oct 21, 2012 6:14 pm
Location: I'm not sure where I am, but I know where my towel is.

Re: wireless not 100%

Postby sdibaja on Thu Dec 13, 2012 1:36 pm

myrjon1

having the same problem here with another DV7
went thru the steps you describe here also
let us know if you find a fix
User avatar
sdibaja
Level 2
Level 2
 
Posts: 76
Joined: Sun May 08, 2011 12:57 pm
Location: Mexico

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 9 guests