32bit pulseaudio alsa plugin on 64bit LMDE (WINE)

Questions about applications and software
Forum rules
Before you post please read this

32bit pulseaudio alsa plugin on 64bit LMDE (WINE)

Postby slightlyrandom on Thu Oct 25, 2012 2:32 am

I'm having some issues getting sound to run properly with WINE on LMDE 64bit.

Sound is flawless everywhere else.

I've set up multiarch, per viewtopic.php?f=190&t=111026, and WINE installs and runs (aptitude install wine). There is no sound, however, until I grab and dpkg -i http://packages.debian.org/squeeze/lib32asound2-plugins , and link (ln -s) the installed .so files from /usr/lib32/alsa-lib/ into /usr/lib/i386-linux-gnu/alsa-lib/

This works, apart from the fact that lib32asound2-plugins is 1.0.23, with no google-able updates, and when I run a program with wine, I get varying degrees of stuttery audio (from nearly none to unbearable, depending on game) and this message:

Code: Select all
err:winediag:AUDDRV_GetAudioEndpoint PulseAudio "default" -22 without handle_underrun. Audio may hang. Please upgrade to alsa_plugins >= 1.0.24


along with a fair few of these:
Code: Select all
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred


The package I think fixes this, libasound2-plugins:i386 (1.0.25) is in the repository, but trying to install it leads me into dependency issues, like so (from clean):

Code: Select all
aptitude install libasound2-plugins:i386
The following NEW packages will be installed:
  libaacplus2:i386{a} libasound2:i386{a} libasound2-plugins:i386
  libasyncns0:i386{a} libattr1:i386{a} libavcodec53:i386{a}
  libavutil51:i386{a} libc6:i386{a} libc6-i686:i386{a} libcap2:i386{ab}
  libcrystalhd3:i386{a} libdbus-1-3:i386{a} libdirac-encoder0:i386{a}
  libfaac0:i386{a} libflac8:i386{a} libgcc1:i386{a} libgsm1:i386{a}
  libice6:i386{a} libjack-jackd2-0:i386{a} libjson0:i386{a}
  libmp3lame0:i386{a} libogg0:i386{a} libopencore-amrnb0:i386{a}
  libopencore-amrwb0:i386{a} libopenjpeg2:i386{ab} liborc-0.4-0:i386{a}
  libpulse0:i386{a} libsamplerate0:i386{a} libschroedinger-1.0-0:i386{a}
  libsm6:i386{a} libsndfile1:i386{a} libspeex1:i386{a} libspeexdsp1:i386{a}
  libstdc++6:i386{a} libtheora0:i386{a} libuuid1:i386{a} libva1:i386{a}
  libvo-aacenc0:i386{a} libvo-amrwbenc0:i386{a} libvorbis0a:i386{a}
  libvorbisenc2:i386{a} libvpx1:i386{a} libwrap0:i386{a} libx11-6:i386{a}
  libx11-xcb1:i386{a} libx264-124:i386{a} libxau6:i386{a} libxcb1:i386{a}
  libxdmcp6:i386{a} libxext6:i386{a} libxi6:i386{a} libxtst6:i386{a}
  libxvidcore4:i386{a} zlib1g:i386{a}
0 packages upgraded, 54 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.2 MB/20.5 MB of archives. After unpacking 48.2 MB will be used.
The following packages have unmet dependencies:
 libcap2 : Conflicts: libcap2:i386 but 1:2.22-1 is to be installed.
 libcap2:i386 : Conflicts: libcap2 but 1:2.22-1 is installed.
 libopenjpeg2 : Conflicts: libopenjpeg2:i386 but 1.3+dfsg-4.1 is to be installed.
 libopenjpeg2:i386 : Conflicts: libopenjpeg2 but 1.3+dfsg-4.1 is installed.


The issue has been addressed (briefly) elsewhere:
http://help.lockergnome.com/linux/Bug-6 ... 54686.html
http://us.generation-nt.com/answer/bug- ... 29602.html

Including this, which I haven't been able to do (correctly, at least):
If you get libopenjpeg2 from unstable, you should be able to install it.



When I try, I get something like this:
Code: Select all
apt-get install libcap2:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  cdrdao crda finger gir1.2-polkit-1.0 iputils-tracepath iw libao-common
  libao4 libavahi-compat-libdnssd1 libbrasero-media3-1 libdotconf1.0 libg15-1
  libg15daemon-client1 libg15render1 liblinear-tools liblinear1 libmate-common
  libmatecanvas libmatecomponent libmateconf libmatecorba libmatedesktop
  libmatekeyring libmatemenu libnl-route-3-200 libnm-gtk-common libnm-gtk0
  libprotobuf7 libsonic0 libspeechd2 libsvm-tools libtasn1-3-bin
  libtracker-sparql-0.14-0 mate-conf-common mate-corba mate-menus
  mate-mime-data mate-vfs-common nmap python-cddb python-corba
  python-keybinder python-keyring python-mate-desktop python-mate-menu
  python-mmkeys python-mutagen scummvm-data wireless-regdb
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libattr1:i386 libc6:i386 libc6-i686:i386 libgcc1:i386
Suggested packages:
  glibc-doc:i386 locales:i386
The following packages will be REMOVED:
  accountsservice apache2.2-bin aptdaemon apturl at-spi avahi-daemon
  bind9-host bluez brasero chromium colord comix consolekit dbus dbus-x11
  dnsutils espeak evolution-data-server exaile gconf-defaults-service gconf2
  gcr gdebi gimp giver gksu gnome-applets gnome-applets-data gnome-bluetooth
  gnome-contacts gnome-disk-utility gnome-keyring gnome-media
  gnome-media-common gnome-nettool gnome-panel gnome-panel-data
  gnome-search-tool gnome-session-bin gnome-system-log gnome-system-tools
  gnome-themes-standard gstreamer0.10-gconf gstreamer0.10-gnomevfs
  gstreamer0.10-plugins-good gstreamer0.10-pulseaudio gufw gvfs gvfs-backends
  gvfs-daemons hal hplip inkscape kupfer libapache2-mod-dnssd
  libasound2-plugins libbind9-60 libbind9-80 libbonoboui2-0
  libcanberra-gtk-module libcap2 libcap2-bin libdns66 libdns69 libdns81
  libespeak1 libfarstream-0.1-0 libfluidsynth1 libfolks-eds25 libgdu0
  libgegl-0.2-0 libgksu2-0 libgnome-media-profiles-3.0-0 libgnome-media0
  libgnome-speech7 libgnome-vfs2.0-cil libgnome2-0 libgnome2-common
  libgnome2.24-cil libgnomeui-0 libgnomevfs2-0 libgnomevfs2-common
  libgnomevfs2-extra libgweather-3-0 libgweather-common libisc60 libisc62
  libisc83 libisccc60 libisccc80 libisccfg60 libisccfg62 libisccfg82
  liblwres60 liblwres80 libmate libmatecomponentui libmatepanelapplet
  libmateui libmatevfs libmjpegtools-1.9 libnss-mdns libnss-winbind
  liboobs-1-4 liboobs-1-5 libpam-winbind libpolkit-gtk-1-0
  libpulse-mainloop-glib0 libpulse0 libpurple-bin libpurple0 libreoffice-gnome
  libsdl-image1.2 libsdl-mixer1.2 libsdl-ttf2.0-0 libsdl1.2debian libsmbclient
  libsmpeg0 libsystemd-login0 libthunarx-2-0 libunique-1.0-0 libunique-3.0-0
  libxfce4ui-1-0 libxfconf-0-2 mate-conf mate-keyring mate-vfs
  mint-meta-debian-core mint-meta-debian-xfce mintdesktop mintinstall mintmenu
  mintwelcome mplayer2 mumble nautilus-open-terminal network-manager
  network-manager-gnome ntp orage pavucontrol pidgin pidgin-facebookchat
  pidgin-skype policykit-1 policykit-1-gnome printer-driver-postscript-hp
  pulseaudio pulseaudio-module-x11 pulseaudio-utils python-aptdaemon
  python-aptdaemon.gtk3widgets python-gnome2 python-mate python-pygame rtkit
  samba samba-common-bin scummvm seahorse software-properties-gtk
  speech-dispatcher system-config-printer system-tools-backends
  telepathy-salut thunar thunar-archive-plugin thunar-media-tags-plugin
  thunar-shares-plugin thunar-thumbnailers thunar-volman tomboy udisks upower
  winbind xchat-common xfce4-appfinder xfce4-mixer xfce4-notifyd xfce4-panel
  xfce4-places-plugin xfce4-power-manager xfce4-power-manager-plugins
  xfce4-screenshooter xfce4-session xfce4-settings xfce4-utils
  xfce4-xkb-plugin xfconf xfdesktop4 xfwm4
The following NEW packages will be installed:
  libattr1:i386 libc6:i386 libc6-i686:i386 libcap2:i386 libgcc1:i386
0 upgraded, 5 newly installed, 191 to remove and 0 not upgraded.
Need to get 13.7 kB/5,250 kB of archives.
After this operation, 592 MB disk space will be freed.
Do you want to continue [Y/n]?



Does anyone have some thoughts on the issues?
slightlyrandom
Level 1
Level 1
 
Posts: 1
Joined: Thu Oct 25, 2012 1:38 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 7 guests