Mint4win install tries to mount my NTFS drive multiple times

Questions about Grub, UEFI,the liveCD and the installer
Forum rules
Before you post please read this

Mint4win install tries to mount my NTFS drive multiple times

Postby Elaugaufein on Thu Oct 25, 2012 4:35 pm

Hi,

I recently got a new Clevo laptop.
Will briefly list the stuff that might be relevant:
2 SSDs in Raid 0. (The drives are Intel and I start the RAID config with Ctrl-I, not sure if its fake/real/software, if that makes a difference and someone can let me know how to check I will).
Does have a built in TPM.
UEFI system.

I attempted to do a Dual boot of Linux Mint 13 the normal way. The installation partition manager was odd (wouldn't let me resize partitions , didn't know the used space of any partiations and would show the partitions multiple times (it'd show the EFI partition and the NTFS partition under an overall mapper and then it'd show each again under a seperate mapper), so I used Gparted to setup the partitions (The system reserved NTFS partition, the NTFS with Windows,1 swap partition , and a ex4 partition for Linux), long story short the installation failed, I presumed it was a hardware thing and decided to install Mint4win instead, so I reverted back to the 2 original partitions, rebooted into windows , put in the DVD and said to install in windows. All was good. Restart my computer, it goes into Mint installation, it then drops into initramfs with the errors

Mount is denied because the NTFS volume is exclusively opened.
The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command.
mount: mounting /dev/dm-2 on /tmpmountpoint failed: No such device

Cound not find the installation files /linuxmint/install/custom-installation
(Blah Blah about restarting windows and running chkdsk /r).

I started windows, ran chkdsk /r as it said, which restarted my computer and said there were no problems.

So I've gone into the Mint installation again and it still fails.

The weird things are
1) As far as I know I don't *have* a dev/dm-2 nor does mount show any such thing
2) My NTFS drive is already mounted as /isodevice and in initramfs I can go into it, look around and even navigate to /linuxmint/install/custom-installation , so the device can definitely be read. (This may be why it says its exclusively locked even?)

I'm stumped. Any advice on how to fix this/get this to finish ?

Thanks
Elaugaufein
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 28, 2012 5:37 am

Linux Mint is funded by ads and donations.
 

Re: Mint4win install tries to mount my NTFS drive multiple t

Postby xenopeek on Fri Oct 26, 2012 3:18 am

To answer the first question, it's fake raid. As to installing with mint4win to raid, that's not officially supported. mint4win is based on wubi, Ubuntu's Windows installer, so possibly you can find help for wubi and raid.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 14561
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 12 guests