Live-cd install inside KVM. Virtio disk. Bugfix reported.

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read this

Live-cd install inside KVM. Virtio disk. Bugfix reported.

Postby tecnico on Mon Sep 24, 2012 8:40 pm

The installer on a 201204 LMDE Live CD is unable to see a virtio disk when running inside a KVM image (disk /dev/vda for example). This error and the bug fix was reported and acknowledged on the following post at least by Apr/2011. The fix is to run the command $inxi -U (as root). Hopefully this simple command can be added to the next Live-CD release.

https://bugs.launchpad.net/linuxmint/+bug/694729

Copy and paste of the relevant post from the URL above:

====
Justin Krehel (jkrehel) wrote on 2011-04-21:
This has been added. In the live environment, you can open a terminal and issue the following command:

sudo inxi -U

This will update the inxi script, which is used in live-installer for disk detection. Subsequent versions of LM Debian Edition will contain the updated script, but for now this should handle the issue.

Thank you for your patience.

- Justin
=====
tecnico
Level 1
Level 1
 
Posts: 3
Joined: Mon Sep 24, 2012 8:29 pm

Linux Mint is funded by ads and donations.
 

Re: Live-cd install inside KVM. Virtio disk. Bugfix reported

Postby justin on Fri Oct 26, 2012 4:20 pm

That's pretty amazing this problem still exists, considering I helped patch inxi for virtio over a year and a half ago, and all someone had to do was run an inxi -U from the live environment before spinning the ISO.
justin
Level 1
Level 1
 
Posts: 38
Joined: Thu Nov 12, 2009 10:13 pm

Re: Live-cd install inside KVM. Virtio disk. Bugfix reported

Postby tecnico on Fri Oct 26, 2012 5:00 pm

I guess they didn't get the memo :) Thanks for taking the time to post your original solution btw, it was very helpful.
tecnico
Level 1
Level 1
 
Posts: 3
Joined: Mon Sep 24, 2012 8:29 pm

Re: Live-cd install inside KVM. Virtio disk. Bugfix reported

Postby justin on Fri Oct 26, 2012 5:37 pm

No problem tecnico - I'm glad my solution was useful to you.
justin
Level 1
Level 1
 
Posts: 38
Joined: Thu Nov 12, 2009 10:13 pm


Return to Installation & Boot

Who is online

Users browsing this forum: No registered users and 4 guests