rackarrack no sound

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

rackarrack no sound

Postby bartbar on Wed Oct 31, 2012 2:37 pm

Hello,

I have a standard Mint 13 (Cinnamon) install and would like to use rackarrack (the guitar amp). Now I need to get jack working for this and although I did a lot of homework and tried to follow several tutorials I just don't get it to work.

The details: I have a UGM96 USB audio adapter (http://www.esi-audio.com/products/ugm96/) that I managed to setup with Alsa. So my computer uses this as soundcard all right. With Alsa I can record my guitar plugged into the UGM96, in Audacity. So far so good. Only thing is I have no guitar affects. Therefore I'd like to use rakarrack, which needs jack.

But now, if I try to use Jack, it all goes wrong. I can start jackd with qjackctl, I can start rakarrack, I can connect inputs and outputs and such (in fact it connects automatically), but ... no sound at all. I did find in the qjackctl settings my USB audio card (hw:1 UGM96) and tried all sorts of tweaking but no good. And if I try to use Audacity with Jack, no input either. I also added myself to the audio group.

I put "pasuspender -- " in the qjackctl settings, to no avail. I tried with and without pulseaudio-module-jack installed and edited in /etc/pulse/default.pa, no difference. It just doesn't give a peep whatever I do :(

Can anyone help, please?

Here is the output from the qjackctl messages:
5:05.289 Baie de brassage désactivée.
19:45:05.304 Réinitialisation des statistiques.
19:45:05.313 Changement des connexions ALSA.
19:45:05.321 DBUS : le service est disponible (org.jackaudio.service soit jackdbus).
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
19:45:08.827 DBUS : le serveur JACK démarre…
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started
19:45:08.833 DBUS : le serveur JACK a été démarré (org.jackaudio.service soit jackdbus).
Wed Oct 31 19:45:08 2012: Starting jack server...
Wed Oct 31 19:45:08 2012: JACK server starting in realtime mode with priority 10
Wed Oct 31 19:45:08 2012: ERROR: Cannot lock down 82246176 byte memory area (Cannot allocate memory)
Wed Oct 31 19:45:08 2012: control device hw:0
Wed Oct 31 19:45:08 2012: control device hw:0
Wed Oct 31 19:45:08 2012: Acquired audio card Audio0
Wed Oct 31 19:45:08 2012: creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
Wed Oct 31 19:45:08 2012: control device hw:0
Wed Oct 31 19:45:08 2012: configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
Wed Oct 31 19:45:08 2012: ALSA: final selected sample format for capture: 32bit integer little-endian
Wed Oct 31 19:45:08 2012: ALSA: use 2 periods for capture
Wed Oct 31 19:45:08 2012: ALSA: final selected sample format for playback: 32bit integer little-endian
Wed Oct 31 19:45:08 2012: ALSA: use 2 periods for playback
Wed Oct 31 19:45:08 2012: ERROR: Cannot use real-time scheduling (RR/10)(1: Operation not permitted)
Wed Oct 31 19:45:08 2012: ERROR: AcquireSelfRealTime error
Wed Oct 31 19:45:08 2012: graph reorder: new port 'system:capture_1'
Wed Oct 31 19:45:08 2012: New client 'system' with PID 0
Wed Oct 31 19:45:08 2012: graph reorder: new port 'system:capture_2'
Wed Oct 31 19:45:08 2012: graph reorder: new port 'system:playback_1'
Wed Oct 31 19:45:08 2012: graph reorder: new port 'system:playback_2'
19:45:10.991 Changement des connexions JACK.
19:45:10.992 Configuration du serveur enregistrée dans « /home/casa/.jackdrc ».
19:45:10.992 Réinitialisation des statistiques.
19:45:11.009 Client activé.
19:45:11.038 Changement du graphique des connexions JACK.
Cannot lock down 82246176 byte memory area (Cannot allocate memory)
Wed Oct 31 19:45:10 2012: Saving settings to "/home/casa/.config/jack/conf.xml" ...
Wed Oct 31 19:45:10 2012: New client 'qjackctl' with PID 2862
bartbar
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 06, 2011 6:30 am
Location: Brussels, Belgium

Linux Mint is funded by ads and donations.
 

Re: rackarrack no sound

Postby bartbar on Thu Nov 01, 2012 3:43 am

I tried Ubuntustudio (Live DVD) and it just worked right away.

So thanks for the links, I really appreciate your help but I really can't spend half my life studying this stuff.

BTW, I succeeded in getting rid of the "cannot allocate memory" fault (in Mint) by doing
Code: Select all
sudo dpkg-reconfigure -p high jackd2
and choosing "Yes" (see http://ubuntuforums.org/showthread.php?t=1637399)

So I don't have any error messages in jack but still not one peep out of my system.

I'm giving up and am going to install Ubuntustudio next to Mint. One day then I'll switch to one of the two depending on which gives me the least problems.

So I'm still interested in a fix for Mint if anybody can point out precisely the solution. I still find Mint a tremendously fabulous distribution and would recommend it to everyone. I haven't experienced one single problem in the last few years, it's just this jack-thing now, but one has to admit this is a very precise and musician-specific issue and shouldn't be used to think negative of Mint.
bartbar
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 06, 2011 6:30 am
Location: Brussels, Belgium

Re: rackarrack no sound

Postby 900i on Thu Nov 01, 2012 6:31 am

I was going to suggest Ubuntu Studio. I had most success with it.
Intel i7 3770 LMDE Mate 64
User avatar
900i
Level 6
Level 6
 
Posts: 1014
Joined: Sat Nov 18, 2006 9:30 am
Location: Wakefield, UK

Re: rackarrack no sound

Postby bartbar on Thu Nov 01, 2012 11:43 am

Yes, Ubuntu Studio works perfectly with jack out of the box, exact same hardware setup of course, just another partition on the same drive.
I tried to copy the exact same settings that work in Ubuntustudio in Mint, but it just doesn't work. I'm also using the low-latency kernel in Mint, to no avail. I even uninstalled aal jack-related packages completely, then reinstalled - but it remembered the config file apparently.

I did manage to break my jack setup once in Ubuntu Studio also, and reinstalled it to start fresh over. So it's really very "fragile" as a setup, this jack stuff.

Hope I don't break it again - and still hope someone can hold my hand to get it working in Mint. I love Mint :)
bartbar
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 06, 2011 6:30 am
Location: Brussels, Belgium

Re: rackarrack no sound

Postby bartbar on Thu Nov 01, 2012 11:50 am

And to be complete, I just nticed that even in Ubuntu Studio if I have Firefox running I have no sound from rakarrack. It works again after I close all programs, unplug and replug my UGM96 USB audio adapter, then launch qjackctl and then rakarrack.
bartbar
Level 1
Level 1
 
Posts: 13
Joined: Wed Jul 06, 2011 6:30 am
Location: Brussels, Belgium


Return to Sound, Multimedia, & Codecs

Who is online

Users browsing this forum: No registered users and 2 guests