Re: Hibernation in Linux mint 13 ? [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Re: Hibernation in Linux mint 13 ? [SOLVED]

Postby Incentive I.C on Sun Sep 09, 2012 5:07 pm

I have a question involving how i can get hibernation on the shutdown menu in Linux Mint 13 Cinnamon. I know it was disabled in newer versions of Ubuntu for i guess it causing problems when some people resume from it. Linux mint 13 being based off it it had to be disabled in too. I have done it via terminal and I can get in and out of it no problems at all. I am also curious to know if it is disabled in Linux Mint Debian Edition also.

Cheers and have a Great day!
Last edited by Incentive I.C on Mon Dec 24, 2012 4:16 pm, edited 2 times in total.
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Linux Mint is funded by ads and donations.
 

Re: Hibernation in Linux mint 13 ?

Postby Incentive I.C on Sun Sep 09, 2012 6:08 pm

"Last edited by Vincent Vermeulen on Sun Sep 09, 2012 4:51 pm, edited 1 time in total.
Reason: Moved here and changed subject to reflect question is about LMDE"

Oops sorry I mint(ha ha ha! ) to put Linux mint 13 in the title instead of Debian edition.I am talking about the Ubuntu edition

I have already done that so if you could be so kind as to move it back to were it was that would be nice. This question's mainly about the "Maine" edition( ha ha ha that was terrible!) if i need to take the LMDE question out and post it here please tell me.
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ?

Postby ddurdle on Mon Sep 10, 2012 9:04 am

Hibernation is not disabled in any Linux Mint distribution (including LMDE). I would hazard the same is the case with Ubuntu.

In the above mentioned distributions, if you don't see a Hibernate option in the shutdown menu, it's because you don't have a swap partition created or active. Since hibernation will make use of the swap, it needs to exist and be active. If you're not seeing it, it's because linux isn't seeing the swap.
ddurdle
Level 3
Level 3
 
Posts: 106
Joined: Sat Dec 17, 2011 10:03 am

Re: Hibernation in Linux mint 13 ?

Postby Incentive I.C on Fri Sep 21, 2012 10:34 pm

"Hibernation is not disabled in any Linux Mint distribution (including LMDE)"
You sure about that?Google "Add hibernate button to Linux Mint 13" and tell me all the search results you get.(okay it technically isn't "disabled" but it is not accessible with out the terminal, its even blanked out in the power options.)

"it's because you don't have a swap partition created or active"
I do have a swap of 3.9G.B(3.7G.B Ram usability for me with 4.0G.B being the max) and it does work as I have seen sore to a 87.5K.B before. Why wouldn't I have a working swap? i did all the default in the installion and I can see the swap is also taking a little of my max hard drive space.


"Since hibernation will make use of the swap, it needs to exist and be active. If you're not seeing it, it's because linux isn't seeing the swap."
Like i said I can hibernate just fine. All i want to do is put it in the shutdown menu so i do not have to type in the terminal command every time i want to hibernate....
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ?

Postby axel668 on Sat Sep 22, 2012 4:03 am

Running Mint 13 XFCE here and it seems to be disabled for me, too. I have an active swap partition (shown in conky) but hibernate is greyed out in xfce4-session-shutdown.
I don't mind though, XFCE can remember the session if you want that and booting is almost as fast as restoring form Hibernate.
“A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila” (Mitch Ratcliffe)
User avatar
axel668
Level 3
Level 3
 
Posts: 183
Joined: Wed Jul 08, 2009 11:56 am

Re: Hibernation in Linux mint 13 ?

Postby Incentive I.C on Sun Sep 30, 2012 4:26 pm

axel668 wrote:Running Mint 13 XFCE here and it seems to be disabled for me, too. I have an active swap partition (shown in conky) but hibernate is greyed out in xfce4-session-shutdown.
I don't mind though, XFCE can remember the session if you want that and booting is almost as fast as restoring form Hibernate.


How exactly do i get Mint to remember my session. I am using cinnamon but i would also like to know how i can put the XFCE interface(its a nice interface )on my system,too.
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ?

Postby Incentive I.C on Sat Oct 13, 2012 9:00 pm

bump :(
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ?

Postby Onsen on Mon Oct 29, 2012 6:41 am

Running Linux Mint 13 / Mate.
There is no suspend to disk (hibernation) in the shutdown menu for me either.
I've got 8GB RAM and therefore I gave the Swap partition about 12GB. Turns out that was useless.
My introduction. Free Games for Linux.
User avatar
Onsen
Level 1
Level 1
 
Posts: 33
Joined: Tue Sep 11, 2012 9:54 am

Re: Hibernation in Linux mint 13 ?

Postby asuarezp on Sun Nov 04, 2012 8:37 pm

I fixed this problem in this way:
1. I followed the instructions found in http://www.linuxandlife.com/2012/06/how ... -mint.html
2. I made sure there were no extra white spaces at the end of the lines.
3. I executed "sudo update-grub".

Good luck!
asuarezp
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 04, 2012 8:27 pm

Re: Hibernation in Linux mint 13 ?

Postby Incentive I.C on Mon Nov 05, 2012 7:20 pm

asuarezp wrote:I fixed this problem in this way:
1. I followed the instructions found in http://www.linuxandlife.com/2012/06/how ... -mint.html
2. I made sure there were no extra white spaces at the end of the lines.
3. I executed "sudo update-grub".

Good luck!


I understand everything except 2
How do you make it so there were no extra spaces after copying and pasting? Turning off some kind of word wrap or did you just write out the whole thing on one line. There is not enough words in the command to not have any extra space after coping and pasting. :?

Thanks for the response!
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ?

Postby edcompsci on Fri Dec 21, 2012 5:32 pm

Another forum's post reminded me that you need to be sure that there are no trailing spaces at the end of each line of the file you save.

Now I'd like to know how to make the power options include it as a timeout option.


The file is:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes


saved as:

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla



Good luck.
www.progave.com
edcompsci
Level 1
Level 1
 
Posts: 7
Joined: Fri Dec 21, 2012 5:25 pm

Re: Hibernation in Linux mint 13 ? [SOLVED]

Postby Incentive I.C on Mon Dec 24, 2012 3:43 pm

edcompsci wrote:Another forum's post reminded me that you need to be sure that there are no trailing spaces at the end of each line of the file you save.

Now I'd like to know how to make the power options include it as a timeout option.


The file is:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes


saved as:

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla



Good luck.
http://www.progave.com



Thanks a bunch that seemed to have finally fixed the problem!
Cheers
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Re: Hibernation in Linux mint 13 ? [SOLVED]

Postby Incentive I.C on Wed Jan 02, 2013 10:30 pm

It also seems that in Linux mint 14 hibernation is back on as default! I guess enough Ubuntu people caused an uproar about it that it finally came back. Even if it fails to work Linux will tell you the problem and take you back to your session. I think it was silly to have it disabled but it is not mints fault :)
The best way to learn from it is break it OS's (is there a plural for OS?) included.
User avatar
Incentive I.C
Level 4
Level 4
 
Posts: 320
Joined: Mon Aug 27, 2012 9:20 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 5 guests