kworker high cpu

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

Important information

kworker high cpu

Postby berezka on Tue Jul 24, 2012 3:40 am

I have installed LMDE Gnome2 64bit ( squeeze setup according http://community.linuxmint.com/tutorial/view/497 ) on new HP workstation. One of two cores is permanently loaded over 80 %

Code: Select all
top | grep kworker
 4171 root      20   0     0    0    0 R   87  0.0   0:21.16 kworker/0:0


Kernel and xorg-server is updated to latest version from squeeze-backports:

Code: Select all
Linux berezka 3.2.0-0.bpo.2-amd64 #1 SMP Fri Jun 29 20:42:29 UTC 2012 x86_64 GNU/Linux


Code: Select all
dpkg -l | grep xorg
ii  xorg                                     1:7.6+8~bpo60+1                        X.Org X Window System
ii  xorg-docs-core                           1:1.5-1                                Core documentation for the X.org X Window System
ii  xorg-sgml-doctools                       1:1.8-2~bpo60+1                        Common tools for building X.Org SGML documentation
ii  xserver-xorg                             1:7.6+8~bpo60+1                        X.Org X server
ii  xserver-xorg-core                        2:1.10.4-1~bpo60+1                     Xorg X server - core server
ii  xserver-xorg-input-all                   1:7.6+8~bpo60+1                        X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev                 1:2.6.0-2~bpo60+1                      X.Org X server -- evdev input driver
ii  xserver-xorg-input-synaptics             1.4.1-1~bpo60+1                        Synaptics TouchPad driver for X.Org server
ii  xserver-xorg-input-wacom                 0.10.10+20110203-1~bpo60+1             X.Org X server -- Wacom input driver
ii  xserver-xorg-video-all                   1:7.6+8~bpo60+1                        X.Org X server -- output driver metapackage
ii  xserver-xorg-video-apm                   1:1.2.3-2~bpo60+1                      X.Org X server -- APM display driver
ii  xserver-xorg-video-ark                   1:0.7.3-2~bpo60+1                      X.Org X server -- ark display driver
ii  xserver-xorg-video-ati                   1:6.14.2-1~bpo60+1                     X.Org X server -- AMD/ATI display driver wrapper
ii  xserver-xorg-video-chips                 1:1.2.4-1~bpo60+1                      X.Org X server -- Chips display driver
ii  xserver-xorg-video-cirrus                1:1.3.2-4~bpo60+1                      X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-fbdev                 1:0.4.2-4~bpo60+1                      X.Org X server -- fbdev display driver
ii  xserver-xorg-video-i128                  1:1.3.4-2~bpo60+1                      X.Org X server -- i128 display driver
ii  xserver-xorg-video-i740                  1:1.3.2-4~bpo60+1                      X.Org X server -- i740 display driver
ii  xserver-xorg-video-intel                 2:2.15.0-3~bpo60+2                     X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-mach64                6.9.0-1~bpo60+1                        X.Org X server -- ATI Mach64 display driver
ii  xserver-xorg-video-mga                   1:1.4.13.dfsg-3~bpo60+1                X.Org X server -- MGA display driver
ii  xserver-xorg-video-neomagic              1:1.2.5-2~bpo60+1                      X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-nouveau               1:0.0.16+git20110411+8378443-1~bpo60+1 X.Org X server -- Nouveau display driver (experimental)
ii  xserver-xorg-video-openchrome            1:0.2.904+svn920-1~bpo60+1             X.Org X server -- VIA display driver
ii  xserver-xorg-video-r128                  6.8.1-5~bpo60+1                        X.Org X server -- ATI r128 display driver
ii  xserver-xorg-video-radeon                1:6.14.2-1~bpo60+1                     X.Org X server -- AMD/ATI Radeon display driver
ii  xserver-xorg-video-rendition             1:4.2.4-2~bpo60+1                      X.Org X server -- Rendition display driver
ii  xserver-xorg-video-s3                    1:0.6.3-4~bpo60+1                      X.Org X server -- legacy S3 display driver
ii  xserver-xorg-video-s3virge               1:1.10.4-4~bpo60+1                     X.Org X server -- S3 ViRGE display driver
ii  xserver-xorg-video-savage                1:2.3.2-3~bpo60+1                      X.Org X server -- Savage display driver
ii  xserver-xorg-video-siliconmotion         1:1.7.5-1~bpo60+1                      X.Org X server -- SiliconMotion display driver
ii  xserver-xorg-video-sis                   1:0.10.3-3~bpo60+1                     X.Org X server -- SiS display driver
ii  xserver-xorg-video-sisusb                1:0.9.4-2~bpo60+1                      X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tdfx                  1:1.4.3-4~bpo60+1                      X.Org X server -- tdfx display driver
ii  xserver-xorg-video-trident               1:1.3.4-2~bpo60+1                      X.Org X server -- Trident display driver
ii  xserver-xorg-video-tseng                 1:1.2.4-2~bpo60+1                      X.Org X server -- Tseng display driver
ii  xserver-xorg-video-vesa                  1:2.3.0-7~bpo60+1                      X.Org X server -- VESA display driver
ii  xserver-xorg-video-vmware                1:11.0.3-2~bpo60+1                     X.Org X server -- VMware display driver
ii  xserver-xorg-video-voodoo                1:1.2.4-2~bpo60+1                      X.Org X server -- Voodoo display driver

dpkg -l | grep mesa
ii  libgl1-mesa-dev                          7.10.3-4~bpo60+1                       free implementation of the OpenGL API -- GLX development files
ii  libgl1-mesa-dri                          7.10.3-4~bpo60+1                       free implementation of the OpenGL API -- DRI modules
ii  libgl1-mesa-glx                          7.10.3-4~bpo60+1                       free implementation of the OpenGL API -- GLX runtime
ii  libglu1-mesa                             7.10.3-4~bpo60+1                       Mesa OpenGL utility library (GLU)
ii  mesa-common-dev                          7.10.3-4~bpo60+1                       Developer documentation for Mesa
ii  mesa-utils                               7.7.1-5                                Miscellaneous Mesa GL utilities



I have googled and tried several solutions.

1. I have added in /etc/modprobe.d/local.conf :
options drm_kms_helper poll=N - did not work for me

2. I have added to /etc/default/grub option : acpi=off.
This action was helpful. The problem is that X can’t start with intel driver (vesa only) and vesa don’t support resolution 1920x1080.

System configuration:
Code: Select all
inxi -F
System:    Host berezka Kernel 3.2.0-0.bpo.2-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
CPU:       Dual core Intel Pentium G850 (-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 11571.3
           Clock Speeds: (1) 2892.838 MHz (2) 2892.838 MHz
Graphics:  Card Intel Sandy Bridge Integrated Graphics Controller X.Org 1.10.4 Res: 1920x1080@60.0hz
           GLX Renderer Mesa DRI Intel Sandybridge Desktop   GLX Version 2.1 Mesa 7.10.3 Direct Rendering Yes
Audio:     Card Intel Cougar Point High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card Intel 82579LM Gigabit Network Connection driver e1000e v: 1.5.1-k at port f080 BusID: 00:19.0
Disks:     HDD Total Size: 500.1GB (7.6% used) 1: /dev/sda WDC_WD5000AAKX 500.1GB
Partition: ID:/ size: 64G used: 6.7G (11%) fs: ext4 ID:/boot size: 1021M used: 81M (9%) fs: ext4
           ID:/home size: 393G used: 29G (8%) fs: ext4 ID:swap-1 size: 8.59GB used: 0.00GB (0%) fs: swap
Info:      Processes 154 Uptime 1:24 Memory 923.3/3854.7MB Runlevel 3 Client Shell inxi 1.4.23


Maybe I have missed something and you have another solutions for this problem? or should I report about this bug somewhere?
berezka
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 20, 2012 5:31 am

Linux Mint is funded by ads and donations.
 

Re: kworker high cpu

Postby berezka on Thu Jul 26, 2012 10:47 am

Update of bios fixed the problem. Topic can be closed
berezka
Level 1
Level 1
 
Posts: 2
Joined: Fri Jan 20, 2012 5:31 am

Re: kworker high cpu

Postby revdjenk on Sat Nov 10, 2012 12:12 pm

berezka,

Can you tell me the 'howto' of this bios update, please? I was affected by this kworker bug a year ago, and it has re-appeared. I tried the same fix that worked for me last time the first one on your list) but it had no affect.
I then installed the phc-intel ppa found in an ubuntu forum (http://askubuntu.com/questions/185925/k ... ng-100-cpu) which is currently working for me.
I am beginning to see kworker mentioned more and more in hoggin cpu time, but not seeing any fix coming from bug reports/patches, yet.

Doug
Malachi 3:10 NRSV
...says the LORD of hosts... I will not open...windows...for you...

Linux user since 2001 pda; 2006 lappy
revdjenk
Level 4
Level 4
 
Posts: 336
Joined: Sat Nov 15, 2008 2:51 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 0 guests