Getting fglrx to work on sid/liquorix

Questions about hardware and drivers
Forum rules
Before you post please read this

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 8:33 pm

There's always mate aka gnome 2
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Linux Mint is funded by ads and donations.
 

Re: Getting fglrx to work on sid/liquorix

Postby xircon on Sat Nov 10, 2012 8:42 pm

Before I used Cinnamon, I used to use just compiz as my dm, think I will dig out my old config files and play. Never liked gnome2 but I do like cinnamon and gnome 3 :-)
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 8:54 pm

I thought the goal was fglrx drivers to play your game?
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 8:55 pm

lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 8:56 pm

install mate and fglrx and see if it runs... delete the taskbars and just run compiz? not a bad idea really. i did that before too.
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 9:00 pm

right now I'm running the stock fglrx drivers from the repos just to see how they fare. Not bad and they work with the liquorix kernel too. ver 12.6 according the files listed in synaptic.
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby xircon on Sat Nov 10, 2012 9:24 pm

Might try that later, compiling current liquorix kernel for Arch ATM (I really like Manjaro, it feels so snappy compared to LMDE, perhaps I need a fresh install to compare). Yeh, I had a panel less gnome2 for a while it wasn't to bad, I just renamed gnome-panel to gnome-panel-old.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 9:51 pm

Code: Select all
sudo apt-get install glx-alternative-fglrx fglrx-driver fglrx-control amd-opencl-icd
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby lizbeth on Sat Nov 10, 2012 9:53 pm

I never tried arch. I read the installation instructions and and kept going :mrgreen:
lizbeth
Level 4
Level 4
 
Posts: 314
Joined: Thu Mar 31, 2011 5:44 pm

Re: Getting fglrx to work on sid/liquorix

Postby xircon on Sat Nov 10, 2012 10:03 pm

Same here :), but this spin-off has a graphical installer of sorts (and I had a spare 20gb partition). I won't say it was easy, I must of tried 3 times, eventually got there with the beta installer. It (Arch) is a bit rough around the edges, needs a decent synaptic type application (pacman-gui is crap!). Pacman itself is OK, still compiling Liquorix, I accidently cancelled it (twice). Am watching a film (Drive 2011) and to swap out of compact mode it is ctrl+c............... :lol: Never compile with guake open!

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"
User avatar
xircon
Level 5
Level 5
 
Posts: 775
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: Getting fglrx to work on sid/liquorix

Postby darethehair on Mon Dec 31, 2012 2:02 pm

Was the issue of using the AMD zip/run file to install Catalyst/fglrx 12.10 into an LMDE environment resolved?

I am tentatively planning to purchase a "Radeon HD 7750" graphics card, and would eventually need to chose between using experimental repos to install (version 12.10), or using the zip/run file from AMD to install (version 12.10 or 12.11 beta).

Thanks!
There is nothing more dangerous than a bored cat.
User avatar
darethehair
Level 3
Level 3
 
Posts: 158
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada

Re: Getting fglrx to work on sid/liquorix

Postby Aronax on Tue Feb 04, 2014 9:17 pm

Hi u are using an Hd5xx try to use the catalyst 9.5

http://wiki.cchtml.com/index.php/Main_Page

Read Me First

Which cards are no longer supported by ATI Catalyst? The ATI Radeon 9500-9800, Xpress200-1250, 690G, 740G, X300-X2500 (including Mobility RadeonHD 2300, since it is really a DirectX 9 part). See the complete list here. If your card is on that list, you are limited to open-source drivers on Debian Squeeze/6.0 (and later). If you really need the proprietary Catalyst/fglrx driver, you will have to use Debian Lenny/5.0.x and install Catalyst 9-3.
ATTENTION RADEON USERS

NOTE: If you enter your card information on AMD/ATI's driver page, it will offer you the Catalyst 9-3 driver to download. However, the Catalyst 9-3 driver doesn't support X servers past 1.5, and it will not work with Debian versions later than Lenny/5.0.x! !!!SO BE CAREFUL!!! If you tried to install Catalyst on a system with one of these cards, see the 'Removing the Driver' section to restore the default/pre-installed drivers.

http://wiki.cchtml.com/index.php/Debian
i hope it helps, by the way i dident manageged it either to install the driver proper i have an hd6xx
Aronax
Level 1
Level 1
 
Posts: 3
Joined: Tue Feb 04, 2014 4:45 pm

Linux Mint is funded by ads and donations.
 
Previous

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 7 guests