Wireless stops working regularly

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Wireless stops working regularly

Postby Valdemar on Sun Nov 11, 2012 4:21 am

Good day community. I have a router in my room which serves as an access point with 2 PCs connected to it. My PC is connected via WiFi but at times the internet just stops working! I can reconnect to the router successfully and in the network connections I'm displayed as connected but I can't ping the router! After a certain period of time (15m - infinity) it starts working again. What could be the solution? Thanks.
Valdemar
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 11, 2012 4:12 am

Linux Mint is funded by ads and donations.
 

Re: Wireless stops working regularly

Postby remoulder on Sun Nov 11, 2012 4:08 pm

Please provide more information, see http://forums.linuxmint.com/viewtopic.php?f=53&t=1085. Also output of
Code: Select all
inxi -SNx
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: Wireless stops working regularly

Postby Valdemar on Tue Nov 13, 2012 3:55 am

sudo /usr/lib/linuxmint/mintWifi/mintWifi.py

-------------------------
* I. scanning WIFI PCI devices...
-- Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
==> PCI ID = 168c:002b (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"dlink"
Mode:Managed Frequency:2.437 GHz Access Point: 1C:BD:B9:8F:40:B6
Bit Rate=65 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=61/70 Signal level=-49 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:98 Missed beacon:0

eth0 no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr f4:6d:04:83:c7:07
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:50

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:690 errors:0 dropped:0 overruns:0 frame:0
TX packets:690 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:49047 (49.0 KB) TX bytes:49047 (49.0 KB)

wlan0 Link encap:Ethernet HWaddr 48:5d:60:e8:9e:bb
inet addr:192.168.0.101 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::4a5d:60ff:fee8:9ebb/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4667 errors:0 dropped:0 overruns:0 frame:0
TX packets:5789 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1056596 (1.0 MB) TX bytes:907574 (907.5 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 192.168.0.1
Address: 192.168.0.1#53

Non-authoritative answer:
Name: google.com
Address: 173.194.39.70
Name: google.com
Address: 173.194.39.71
Name: google.com
Address: 173.194.39.72
Name: google.com
Address: 173.194.39.73
Name: google.com
Address: 173.194.39.78
Name: google.com
Address: 173.194.39.64
Name: google.com
Address: 173.194.39.65
Name: google.com
Address: 173.194.39.66
Name: google.com
Address: 173.194.39.67
Name: google.com
Address: 173.194.39.68
Name: google.com
Address: 173.194.39.69

inxi -SNx
System: Host: outland Kernel: 3.2.0-23-generic i686 (32 bit, gcc: 4.6.3)
Desktop: Xfce 4.10.0 (Gtk 2.24.10) Distro: Linux Mint 13 Maya
Network: Card-1: Atheros AR9285 Wireless Network Adapter (PCI-Express) driver: ath9k bus-ID: 03:00.0
Card-2: JMicron JMC250 PCI Express Gigabit Ethernet Controller
driver: jme ver: 1.0.8 ports: 9100 9000 bus-ID: 05:00.5
Valdemar
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 11, 2012 4:12 am

Re: Wireless stops working regularly

Postby remoulder on Tue Nov 13, 2012 11:42 am

Ok try each of the suggestions in http://ubuntuforums.org/showthread.php?t=1970349 posts #9 on, also note the suggestions at the end of #11. If either of the options solve the problem, you can make it permanent by in a terminal entering
Code: Select all
echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
or
echo "options ath9k btcoex_enable=1" | sudo tee /etc/modprobe.d/ath9k.conf
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: Wireless stops working regularly

Postby Valdemar on Wed Nov 14, 2012 10:02 am

No, it hasn't helped. At the same time wired works fine.
Valdemar
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 11, 2012 4:12 am

Re: Wireless stops working regularly

Postby remoulder on Wed Nov 14, 2012 12:28 pm

Valdemar wrote:At the same time wired works fine

JFTR you are not trying to use both wired and wireless at the same time are you as this is not going to work using network manager? Assuming no, you will need to look for clues in the output after you lose wifi connection of
Code: Select all
dmesg | tail -50
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: Wireless stops working regularly

Postby Valdemar on Thu Nov 15, 2012 3:00 am

No, I'm not trying :wink:

[ 2860.635183] wlan0: associate with 1c:bd:b9:8f:40:b6 (try 1)
[ 2860.639159] wlan0: RX ReassocResp from 1c:bd:b9:8f:40:b6 (capab=0xc31 status=0 aid=2)
[ 2860.639165] wlan0: associated
[ 2860.645864] cfg80211: Calling CRDA for country: GB
[ 2860.650945] cfg80211: Updating information on frequency 2412 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650952] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650956] cfg80211: Updating information on frequency 2417 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650960] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650964] cfg80211: Updating information on frequency 2422 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650969] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650973] cfg80211: Updating information on frequency 2427 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650977] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650981] cfg80211: Updating information on frequency 2432 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650985] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650989] cfg80211: Updating information on frequency 2437 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.650993] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.650997] cfg80211: Updating information on frequency 2442 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651002] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651005] cfg80211: Updating information on frequency 2447 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651010] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651013] cfg80211: Updating information on frequency 2452 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651018] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651022] cfg80211: Updating information on frequency 2457 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651026] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651030] cfg80211: Updating information on frequency 2462 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651092] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651096] cfg80211: Updating information on frequency 2467 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651101] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651104] cfg80211: Updating information on frequency 2472 MHz for a 20 MHz width channel with regulatory rule:
[ 2860.651109] cfg80211: 2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A mBi, 2000 mBm)
[ 2860.651112] cfg80211: Disabling freq 2484 MHz
[ 2860.651119] cfg80211: Regulatory domain changed to country: GB
[ 2860.651123] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2860.651127] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2860.651131] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2860.651134] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2860.651138] cfg80211: (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 2861.451056] wlan0: no IPv6 routers present
[ 2863.436779] wlan0: deauthenticated from 1c:bd:b9:8f:40:b6 (Reason: 3)
[ 2863.585470] cfg80211: All devices are disconnected, going to restore regulatory settings
[ 2863.585480] cfg80211: Restoring regulatory settings
[ 2863.585486] cfg80211: Calling CRDA to update world regulatory domain
[ 2863.591235] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
[ 2863.591241] cfg80211: World regulatory domain updated:
[ 2863.591245] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2863.591250] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2863.591254] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2863.591258] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2863.591262] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2863.591267] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Valdemar
Level 1
Level 1
 
Posts: 7
Joined: Sun Nov 11, 2012 4:12 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: Bing [Bot] and 5 guests