How to install KDE

Forum rules
Before you post please read how to get help

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 10:38 am

OK, KDE's parts and pieces are totally hosed up. A finese (sp?) fix will not work. I have purge all packages that have "kde" in the name, though not anything that merely starts with a "k" This is often a clue to KDE packages, but not iron-clad.

only these remain:
Code: Select all
kbd                  install
kerneloops-daemon            install
keyboard-configuration            install
klibc-utils               install
krb5-locales               install
ksh                  install


Now, on 11/2 you said I should not use backports "ok, let's try this way: remove kubuntu-backports-ppa", but in 4c, above you said kubuntu backports should be used.

So what is you final guidance on backports

Thanks,
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Linux Mint is funded by ads and donations.
 

Re: How to install KDE

Postby zerozero on Sun Nov 11, 2012 10:48 am

sorry if the wording above in 4c was not very clear: was meant to read
"kubuntu-backports should be used to update kde not to install it afresh (it's a kde ppa afterall) the kind of usage you tried might/most probably will leave to broken dependencies/mismatches"


getting back to the issue, try the simulation
Code: Select all
sudo apt-get -s install kde-full

and thanks for your perseverance 8)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 3:27 pm

Now, I've got no backports in place, right?

Here's the results. BTW, this is a laptop, not a netbook. Do I have to leave kde-plasma-netbook installed? (assuming I ever get this bad boy installed)

Code: Select all
greg@greg-Inspiron ~ $ sudo apt-get -s install kde-full
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-full : Depends: kde-plasma-desktop (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
            Depends: kde-plasma-netbook (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
            Depends: kdeartwork (>= 4:4.8.2) but it is not going to be installed
            Depends: kdenetwork (>= 4:4.8.2) but it is not going to be installed
            Depends: kdeutils (>= 4:4.8.2) but it is not going to be installed
            Depends: kdepim (>= 4:4.8.2) but it is not going to be installed
            Depends: kdeplasma-addons (>= 4:4.8.2) but it is not going to be installed
            Recommends: kde-standard (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
            Recommends: kdesdk (>= 4:4.8.2) but it is not going to be installed
            Recommends: kdewebdev (>= 4:4.8.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


BTW, after I purged all the KDE stuff, I even rebooted. You're not supposed to have to but wanted to make sure nothing is lodged in memory, whatever.

I went into Synaptic, searched for broken packages - nothing listed Dho-oh!

Thanks for hanging in there with me, too!! :D
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Sun Nov 11, 2012 3:39 pm

not a problem :D
this is a "war" i want to win now :mrgreen: (if possible)
from this last output i see that we still have problems.
as per this site http://www.psychocats.net/ubuntu/pureubuntuprecise (the command is a bit modded) can you try the following
(it's a simulation as well, we want to see what would happen in real world)
Code: Select all
sudo apt-get -s remove akonadi-backend-mysql akonadi-server akregator amarok amarok-common amarok-utils apport-kde apturl-kde ark bluedevil cdparanoia cdrdao cryptsetup docbook-xml docbook-xsl dolphin dragonplayer freespacenotifier gnupg-agent gnupg2 gpgsm gpsd gstreamer0.10-qapt gtk2-engines-oxygen gtk3-engines-oxygen gwenview ibus-qt4 icoutils jockey-kde k3b k3b-data kaccessible kaddressbook kamera kate kate-data katepart kcalc kde-baseapps-bin kde-baseapps-data kde-config-gtk kde-config-touchpad kde-runtime kde-runtime-data kde-style-oxygen kde-wallpapers-default kde-window-manager kde-window-manager-common kde-workspace kde-workspace-bin kde-workspace-data kde-workspace-kgreet-plugins kde-zeroconf kdegames-card-data kdegraphics-strigi-analyzer kdelibs-bin kdelibs5-data kdelibs5-plugins kdemultimedia-kio-plugins kdenetwork-filesharing kdepasswd kdepim-kresources kdepim-runtime kdepim-strigi-plugins kdepimlibs-kio-plugins kdesudo kdm kdoctools khelpcenter4 kinfocenter klipper kmag kmail kmenuedit kmix kmousetool knotes konsole kontact kopete kopete-message-indicator korganizer kpat kppp ksnapshot ksysguard ksysguardd ksystemlog ktimetracker ktorrent ktorrent-data kubuntu-debug-installer kubuntu-default-settings kubuntu-desktop kubuntu-docs kubuntu-firefox-installer kubuntu-netbook-default-settings kubuntu-notification-helper kubuntu-web-shortcuts kvkbd kwalletmanager language-selector-kde libakonadi-calendar4 libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4 libakonadi-kde4 libakonadi-kmime4 libakonadi-notes4 libakonadiprotocolinternals1 libassuan0 libattica0.3 libbluedevil1 libboost-program-options1.46.1 libcalendarsupport4 libcln6 libclucene0ldbl libdebconf-kde0 libdlrestrictions1 libdmtx0a libencode-locale-perl libepub0 libeventviews4 libfile-listing-perl libflac++6 libfont-afm-perl libgadu3 libgif4 libgpgme++2 libgps20 libgrantlee-core0 libhtml-form-perl libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl libhttp-daemon-perl libhttp-date-perl libhttp-message-perl libhttp-negotiate-perl libibus-qt1 libilmbase6 libincidenceeditorsng4 libindicate-qt1 libio-socket-inet6-perl libio-socket-ssl-perl libk3b6 libkabc4 libkactivities-bin libkactivities6 libkalarmcal2 libkateinterfaces4 libkatepartinterfaces4 libkblog4 libkcal4 libkcalcore4 libkcalutils4 libkcddb4 libkcmutils4 libkde3support4 libkdeclarative5 libkdecorations4 libkdecore5 libkdegames5a libkdepim4 libkdepimdbusinterfaces4 libkdesu5 libkdeui5 libkdewebkit5 libkdgantt2 libkdnssd4 libkemoticons4 libkephal4abi1 libkexiv2-10 libkexiv2-data libkfile4 libkholidays4 libkhtml5 libkidletime4 libkimap4 libkio5 libkipi-data libkipi8 libkjsapi4 libkjsembed4 libkldap4 libkleo4 libkmanagesieve4 libkmbox4 libkmediaplayer4 libkmime4 libknewstuff2-4 libknewstuff3-4 libknotifyconfig4 libkntlm4 libkonq-common libkonq5-templates libkonq5abi1 libkontactinterface4 libkopete4 libkparts4 libkpgp4 libkpimidentities4 libkpimtextedit4 libkpimutils4 libkprintutils4 libkpty4 libkresources4 libkrosscore4 libksba8 libkscreensaver5 libksgrd4 libksieve4 libksieveui4 libksignalplotter4 libktexteditor4 libktnef4 libktorrent-l10n libktorrent3 libkunitconversion4 libkwineffects1abi3 libkwinglutils1 libkwinnvidiahack4 libkworkspace4abi1 libkxmlrpcclient4 liblastfm0 libloudmouth1-0 liblwp-mediatypes-perl liblwp-protocol-https-perl libmailcommon4 libmailtools-perl libmailtransport4 libmessagecomposer4 libmessagecore4 libmessagelist4 libmessageviewer4 libmicroblog4 libmpcdec6 libmsn0.3 libmuonprivate1 libmygpo-qt1 libmysqlclient18 libnepomuk4 libnepomukdatamanagement4 libnepomukquery4a libnepomuksync4 libnepomukutils4 libnet-http-perl libnet-ssleay-perl libntrack-qt4-1 libntrack0 libokularcore1abi1 libopenexr6 libotr2 libphonon4 libplasma-geolocation-interface4 libplasma3 libplasmaclock4abi3 libplasmagenericshell4 libpolkit-qt-1-1 libpoppler-qt4-3 libprison0 libprocesscore4abi1 libprocessui4a libqalculate5 libqapt-runtime libqapt1 libqca2 libqca2-plugin-ossl libqgpgme1 libqimageblitz4 libqjson0 libqrencode3 libqt4-designer libqt4-help libqt4-qt3support libqt4-scripttools libqt4-sql-mysql libqt4-test libqtassistantclient4 libqtglib-2.0-0 libqtgstreamer-0.10-0 libqtscript4-core libqtscript4-gui libqtscript4-network libqtscript4-sql libqtscript4-uitools libqtscript4-xml libqtwebkit4 libreoffice-kde libreoffice-style-oxygen libsocket6-perl libsolid4 libsolidcontrol4abi2 libsolidcontrolifaces4abi2 libsoprano4 libstreamanalyzer0 libstreams0 libsyndication4 libtag-extras1 libtaskmanager4abi3 libtemplateparser4 libthreadweaver4 libtimedate-perl liburi-perl libvirtodbc0 libweather-ion6 libwww-perl libwww-robotrules-perl libxml2-utils libxss1 libzip2 muon muon-installer muon-notifier muon-updater mysql-client-core-5.5 mysql-common mysql-server-core-5.5 ntrack-module-libnl-0 odbcinst odbcinst1debian2 okular okular-extra-backends oxygen-cursor-theme oxygen-icon-theme partitionmanager phonon phonon-backend-gstreamer pinentry-gtk2 pinentry-qt4 plasma-dataengines-addons plasma-dataengines-workspace plasma-desktop plasma-netbook plasma-scriptengine-javascript plasma-scriptengine-python plasma-widget-facebook plasma-widget-folderview plasma-widget-kimpanel plasma-widget-menubar plasma-widget-message-indicator plasma-widget-networkmanagement plasma-widgets-addons plasma-widgets-workspace plymouth-theme-kubuntu-logo plymouth-theme-kubuntu-text polkit-kde-1 printer-applet python-kde4 python-pyudev python-qt4 python-qt4-dbus python-sip qapt-batch qapt-deb-installer quassel quassel-data rekonq sgml-data shared-desktop-ontologies software-properties-kde soprano-daemon system-config-printer-kde systemsettings tasks-icons update-manager-kde usb-creator-kde userconfig virtuoso-minimal virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common xsettings-kde
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 4:18 pm

The spew out of that command was long. Piped output to a text file, attached.

Now, in that file are a number of things that concern me:

The following packages will be REMOVED:
<snip>
libxml2-utils libxss1 lynkeos.app mate-control-center mate-core
mate-desktop-environment mate-system-tools mint-meta-codecs mplayer2

and

Remv mate-desktop-environment [1.2.2+precise]
Remv mate-system-tools [1.2.3-1+precise]

and

Remv mate-core [1.2.2+precise]
Remv mate-control-center [1.2.1-5+precise]

plus I saw remv audacity, and gthumb, gimp, generally a lot of stuff other stuff I want to keep, and I certainly do not want to loose my MATE desktop. which appears about to happen here.

This is kind of alarming.
Attachments
explicit_remove_kde.odt
(27.61 KiB) Downloaded 52 times
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Sun Nov 11, 2012 4:44 pm

:shock: it's a no-go that way, you would loose a lot and win nothing.
give me please the output of
Code: Select all
sudo apt-get -s install kde-plasma-desktop
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 5:31 pm

Code: Select all
sudo apt-get -s install kde-plasma-desktop
[sudo] password for greg:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-plasma-desktop : Depends: plasma-desktop (>= 4:4.8.2) but it is not going to be installed
                      Depends: kde-workspace (>= 4:4.8.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Sun Nov 11, 2012 5:50 pm

digging more
Code: Select all
sudo apt-get -s install plasma-desktop

Code: Select all
sudo apt-get -s kde-workspace
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 6:19 pm

plasma-desktop:

Code: Select all
sudo apt-get -s install plasma-desktop
[sudo] password for greg:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasma-desktop : Depends: plasma-widgets-workspace (= 4:4.8.5-0ubuntu0.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


kde-workspace:

Code: Select all
sudo apt-get -s install kde-workspace
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-workspace : Depends: kde-workspace-bin (>= 4:4.8.5-0ubuntu0.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Both have held broken packages. But no brokens show in Synaptic.

So, how does one release or un-hold brokens? -f? Tried that:

Code: Select all
sudo apt-get -s install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.


So aparently not. But I did it anyway, without -s ...got same results, then tried the first two again....same results.

I think the key is WTH is a "held package"? if we can break that log-jam, maybe the whole thing breaks loose.
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 6:24 pm

Zerozero, Check this out - http://ubuntuforums.org/showthread.php?t=947124

I haven't seen "force-remove-reinstreq package name" before. Going to man this

Hey, BTW, do you know what "00" means in Europe?
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 6:30 pm

remove-reinstreq: Remove a package, even if it's broken and marked to require reinstallation. This may, for example, cause parts of the package to remain on the system, which will then be forgotten by dpkg.

Sounds promising. So we force blow away a required package. Then start from the top and perhaps it gets reinstalled.
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Sun Nov 11, 2012 6:38 pm

00 :?: nahh it's kinda of a family name :lol:

marietta_greg wrote:I haven't seen "force-remove-reinstreq package name" before. Going to man this
you don't need this, not here and not for this situation: it should only be used in last situations, it's an aggressive command (but useful sometimes), here apt is telling you that it can't solve the situation you request because there's some impossible dependency loop to solve first and that's what we have to find
Code: Select all
sudo apt-get -s install plasma-widgets-workspace

Code: Select all
sudo apt-get -s install kde-workspace-bin
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Sun Nov 11, 2012 7:08 pm

Code: Select all
sudo apt-get -s install plasma-widgets-workspace
[sudo] password for greg:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasma-widgets-workspace : Depends: plasma-dataengines-workspace (= 4:4.8.5-0ubuntu0.1) but it is not going to be installed
                            Depends: akonadi-server but it is not going to be installed
                            Depends: kdepim-runtime but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


and . . .

Code: Select all
sudo apt-get -s install kde-workspace-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kde-workspace-bin : Depends: plasma-desktop (= 4:4.8.5-0ubuntu0.1) but it is not going to be installed or
                              plasma-netbook (= 4:4.8.5-0ubuntu0.1) but it is not going to be installed or
                              plasma-active but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


Also check this out "Why packages are held back"

http://ubuntu.5.n6.nabble.com/How-to-find-out-why-packages-are-quot-held-back-quot-td1355165.html

I sim'ed their suggestion, got:

Code: Select all
sudo apt-get -s dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  linux-headers-3.2.0-32 linux-headers-3.2.0-32-generic linux-image-3.2.0-32-generic
The following packages will be upgraded:
  linux-generic linux-headers-generic linux-image-generic
3 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Inst linux-image-3.2.0-32-generic (3.2.0-32.51 Ubuntu:12.04/precise-updates [amd64])
Inst linux-generic [3.2.0.26.28] (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64]) []
Inst linux-image-generic [3.2.0.26.28] (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64])
Inst linux-headers-3.2.0-32 (3.2.0-32.51 Ubuntu:12.04/precise-updates [all])
Inst linux-headers-3.2.0-32-generic (3.2.0-32.51 Ubuntu:12.04/precise-updates [amd64])
Inst linux-headers-generic [3.2.0.26.28] (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64])
Conf linux-image-3.2.0-32-generic (3.2.0-32.51 Ubuntu:12.04/precise-updates [amd64])
Conf linux-image-generic (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64])
Conf linux-generic (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-3.2.0-32 (3.2.0-32.51 Ubuntu:12.04/precise-updates [all])
Conf linux-headers-3.2.0-32-generic (3.2.0-32.51 Ubuntu:12.04/precise-updates [amd64])
Conf linux-headers-generic (3.2.0.32.35 Ubuntu:12.04/precise-updates [amd64])


Helpful? I don't see mention of anything we're dealing with, tho.

Also found thishttp://www.linuxforums.org/forum/debian-linux/59318-package-problem-broken-dependency-more.html, scroll to the bottom.

I don't want to fly off try something without flying by you since we're deep into this -- I see you're parsing every step, now.
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Mon Nov 12, 2012 7:58 pm

hi :D
(sorry for the late reply: real life got in the way)
the research you are doing (great btw) doesn't apply exactly to our situation because apt is giving us a misleading error msg: you don't actually have broken packages right now (at present); apt is telling you that can't complete the request you are making because it's based on an impossible situation (what we need to know exactly is here is the road-block)

before we go any further a double-check (if you don't mind: all the last steps were made with kubuntu backports ppa disabled?

Code: Select all
sudo apt-get -s install plasma-dataengines-workspace

Code: Select all
sudo apt-get -s install akonadi-server

Code: Select all
sudo apt-get -s install kdepim-runtime

Code: Select all
sudo apt-get -s install plasma-netbook
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Mon Nov 12, 2012 8:02 pm

Code: Select all
sudo apt-get -s install plasma-dataengines-workspace
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasma-dataengines-workspace : Depends: kdepim-runtime but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
greg@greg-Inspiron ~ $ sudo apt-get -s install akonadi-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 akonadi-server : Depends: akonadi-backend-mysql (= 1.7.2-0ubuntu1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
greg@greg-Inspiron ~ $ sudo apt-get -s install kdepim-runtime
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 kdepim-runtime : Depends: akonadi-server (>= 1.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
greg@greg-Inspiron ~ $ sudo apt-get -s install plasma-netbook
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 plasma-netbook : Depends: plasma-widgets-workspace (= 4:4.8.5-0ubuntu0.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby marietta_greg on Mon Nov 12, 2012 8:08 pm

zerozero,

I've been reading mans about aptitude and there is a command option, unhold. I tried it but it was not successful.

Is there a file somewhere on my system that has a list of flagged, "held", dependencies?

And I don't need any special repositories to install KDE?
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Mon Nov 12, 2012 8:22 pm

aptitude might be a good option here (because i don't see apt being more verbose than this)

first and very important
Code: Select all
sudo aptitude keep-all

now go through the simulation options we tried in the last posts (always with the following syntax)
Code: Select all
sudo aptitude -s install <packagename>

(anyway i'm shutting off for today)
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Mon Nov 12, 2012 9:57 pm

Code: Select all
greg@greg-Inspiron ~ $ sudo aptitude keep-all
[sudo] password for greg:
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.


Results of sudo aptitude -s install kde-full was very verbose, attached as a file. Seems like a lot would not be installed.
Attachments
install_kde-full.odt
(14.53 KiB) Downloaded 62 times
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Re: How to install KDE

Postby zerozero on Tue Nov 13, 2012 11:25 am

finally aptitude starts to give us some hints
The following packages have unmet dependencies:
libqt4-test : Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.
mate-notification-daemon : Conflicts: notification-daemon but it is not going to be installed.
libqt4-sql-mysql : Depends: libqt4-sql (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.
libqt4-scripttools : Depends: libqt4-script (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.
Depends: libqtcore4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.
Depends: libqtgui4 (= 4:4.8.1-0ubuntu4.3) but 4:4.8.2+dfsg-2ubuntu1~precise1~ppa1 is installed.

all the packages with that termination come from kubuntu backports see here and as i suspected from the beginning they are causing mismatches in the dependencies chain.
1- be absolutely sure that kubuntu backports ppa is disabled
2- go in a seek&destroy mission in synaptic for those precise1-ppaX
3- try again the command above and we'll see the errors :lol:
Image

[ bliss of ignorance ]
zerozero
Level 16
Level 16
 
Posts: 6492
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to install KDE

Postby marietta_greg on Tue Nov 13, 2012 9:22 pm

/etc/apt/sources.list by the balls. Note -- no backports.

Code: Select all
deb http://packages.linuxmint.com/ maya main upstream import
deb-src http://packages.linuxmint.com/ maya main upstream import #Added by software-properties
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner
deb http://packages.medibuntu.org/ precise free non-free

# deb-src http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
# deb-src http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
# deb-src http://archive.canonical.com/ubuntu/ precise partner
# deb-src http://packages.medibuntu.org/ precise free non-free

# deb http://archive.getdeb.net/ubuntu precise-getdeb apps
# deb http://archive.getdeb.net/ubuntu precise-getdeb games
# deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
# deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
# deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
# deb http://archive.canonical.com/ubuntu/ precise partner
# deb http://packages.medibuntu.org/ precise free non-free

# deb-src http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb-src http://archive.canonical.com/ubuntu/ precise partner
deb-src http://packages.medibuntu.org/ precise free non-free

# deb http://archive.getdeb.net/ubuntu precise-getdeb apps
# deb http://archive.getdeb.net/ubuntu precise-getdeb games
# deb http://ppa.launchpad.net/screenlets/ppa/ubuntu precise main
deb-src http://ppa.launchpad.net/screenlets/ppa/ubuntu precise main
deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu precise main
deb-src http://ppa.launchpad.net/gezakovacs/ppa/ubuntu precise main



When I fire up Synaptic, it keeps popping a message "Sources have changed, reload" which I do (refresh button) but the message keeps popping.

I will kill the below with apt-get purge
marietta_greg
Level 2
Level 2
 
Posts: 98
Joined: Thu Feb 02, 2012 10:57 pm

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to KDE

Who is online

Users browsing this forum: No registered users and 8 guests