Reset all the DE for graphic server fail at login

Questions about Cinnamon,MATE,Xfce etc.

Reset all the DE for graphic server fail at login

Postby magisterludi on Mon Nov 12, 2012 7:45 am

Hi to all,on my notebook I installed LMDE Gnome 32 bit and I have also Cinnamon.
I can't figure what I changed but now I can't login because xserver doesn't start, I have only a screen not much informative ("Oh no, something was wrong, i got an unrecoverable error, restart session" this is my translation from Italian language because I have an Italian localised installation) and after i click it turns to the login screen, if I choose Cinnamon, Gnome or Gnome Classic nothing changes, the same errors happens. I can login to a text console and if I try to start xserver with
Code: Select all
startx
sometime it works and Gnome Classic starts and sometimes (most of the times) the same error happen.
After a lot of tests, including forced reinstall of gdm, xserver-xorg and dpkg-reconfigure of these packets I then logged in the system as root and Gnome started and works perfectly. I added a new user and also with this user I can login and choose any of the 3 DE and all work.
Then I think there is some config file corrupted that affects all the 3 DE. I found some guide that teach how to reset configuration of gnome and cinnamon separately but how I can identify which config file is in charge of the errors and remove it?
Thanks and regards
magisterludi
Level 1
Level 1
 
Posts: 3
Joined: Sat Oct 08, 2011 2:26 pm

Linux Mint is funded by ads and donations.
 

Re: Reset all the DE for graphic server fail at login

Postby pharpend on Wed Nov 28, 2012 5:02 pm

Howdy

I am an Arch user, but I ran into a similar problem and solved it.

The only configuration file that could potentially be poblematic would be .xinitrc.

Could you please post the output of
Code: Select all
cat < ~/.xinitrc
(when you are logged in as you, as opposed to the root or tertiary user).
pharpend
Level 1
Level 1
 
Posts: 7
Joined: Tue Jul 10, 2012 10:39 pm

Re: Reset all the DE for graphic server fail at login

Postby pharpend on Fri Nov 30, 2012 8:05 pm

Well, I was initially using SLiM. To troubleshoot, I switched to GDM, and now it works.
pharpend
Level 1
Level 1
 
Posts: 7
Joined: Tue Jul 10, 2012 10:39 pm


Return to Desktops and Windows Managers

Who is online

Users browsing this forum: No registered users and 1 guest