Screenshot app malfunctioning, Linux Mint 13 with Cinnamon

Questions about applications and software
Forum rules
Before you post please read this

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby mintorium on Sun Sep 16, 2012 10:47 am

I have the same problem (Cinnamon + Catalyst).

It seems that every time the screenshot is taken, the application grabs whatever is in the "fullscreen buffer" (or whatever it is called). At least this is what I see in the resulting file, be it a fullscreen video frame or a different image that I viewed in fullscreen mode.

What does work is the old "xwd" utility and the "import" tool from ImageMagick (but not with "-window root"). I guess these have a different way of accessing the screen contents.
mintorium
Level 1
Level 1
 
Posts: 1
Joined: Sun Sep 16, 2012 10:33 am

Linux Mint is funded by ads and donations.
 

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby PegHorse on Thu Sep 20, 2012 8:05 pm

I notice the same since i have installed my Catalyst driver 12.8 currently.

Graphics: Card: Advanced Micro Devices [AMD] nee ATI Barts PRO [ATI Radeon HD 6800 Series]
X.Org: 1.11.3 driver: fglrx Resolution: 1920x1200@60.0hz
GLX Renderer: AMD Radeon HD 6800 Series GLX Version: 4.2.11762 - CPC
PegHorse
Level 1
Level 1
 
Posts: 17
Joined: Sat Dec 10, 2011 6:47 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby vampko on Sat Sep 22, 2012 10:33 am

Danko8321 wrote:I have a certain workarround, although it isn't precisely a solution. I was also having this problem, both the delay and the automatic screenshot saving (which I DEEPLY hate); my workarround was to use GCONF to modify the command executed by the "Print Screen" button (open GCONF, go to /apps/metacity/keybinding_commands and change the values of "command_screenshot" and "command_window_screenshot"), and I changed it to the proper KSnapShot defaults (ksnapshot instead of gnome-screenshot and ksnapshot --curent instead of gnome-screenshot --window.

I already had KDE installed so this is not precisely a big deal for me (also, I always liked KSnapShot better than Gnome Screenshot, so it's a win for me). If you don't have KDE installed, you can simply install KSnapShot by putting:

Code: Select all
sudo apt-get install ksnapshot


in a terminal.

My two cents.

Problem persists

ridz1ba wrote:Yep - having the same problem here but I solved it by logging out of Cinnamon and then logging back in using a 'Gnome Classis - no effects' session. Using that session the 'Print Screen' and 'Alt-Print Screen' functions worked properly. Not a great solution but a solution nevertheless.

Problem persists
DellPrecision wrote:I assign new keyboard shortcut ctrl-P and as a command i put gnome-screenshot --interactive
and seems to work well with not time issues i hope that may help.

Problem persists

dagon wrote:See if any of the reported bugs are related:
https://github.com/linuxmint/Cinnamon/issues/search?q=screenshot

Could be related to this issue, but I don't use dual monitors.

Kernel Linux 3.2.0-23-generic (x86_64)
Compiled #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012
C Library Unknown
Default C Compiler GNU C Compiler version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
Distribution Linux Mint 13 Maya

Using the ATI drivers. This happened not very long after I installed those drivers. But, those drivers are needed to play several games, so I'm kind of stuck here.
vampko
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 22, 2012 10:21 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby PegHorse on Sat Sep 22, 2012 11:20 am

I have installed drivers Radeon HD Libre from Xorg-Edgars PPA to solve my graphics problem and some blackscreen at boot.
Screenshot is working normally now and the video acceleration is far better than with Catalyst.

For a Divx as for example, with VLC 2.1, CPU is used only for 3%, with Catalyst with Libva and Xvba-video Drivers, it is 30% and with Catalyst without Libva and Xvba drivers it is 50% and more.

My video card is Asus EAH 6850v2 so its an ATI 6850.
Also with Radeon HD Libre drivers, movies are smoothers than with Catalyst with acceleration enabled.
PegHorse
Level 1
Level 1
 
Posts: 17
Joined: Sat Dec 10, 2011 6:47 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby vampko on Sat Sep 22, 2012 12:29 pm

PegHorse wrote:I have installed drivers Radeon HD Libre from Xorg-Edgars PPA to solve my graphics problem and some blackscreen at boot.
Screenshot is working normally now and the video acceleration is far better than with Catalyst.

For a Divx as for example, with VLC 2.1, CPU is used only for 3%, with Catalyst with Libva and Xvba-video Drivers, it is 30% and with Catalyst without Libva and Xvba drivers it is 50% and more.

My video card is Asus EAH 6850v2 so its an ATI 6850.
Also with Radeon HD Libre drivers, movies are smoothers than with Catalyst with acceleration enabled.

So where would one find these drivers? I'm not getting much luck with a google search.
vampko
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 22, 2012 10:21 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby xclusive585 on Sat Sep 22, 2012 2:43 pm

vampko wrote:
PegHorse wrote:I have installed drivers Radeon HD Libre from Xorg-Edgars PPA to solve my graphics problem and some blackscreen at boot.
Screenshot is working normally now and the video acceleration is far better than with Catalyst.

For a Divx as for example, with VLC 2.1, CPU is used only for 3%, with Catalyst with Libva and Xvba-video Drivers, it is 30% and with Catalyst without Libva and Xvba drivers it is 50% and more.

My video card is Asus EAH 6850v2 so its an ATI 6850.
Also with Radeon HD Libre drivers, movies are smoothers than with Catalyst with acceleration enabled.

So where would one find these drivers? I'm not getting much luck with a google search.


Code: Select all
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install <package name>
-Dave

“The only way to fix Linux is to take one distro, one set of components as a baseline, abandon everything else and everyone should just contribute to this single Linux..."
xclusive585
Level 2
Level 2
 
Posts: 81
Joined: Sat Aug 11, 2012 11:49 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby Devil999 on Sat Sep 22, 2012 3:17 pm

Regarding the screenshot problem, I've been using a quick-fix: restarting cinnamon while having the correct window opened does allow to screenshot it. Obviously, this is a rather rude solution to our problem. For those who don't know it, just open the window you want to screenshot, press Alt-F2 and type 'r' (just the letter). Enter and screenshot as soon as you see the window.
Devil999
Level 1
Level 1
 
Posts: 4
Joined: Sat Apr 28, 2012 1:11 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby vampko on Sat Sep 22, 2012 8:45 pm

xclusive585 wrote:
vampko wrote:
PegHorse wrote:I have installed drivers Radeon HD Libre from Xorg-Edgars PPA to solve my graphics problem and some blackscreen at boot.
Screenshot is working normally now and the video acceleration is far better than with Catalyst.

For a Divx as for example, with VLC 2.1, CPU is used only for 3%, with Catalyst with Libva and Xvba-video Drivers, it is 30% and with Catalyst without Libva and Xvba drivers it is 50% and more.

My video card is Asus EAH 6850v2 so its an ATI 6850.
Also with Radeon HD Libre drivers, movies are smoothers than with Catalyst with acceleration enabled.

So where would one find these drivers? I'm not getting much luck with a google search.


Code: Select all
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install <package name>

what's the package name though?

I tried ppa:xorg-edgers/ppa
But it said 'package not found' or something like that.
vampko
Level 1
Level 1
 
Posts: 3
Joined: Sat Sep 22, 2012 10:21 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby xclusive585 on Sat Sep 22, 2012 11:30 pm

The ppa is basically an additional repository you added to your system. I'm assuming the package the other poster referrs to is "xserver-xorg-video-radeonhd" but I'm not sure as I do not have a Radeon or even the Cinnamon desktop
-Dave

“The only way to fix Linux is to take one distro, one set of components as a baseline, abandon everything else and everyone should just contribute to this single Linux..."
xclusive585
Level 2
Level 2
 
Posts: 81
Joined: Sat Aug 11, 2012 11:49 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby PegHorse on Sun Sep 23, 2012 7:39 am

Hello,

Code: Select all
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade
PegHorse
Level 1
Level 1
 
Posts: 17
Joined: Sat Dec 10, 2011 6:47 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby n0m4d on Wed Oct 03, 2012 7:54 pm

I too am having the same kind of problem, Except i am entirely able to take screenshots, but when I do it is always just a black screen and my pointer...
This happened 4 times in a row. I'm not sure why, but it'd be nice if i could find a solution.
n0m4d
Level 1
Level 1
 
Posts: 1
Joined: Thu Sep 20, 2012 6:59 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby Baladya on Sat Oct 06, 2012 2:45 am

Getting a blackscreen too !
Baladya
Level 1
Level 1
 
Posts: 5
Joined: Tue Jul 10, 2012 1:59 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby xpanta on Sun Nov 11, 2012 3:15 am

GPick shows same behaviour, too.

I cannot pick colors from the screen, as it always shows what is in the screen buffer and not on the current screen.

Any fix for that, yet? I think this is a bug that needs to be reported.
Linux Mint 14, Cinnamon. Intel E6800.4GB RAM. nVidia GT630.
xpanta
Level 1
Level 1
 
Posts: 20
Joined: Wed Nov 07, 2012 7:33 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby agilob on Mon Nov 12, 2012 9:40 am

The same problem on openSUSE 12.2 with Cinnamon

Code: Select all
:~> fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6570M/5700 Series
OpenGL version string: 4.2.11931 Compatibility Profile Context



Code: Select all
~> gnome-screenshot

** (gnome-screenshot:9720): WARNING **: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11. Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Shell was not provided by any .service files


Command has created a new file in ~/Pictures, on the screenshot I see registration form from this forum (I filled it ~6minutes ago)...
agilob
Level 1
Level 1
 
Posts: 2
Joined: Mon Nov 12, 2012 9:35 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby xclusive585 on Tue Nov 13, 2012 3:59 am

agilob wrote:The same problem on openSUSE 12.2 with Cinnamon

Code: Select all
:~> fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6570M/5700 Series
OpenGL version string: 4.2.11931 Compatibility Profile Context



Code: Select all
~> gnome-screenshot

** (gnome-screenshot:9720): WARNING **: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11. Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Shell was not provided by any .service files


Command has created a new file in ~/Pictures, on the screenshot I see registration form from this forum (I filled it ~6minutes ago)...

Yes that is exactly what the issue being discussed here causes. So no surprise there. Try the PPA mentioned up a few posts.

[edit] crap, you are using Suse, so the PPA wont help you. Perhaps you could take the source from the PPA and compile it in Suse?

Curious why you wanna use a Debian family distro's desktop on a non-debian distro... If you are a go-getter like that, you should be equipped (as far as Linux knowledge) to fix things as well.
-Dave

“The only way to fix Linux is to take one distro, one set of components as a baseline, abandon everything else and everyone should just contribute to this single Linux..."
xclusive585
Level 2
Level 2
 
Posts: 81
Joined: Sat Aug 11, 2012 11:49 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby agilob on Tue Nov 13, 2012 5:09 pm

xclusive585 wrote:[edit] crap, you are using Suse, so the PPA wont help you. Perhaps you could take the source from the PPA and compile it in Suse?

Curious why you wanna use a Debian family distro's desktop on a non-debian distro... If you are a go-getter like that, you should be equipped (as far as Linux knowledge) to fix things as well.


There is port for oS:
http://download.opensuse.org/repositories/X11:/


I have found some tricks with AMD catalyst.
I have change some settings this problem disappeared, but new one appeared.
Go to Display Options -> Tear Free and disable tear free.
Now we have problem with blinking screen, when I open new windows screen looks like was crashed, broken...
Last edited by agilob on Mon Mar 11, 2013 5:33 pm, edited 1 time in total.
agilob
Level 1
Level 1
 
Posts: 2
Joined: Mon Nov 12, 2012 9:35 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby cygnus on Fri Nov 30, 2012 4:08 pm

I'm having the same issue on Ubuntu 12.04.1 LTS with Cinnamon 1.6.7 running FGRLX video drivers.

Issue:

I take a screenshot, and it creates and saves it in the ~/Pictures folder, but it's not a current screenshot. If I do the Cinnamon restart trick stated in an earlier post (focus on window you want - press Alt-F2 - type r - take screenshot) it does give me the latest screenshot, but the top window bar is missing. If I run gnome-screenshot from the terminal, it works but I get the same error as listed above:

Code: Select all
** (gnome-screenshot:9443): WARNING **: Unable to use GNOME Shell's builtin screenshot interface, resorting to fallback X11. Error: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.Shell was not provided by any .service files


When I log out and log in using the standard Unity session, screenshots work as they should, with the save prompt.

I absolutely love Cinnamon, and I understand it's relatively new, so I understand there are bugs in this early edition. I'll continue to use it and look forward to this bug being fixed. I'm willing to give anything that the developers would need to help (configs, etc.) but I'm not much of a programmer so unfortunately I can't help that way. :(

Thanks for all your work, Cinnamon is going to be huge (I can really see it becoming one of the top desktop managers in the near future).
cygnus
Level 1
Level 1
 
Posts: 11
Joined: Thu Nov 15, 2012 11:34 am

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby zerozero on Fri Nov 30, 2012 4:51 pm

cygnus,
thanks for your report.
as far as i can remember is the first time the issue is clearly identified as an interaction between cinnamon and the amd/ati drivers
cygnus wrote:When I log out and log in using the standard Unity session, screenshots work as they should, with the save prompt.

if you are willing to help debug this please open a ticket at https://github.com/linuxmint/Cinnamon/issues

again tks for the cooperation :wink:
User avatar
zerozero
Level 16
Level 16
 
Posts: 6435
Joined: Tue Jul 07, 2009 2:29 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby candrax on Sat Dec 01, 2012 4:11 pm

zerozero wrote:cygnus,
thanks for your report.
as far as i can remember is the first time the issue is clearly identified as an interaction between cinnamon and the amd/ati drivers
cygnus wrote:When I log out and log in using the standard Unity session, screenshots work as they should, with the save prompt.

if you are willing to help debug this please open a ticket at https://github.com/linuxmint/Cinnamon/issues

again tks for the cooperation :wink:


Hello,

Just to correct you on the statement that this is the first time someone connects AMD drivers and screenshot functionality in cinnamon :) I've done that numerous times myself, and there is also a bug submission here: https://github.com/linuxmint/Cinnamon/issues/670

So, to clear things, there is an issue going on with screenshots when these things are true:

1. Cinnamon
2. AMD catalyst drivers - fglrx
3. Dual monitor setup

I would appreciate if someone from the devs tell me how can I help to get rid of this bug asap. It's is really a pain to restart cinnamon just to get the darn screenshot.. Is there some guide around on how can someone help in debugging or so?

The interesting thing is that this issue doesn't appear in gnome shell, so it's gotta be something with cinnamon/muffin , devs will know better.

Regards
candrax
Level 1
Level 1
 
Posts: 3
Joined: Sat Apr 28, 2012 5:55 pm

Re: Screenshot app malfunctioning, Linux Mint 13 with Cinnam

Postby cygnus on Thu Dec 06, 2012 12:39 pm

zerozero wrote:cygnus,
thanks for your report.
as far as i can remember is the first time the issue is clearly identified as an interaction between cinnamon and the amd/ati drivers
cygnus wrote:When I log out and log in using the standard Unity session, screenshots work as they should, with the save prompt.

if you are willing to help debug this please open a ticket at https://github.com/linuxmint/Cinnamon/issues

again tks for the cooperation :wink:


No problem, I'll open a bug and help with debugging.

EDIT: Issue reported: https://github.com/linuxmint/Cinnamon/issues/1468
cygnus
Level 1
Level 1
 
Posts: 11
Joined: Thu Nov 15, 2012 11:34 am

Linux Mint is funded by ads and donations.
 
PreviousNext

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 22 guests

cron