Synaptics Touch Pad Bug Report

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Synaptics Touch Pad Bug Report

Postby Rudemeister on Thu Nov 15, 2012 10:23 am

Ok. I have an HP nx9420 laptop with a core2 dual cpu, 4G ram, and Nvidia NVS 510M graphics. It also comes with a Synaptics touch-pad. I am running Mint 13 KDE 32-bit. The touch-pad will function as a normal mouse. But gestures do not work at all.

When I go into System Settings there is an icon for Input Devices. Inside of Input Devices there is a selection for Touchpad. When I select this setting, System Settings faults and terminates with an error.

So then I run these commands from a terminal:

sudo rmmod psmouse
sudo modprobe psmouse proto=imps

After entering this, the Touchpad works fine. Scroll, gestures and everything works. Curiously, when I return to System Settings, I can now open the Input Devices - Touchpad selection. It no longer terminates with a fault. Now it says I have no Touchpad. Hmmmmmm. But it's all working pretty good now.

But when I reboot, the Touchpad returns to functioning without gestures till I do the above procedures in a terminal once again. It works fine once more, but the setting do not save after reboot.

Any ideas?
HP XW8600 Work Station
Dual Quad-Core 3Ghz Xeon CPU's
32GB PC2-5300 ECC DRAM
Nvidia GT520 2G GDDR3 Graphics
2TB Seagate Barracuda 7200 RPM
Linux Mint 16 KDE 64-bit
Windows 7 Professional 64-bit
User avatar
Rudemeister
Level 3
Level 3
 
Posts: 171
Joined: Sat May 09, 2009 7:24 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 6 guests