need ppd file for Canon iRC3580i printer

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

need ppd file for Canon iRC3580i printer

Postby mawisdace on Fri Nov 16, 2012 6:14 am

I am connected to a Canon iRC3580i printer, I was able to configure this printer using the recommended defaults, and it even worked!

However, the printer appears to use its predefined default settings and there is simply no way to change those; whatever I specify (in applications that accept specifications) is simply ignored by the printer. Concretely, it converts everything to booklet sheets in A3 format (which looks very cute, but is absolutely not what I want). I am the only Linux user around here; other people connected to the same printer use Windows and have no problems at all.

I was told that I would need a ppd file for the Canon iRC3580i printer, but Canon does not provide such a file for Linux (only for Windows and Mac). I also tried to convert the Mac files to something useful to Linux, but I failed.

Should I forget about printing with Linux (or move to Windows, or buy a printer of my own)?
mawisdace
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 16, 2012 5:42 am

Linux Mint is funded by ads and donations.
 

Re: need ppd file for Canon iRC3580i printer

Postby catweazel on Fri Nov 16, 2012 6:39 am

mawisdace wrote:Canon does not provide such a file for Linux


http://software.canon-europe.com/software/0040355.asp?model=

iRC1021i
iRC2380i
iRC2880
iRC3080/i
iRC3380
iRC3580/i
iR C4080i
iR C4580i
iR C5185i
iRC5185i

o1113enx_l_ufr220.zip
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: need ppd file for Canon iRC3580i printer

Postby cwsnyder on Fri Nov 16, 2012 6:46 am

CNCUPSIRC3580SK.ppd is the ppd listed in https://wiki.ubuntu.com/HardwareSupport ... ntersCanon . There is more information in the listing on where to find drivers. Make sure any .deb file matches your architecture (i386 or amd64).
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: need ppd file for Canon iRC3580i printer

Postby mawisdace on Fri Nov 16, 2012 8:12 am

@TehGhodTrole:
On the page you quote ( http://software.canon-europe.com/software/0040355.asp?model=), Canon provides Drivers, but not ppd files, which is not quite the same.
mawisdace
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 16, 2012 5:42 am

Re: need ppd file for Canon iRC3580i printer

Postby remoulder on Fri Nov 16, 2012 9:36 am

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: need ppd file for Canon iRC3580i printer

Postby mawisdace on Fri Nov 16, 2012 1:29 pm

@csnyder & remoulder:

I assume that both of you want me to follow the instructions on the following post:
v8.04.3 (Hardy) Default (foomatic) driver does not work.

Get (free) drivers from http://www.canon.com.au,
install the .deb packages,
select "Canon iR C3080/3480/3580 PS3 ver.1.8" as the "Make and Model"

I used lpd://(printer's IP) in the URI field
2009-Jan-21


I have recently installed linuxmint_13_(Maya), so the above advise might be totally dated. However, that might not even matter, since I am a newcomer to installing linux distributions and simply do not understand :-( the above instructions, just see:
(1)
The website http://www.canon.com.au (in its present state) does not provide anything for iRC3580i printers, so that link is useless.
(2)
On the other hand, the website http://www.canon.de does know this printer (http://de.software.canon-europe.com/sof ... asp?model=), and offers at least 3_different drivers. Which (if any) is the one that works? Are you thinking of "CQue 2.0.3 Linux Driver DEB 32-bit"? I had already unpacked that one before posting this quest: I found a lot of ppd files inside, but none for the printer iRC3580i.
(3)
What does "install the deb packeges" mean? I went to the synaptic packet manager and found "qapt-deb-installer". Is that the one I need to install or something else? Some people do install packages without the package manager, but whenever I tried to do such a thing I destroyed the operating system and had to reinstall it anew (the printer stopped working altogether, did not even work with the default settings, as it does now).
(4)
I assume that "Make and Model" is an option of the printer configuration software, but I was never offered such an option.
(5)
What is a printers IP, and at which point (???) should I use a printer IP in a URI field? (I suppose that URI field is a website address)

As you may see, the instructions on the website you recommend seem to be directed to insiders and are not easy to follow and (for more than one newcomer) not even understood. Moreover, it is hard for me to believe that such a dated advise will actually work for the newer releases. This problem remains UNsolved. I have empirically verified, though, the above statement that the "Default (foomatic) driver does not work" ;-)

By the way: although I am a newcomer to installing operating systems and configuring hardware, I definitely DO know how to google ;-). Please do not submit arbitrary pages you found by googling; I am only interested in procedures you have tested and found to be working for the actual mint releases.

Thank you very much for your patience.
mawisdace
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 16, 2012 5:42 am

Re: need ppd file for Canon iRC3580i printer

Postby AlbertP on Fri Nov 16, 2012 2:11 pm

1) Printers that are not sold in Australia do not appear on Canon's Australian website. Usually the last two digits of the model number are different on other continents.
2) Here, I'm not fully sure. I think CQue DEB should be OK; it has 32- and 64-bit versions and of course you need the 64-bit version instead on a 64-bit Mint system.
3) You can double-click a DEB file to install it.
4) The printer configuration software is "system-config-printer-gnome" from the repository (Software Manager); after installing it, you can launch it by running system-config-printer in terminal or in Alt-F2. It is possible that you do not need this when using a USB connection instead of network printing. With USB the printer might be auto-detected when turning it on after installing the DEB.
5) That only applies to network printing; you don't need it if you use a USB connection.

There is no easy driver installer available on openprinting.org for this printer (for many printers, there is a driver or PPD file availble).

(Edit)
Unfortunately, Canon does not offer good Linux support anymore. They haven't released any new Linux drivers since 2009. Their old drivers do not always work on today's Linux versions. For some printers there is a Linux driver available outside Canon; but if that were the case for the iRC3580i, the printer would have been listed on openprinting.org.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: need ppd file for Canon iRC3580i printer

Postby remoulder on Fri Nov 16, 2012 2:23 pm

mawisdace wrote:that link is useless

Ignoring the rest of your rude and impatient post, have you actually tried going to that site and searching for the driver? Best of luck getting people here to help you if this is an example of your response.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: need ppd file for Canon iRC3580i printer

Postby AlbertP on Fri Nov 16, 2012 2:31 pm

@ remoulder: The printer is indeed no longer visible on the canon.com.au website (apart from an empty page titled iRC3580i).
@ mawisdace: I think it's best to visit the Canon website of your own country, so canon.de (or canon-europe.com) would indeed be right if you're from Germany.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: need ppd file for Canon iRC3580i printer

Postby remoulder on Fri Nov 16, 2012 2:40 pm

AlbertP wrote:is indeed no longer visible on the canon.com.au website

@AlbertP, it may no longer be in the products list but there is still a support page with links.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7669
Joined: Fri May 09, 2008 1:14 pm

Re: need ppd file for Canon iRC3580i printer

Postby mawisdace on Fri Nov 16, 2012 2:51 pm

@AlbertP:

Thank you very much for your explanations; I will probably have to wait until Monday to test them. I shall be aware that Canon is no good for Linux users, but unfortunately, the decision to buy that very printer was not mine and I am just borrowing it. As far as I gather, the owners still believe that it is fully supported by Canon, but it is good to know that they are wrong.

I am using a 32-bit installation, so the DEB file might be ok.

However, there is a detail: The iRC3580i printer I am connected to is a "network printer" (so I was told by the Windows user who kindly connected it to my computer). Therefore, I will probably need additional help for network printers.
mawisdace
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 16, 2012 5:42 am

Re: need ppd file for Canon iRC3580i printer

Postby mawisdace on Fri Nov 16, 2012 3:03 pm

remoulder wrote:Ignoring the rest of your rude and impatient post, have you actually tried going to that site and searching for the driver? Best of luck getting people here to help you if this is an example of your response.


I am sorry and very much apologize for having offended you. I never intended to be rude; please keep in mind that English is not my native language, so I may easily miss the appropriate tone.

(Of course I went to the Australian site and used the search function to search for the driver iRC3580i; I got the message "0 results for your search")
mawisdace
Level 1
Level 1
 
Posts: 5
Joined: Fri Nov 16, 2012 5:42 am

Re: need ppd file for Canon iRC3580i printer

Postby pdc_2 on Fri Nov 16, 2012 9:50 pm

so hello there mawisdace;

I see this is a business multifunction device; I went to the Canon Asia website; and they recommend the UFR driver for you ........your printer is well supported with a 32bit debian package ...just for you ........

http://support-asia.canon-asia.com/?personal

........I can show you all the clicks later if you want .......

...... as you are using a 32bit system, that is great and it should install well ...........

...... you will be downloading a package, that contains what you need .......

.......so go here ......

http://support-asia.canon-asia.com/cont ... 70810.html

and download Linux_UFRII_PrinterDriver_V250_uk_EN.tar.gz .

.... as you click to download, your system should offer to "Open with Archive Manager" ......I suggest you let it .......

.... as archive manager shows you the package, ......you need to drill down inside it .....so open the 32bit driver directory ......and then open the debian directory ..

you will see what I have in the thumbnail below ;

1) Install the COMMON package first

2) install the UFR2 driver after that

......how to install?????????.......left-click on each file in turn, and gdebi installer should leap in and offer to help ......let it .....

check they are installed by COPY and PASTE this command into a terminal

sudo dpkg -l | grep cndrvcups


...that should give you all you want .......if you search in the search function for a ppd file after installing the above, you should find it ......I doubt you will need to edit it .......

....let us know how it goes ...............
Attachments
canon_ufr_driver.png
canon_ufr_driver.png (8.01 KiB) Viewed 1239 times
pdc_2
Level 5
Level 5
 
Posts: 820
Joined: Mon May 11, 2009 1:21 am

Re: need ppd file for Canon iRC3580i printer

Postby AlbertP on Sat Nov 17, 2012 6:53 am

@ mawisdace: I thought CQue would be OK because I didn't know what the UFRII packages were, but apparently, like pdc_2 suggests, you will find the DEBs you need in the UFRII package, and the CQue one is just some kind of "helper" program you may not need.

For network printing, you need to know the IP address of the printer, then you can go into system-config-printer > Add > Find Network Printer and type the IP. After that, you need to choose the printer's make and model, Canon iRC3580i should be available in the list after installing the driver (UFRII apparently?).

But before trying to find an IP address please make sure the printer is using the network and not simply a USB connection, because USB is available on most network printers too.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: need ppd file for Canon iRC3580i printer

Postby catweazel on Sat Nov 17, 2012 7:30 am

mawisdace wrote:@TehGhodTrole:
On the page you quote ( http://software.canon-europe.com/software/0040355.asp?model=), Canon provides Drivers, but not ppd files, which is not quite the same.


How rude.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: need ppd file for Canon iRC3580i printer

Postby catweazel on Sat Nov 17, 2012 7:33 am

pdc_2 wrote:I see this is a business multifunction device; I went to the Canon Asia website; and they recommend the UFR driver for you


mawisdace wrote:Canon provides Drivers, but not ppd files, which is not quite the same.


HTH :lol:
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

Re: need ppd file for Canon iRC3580i printer

Postby AlbertP on Sat Nov 17, 2012 7:38 am

@mawisdace: Linux printing drivers include the necessary PPD files so by installing a driver the PPD file will be installed too. The PPD files from a driver package can only be used if the driver itself is installed too.
So you can just install a driver then your PPDs will also be sorted.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6501
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 20 guests