Error occurs during update. SOLVED

Questions about applications and software
Forum rules
Before you post please read this

Error occurs during update. SOLVED

Postby africanlion on Fri Nov 16, 2012 4:36 pm

Everytime i try to insall updates that have been flagged up after a search or otherwise i get this message

"W: GPG error: http://dl.google.com stable Release: The following signatures were invalid: BADSIG A040830F7FAC5991 Google, Inc. Linux Package Signing Key <linux-packages-keymaster@google.com>"

How do i solve this problem please
Last edited by africanlion on Wed Nov 21, 2012 11:01 pm, edited 1 time in total.
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Linux Mint is funded by ads and donations.
 

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 4:43 pm

could you post the contents of /etc/apt/sources.list ? It looks like you have a repository with a bad security key. Try removing the offending repository from that file and then reinstalling it. You can also use "Software Sources" to find and remove entries.
EDIT: also see the comments on http://www.ubuntuupdates.org/ppa/google_chrome
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 4:58 pm

bigj231 wrote:could you post the contents of /etc/apt/sources.list ? It looks like you have a repository with a bad security key. Try removing the offending repository from that file and then reinstalling it. You can also use "Software Sources" to find and remove entries.
EDIT: also see the comments on http://www.ubuntuupdates.org/ppa/google_chrome



Thanks for your response. How do i get into /etc/apt/sources.list folder? Sorry still learning how Linux works
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 5:19 pm

It's actually a file, not a folder. You need to open a terminal and type in
Code: Select all
gedit /etc/apt/sources.list
Then just copy and paste everything in that file into a code box in a reply.
After you post back here with that info, I would urge you to read the following quote.
You can really break your system if you are not careful with the terminal. I would also recommend learning how to use the terminal before you start copying and pasting commands into it. It's really the fastest way to do things in Linux. Breaking things included. Like any tool, it takes time to learn how to use it.
I would strongly recommend using the Software Sources application if you are unfamiliar with the terminal.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 5:41 pm

Thanks bigj231. Will try to familiarise myslef with the terminal though its hard to know what is safe and what isnt when copying into it


Code: Select all
deb http://packages.linuxmint.com/ maya main upstream import
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ precise partner
deb http://packages.medibuntu.org/ precise free non-free

# deb http://archive.getdeb.net/ubuntu precise-getdeb apps
# deb http://archive.getdeb.net/ubuntu precise-getdeb games
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 6:06 pm

Hmm, I don't see anything odd there...
Sorry, I had a brainfart. That's where all your software sources are found in Debian and older versions of Ubuntu/Mint. Look around in the "Other Software" tab in Software Sources. See if there is something similar to your error, and uncheck the box next to it. Then try updating again and see if it fixes the error. if it doesn't, recheck the box and uncheck another one.
I'll be away from the computer for the next few hours, but I'll try to assist you when I get home.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 6:50 pm

Here is a screeshot of other software
Attachments
screenshot.doc
(137.5 KiB) Downloaded 104 times
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby remoulder on Fri Nov 16, 2012 7:57 pm

bigj231 wrote:post the contents of /etc/apt/sources.list

@bigj231, mint uses the inxi tool to provide system information, all repositories can be listed with inxi -r.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 8:26 pm

remoulder wrote:
bigj231 wrote:post the contents of /etc/apt/sources.list

@bigj231, mint uses the inxi tool to provide system information, all repositories can be listed with inxi -r.



Code: Select all
africamlion@africamlion-Dimension-5000 ~ $  inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com/ maya main upstream import
           deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ precise-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ precise partner
           deb http://packages.medibuntu.org/ precise free non-free
           deb http://archive.getdeb.net/ubuntu precise-getdeb apps
           deb http://archive.getdeb.net/ubuntu precise-getdeb games
           Active apt sources in file: /etc/apt/sources.list.d/damnvid-ppa-precise.list
           deb http://ppa.launchpad.net/damnvid/ppa/ubuntu precise main
           deb-src http://ppa.launchpad.net/damnvid/ppa/ubuntu precise main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/local-repository.list
           deb file:///usr/share/local-repository binary/
           Active apt sources in file: /etc/apt/sources.list.d/upubuntu-com-office-precise.list
           deb http://ppa.launchpad.net/upubuntu-com/office/ubuntu precise main
           deb-src http://ppa.launchpad.net/upubuntu-com/office/ubuntu precise main

africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 8:59 pm

Thanks remoulder. I had forgotten that.
It looks like one of your Google repositories is missing a key seeing your issue from the first post. Try unchecking all of the lines that contain "google" and then running:
Code: Select all
sudo apt-get update
That should run for a bit and return no errors. If there are any errors, post back here and we'll try to work them out.

If there are no errors after you have done that, you then need to get the proper signing key. From the page I linked to earlier, the process for that is
Code: Select all
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

After you get the key, you can then re-enable the Google repositories and run apt-get update again.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 9:40 pm

bigj231 wrote:Thanks remoulder. I had forgotten that.
It looks like one of your Google repositories is missing a key seeing your issue from the first post. Try unchecking all of the lines that contain "google" and then running:
Code: Select all
sudo apt-get update
That should run for a bit and return no errors. If there are any errors, post back here and we'll try to work them out.

If there are no errors after you have done that, you then need to get the proper signing key. From the page I linked to earlier, the process for that is
Code: Select all
wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

After you get the key, you can then re-enable the Google repositories and run apt-get update again.


Hi
That prblem is fixed and when i ran updates again it reported this

You have 2 broken packages on your system!

Use the "Broken" filter to locate them.

When i go to broken filters i get this

E: fgfs-base: dependency problems - leaving unconfigured
E: flightgear: dependency problems - leaving unconfigured

Sorry about this and thanks for your patience :(
Last edited by africanlion on Fri Nov 16, 2012 9:52 pm, edited 1 time in total.
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 9:45 pm

That shows me that there are 2 broken packages on your system. I would look for those two packages in Synaptic (use the search) and uninstall them or find the missing dependencies and install them. If flightgear is a 32 bit package and you are running a 64 bit system, you will need the ia32-libs(?) package. It might be easiest to uninstall flightgear then try reinstalling to get the dependencies working.
Try this line of code:
Code: Select all
sudo apt-get remove fgfs-base flightgear
That should uninstall those packages. Then post back if there are any more errors. Try looking in the documentary on flightgear's website to see the dependencies needed before reinstalling.
As an aside, I never had good performance with flightgear on any of my systems. I never uninstalled it but didn't reinstall it when I upgraded.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 9:55 pm

Done and got this from terminal after being asked to proceed y/n


Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  python-gdata fgfs-aircraft-base simgear2.4.0 python-wxtools rtmpdump libplib1 fgfs-models-base apport-hooks-medibuntu fgfs-scenery-base
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
  fgfs-base flightgear
0 upgraded, 0 newly installed, 2 to remove and 21 not upgraded.
2 not fully installed or removed.
After this operation, 357 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 184003 files and directories currently installed.)
Removing flightgear ...
Removing fgfs-base ...
dpkg: error processing fgfs-base (--remove):
 subprocess installed pre-removal script returned error exit status 1
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
 fgfs-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
africamlion@africamlion-Dimension-5000 ~ $
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby africanlion on Fri Nov 16, 2012 10:22 pm

Have uninstalled flightgear totally as i never use it anyway but still getting one error when updating

Selecting previously unselected package fgfs-base.
(Reading database ... 181332 files and directories currently installed.)
Preparing to replace fgfs-base 2.4.0-1 (using .../fgfs-base_2.8.0-1~getdeb1_all.deb) ...
Unpacking replacement fgfs-base ...
dpkg: error processing /var/cache/apt/archives/fgfs-base_2.8.0-1~getdeb1_all.deb (--unpack):
trying to overwrite '/usr/share/games/flightgear/Scenery/Airports/8/Q/1/8Q1.threshold.xml', which is also in package fgfs-scenery-base 2.4.0-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/fgfs-base_2.8.0-1~getdeb1_all.deb
W: Waited for dpkg --assert-multi-arch but it wasn't there - dpkgGo (10: No child processes)
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Fri Nov 16, 2012 10:33 pm

have you tried this?
Code: Select all
sudo apt-get install -f
The -f option tells it to fix. See what you get there. Also, don't forget to update your apt-cache.
EDIT: WOHOO! 101st Post!
EDIT 2: Also try purging fgfs-base
Code: Select all
sudo apt-get purge fgfs-base

EDIT 3: remove all the fgfs packages too. There is a shortcut, but you have to be careful that it doesn't uninstall anything important. Use wildcards (*) to select all packages like fgfs-*. It saves time, but you really need to check everything before you hit okay.
4 EDITS *AH AH AH*: you can use
Code: Select all
sudo apt-get autoremove
to remove all the packages that it says it doesn't need. Do this instead of what I suggested in edits 2&3.
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Re: Error occurs during update

Postby africanlion on Tue Nov 20, 2012 11:30 am

Thanks guys its fixed. Much obliged 8)
africanlion
Level 3
Level 3
 
Posts: 115
Joined: Sun Jul 08, 2012 7:33 pm

Re: Error occurs during update

Postby bigj231 on Wed Nov 21, 2012 1:56 pm

Great. Could you edit the thread title to include [SOLVED]?
Running on a 4-slot toaster @ 60Hz
User avatar
bigj231
Level 5
Level 5
 
Posts: 793
Joined: Fri Feb 26, 2010 10:16 am
Location: Middle of Nowhere

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: mdevour, tj-el and 21 guests