LM13 XFCE - Static IP + NetworkManager - DNS issue <SOLVED>

Questions about cabled networking
Forum rules
Before you post please read this

LM13 XFCE - Static IP + NetworkManager - DNS issue <SOLVED>

Postby hitekagpilot on Sat Nov 17, 2012 2:56 am

I am not sure if this is a bug with NetworkManager or what, however from compiling information from multiple locations I was able to resolve the issue.

SYMPTOM: After configuring LinuxMint 13 (Maya) XFCE to use a static IP, unable to use 'hostname' only identity when referring to network hosts on local network. Example: ping NAS01 would result in a DNS resolution failure, however, a 'ping NAS01.mydomain.com' would work.

RESOLUTION: After configuring your manual network settings via 'Menu -> Settings -> Network Connections'. I found adding the following entries into the /etc/resolv.conf file corrected the above listed issue.

*NOTE: For demonstation purposes the network configuration is as follows:

Host Addresses : 192.168.1.*
Subnet Mask : 255.255.255.0 (aka /24)
Gateway/Router : 192.168.1.1
DNS Server 1 : 192.168.1.1 <my network server>
DNS Server 2 : 8.8.8.8 <Google DNS1 Server>
DNS Server 3 : 8.8.4.4 <Google DNS2 Server>
Domain : mydomain.com


Add the following entries to your /etc/resolv.conf:

nameserver 192.168.1.1 <your Network DNS server IP Addrx>
nameserver 8.8.8.8 <optional>
nameserver 8.8.4.4 <optional>
domain mydomain.com
search mydomain.com

This corrected the problem on TWO LM13 machines I have on my home network (server setups).

HiTekAgPilot

===========================================================================

Workstation : LMDE + Cinnamon (64-bit)
Laptop : LMDE + Cinnamon (64-bit)
Server 1 : LM13 + XFCE (64-bit)
Server 2 : LM13 + XFCE (64-bit)
Server 3 : OpenMediaVault 3.0 (64-bit)
hitekagpilot
Level 1
Level 1
 
Posts: 1
Joined: Wed Oct 10, 2012 12:26 am

Linux Mint is funded by ads and donations.
 

Return to Ethernet

Who is online

Users browsing this forum: No registered users and 1 guest