Broken Dependencies!

Questions about applications and software
Forum rules
Before you post please read how to get help

Broken Dependencies!

Postby crazyfury on Sat Nov 17, 2012 8:28 pm

Hi I'm pretty new to the Linux scene, so far it's going great. Except I need help with a Broken Dependency. It occurs when I try to install web browsers such as Opera or any other web based apps. I need assistance.
It asks me to run gksudo synaptic or sudo apt-get install -f in a terminal to fix this error. I go ahead and run the terminal option instead of the gksudo synaptic. I receive this. The problem isn't solved. Please help. Thanks guys :D

crazyfury@crazyfury-System-Product-Name ~ $ sudo apt-get install -f
[sudo] password for crazyfury:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
rhythmbox-data python-ubuntuone-client libqt4-test libqt4-designer
ubuntuone-installer python-ubuntuone-storageprotocol libqt4-help python-sip
libcluttergesture-0.0.2-0 ubuntuone-control-panel-common
libclutter-imcontext-0.1-0 cheese-common libmx-1.0-2 libqtassistantclient4
python-apport libqt4-scripttools
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
docbook-xsl libencode-locale-perl libfile-listing-perl libfont-afm-perl
libhtml-form-perl libhtml-format-perl libhtml-parser-perl
libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-socket-inet6-perl libio-socket-ssl-perl
liblwp-mediatypes-perl liblwp-protocol-https-perl libmailtools-perl
libmysqlclient18 libnet-http-perl libnet-ssleay-perl libqt4-sql-mysql
libsocket6-perl libudev0:i386 liburi-perl libwww-perl libwww-robotrules-perl
libxml2-utils python3 python3-minimal python3.2 python3.2-minimal
Suggested packages:
docbook-xsl-doc-html docbook-xsl-doc-pdf docbook-xsl-doc-text
docbook-xsl-doc libsaxon-java libxalan2-java libxslthl-java
docbook-xsl-saxon fop xalan dbtoepub libdata-dump-perl libcrypt-ssleay-perl
libqt4-dev libauthen-ntlm-perl python3-doc python3-tk python3.2-doc
The following packages will be REMOVED:
apturl banshee bluez-gstreamer brasero brasero-cdrkit cheese
evolution-data-server gimp gir1.2-clutter-gst-1.0 gir1.2-rb-3.0
gir1.2-totem-1.0 gir1.2-ubuntuoneui-3.0 gir1.2-webkit-3.0
gnome-control-center gnome-media gnome-online-accounts
gnome-session-fallback gnome-sushi gnome-video-effects gstreamer0.10-alsa
gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-base
gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly
gstreamer0.10-pulseaudio gstreamer0.10-x gthumb indicator-datetime
indicator-power libbrasero-media3-1 libcheese-gtk21 libcheese3
libclutter-gst-1.0-0 libdmapsharing-3.0-2 libfarstream-0.1-0 libfolks-eds25
libgoa-1.0-0 libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0
libpurple0 libqtwebkit4 libreoffice-base libreoffice-base-core
libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
libreoffice-emailmerge libreoffice-gnome libreoffice-gtk
libreoffice-help-en-us libreoffice-impress libreoffice-java-common
libreoffice-math libreoffice-style-human libreoffice-style-tango
libreoffice-writer librhythmbox-core5 libsyncdaemon-1.0-1
libtelepathy-farstream2 libtotem0 libubuntuoneui-3.0-1 libwebkitgtk-1.0-0
libwebkitgtk-3.0-0 libyelp0 metacity mint-meta-cinnamon
mint-meta-cinnamon-dvd mintinstall mintwelcome nautilus-sendto-empathy
nautilus-share pidgin pidgin-facebookchat pidgin-libnotify python-gst0.10
python-qt4 python-ubuntu-sso-client python-ubuntuone-control-panel
python-uno python-webkit rhythmbox rhythmbox-mozilla
rhythmbox-plugin-cdrecorder rhythmbox-plugin-zeitgeist rhythmbox-plugins
rhythmbox-ubuntuone sessioninstaller totem totem-mozilla totem-plugins
totem-plugins-extra ubuntu-sso-client ubuntu-sso-client-gtk
ubuntu-sso-client-qt ubuntuone-client ubuntuone-client-gnome
ubuntuone-control-panel ubuntuone-control-panel-qt yelp zenity
The following NEW packages will be installed:
docbook-xsl libencode-locale-perl libfile-listing-perl libfont-afm-perl
libhtml-form-perl libhtml-format-perl libhtml-parser-perl
libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-socket-inet6-perl libio-socket-ssl-perl
liblwp-mediatypes-perl liblwp-protocol-https-perl libmailtools-perl
libmysqlclient18 libnet-http-perl libnet-ssleay-perl libqt4-sql-mysql
libsocket6-perl libudev0:i386 liburi-perl libwww-perl libwww-robotrules-perl
libxml2-utils python3 python3-minimal python3.2 python3.2-minimal
0 upgraded, 33 newly installed, 103 to remove and 31 not upgraded.
24 not fully installed or removed.
Need to get 0 B/8,154 kB of archives.
After this operation, 429 MB disk space will be freed.
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
dpkg: error: parsing file '/var/lib/dpkg/status' near line 10909 package 'libudev0:i386':
`Pre-Depends' field, invalid package name `multiarch%support': character `%' not allowed (only letters, digits and characters `-+._')
E: Sub-process /usr/bin/dpkg returned an error code (2)
crazyfury@crazyfury-System-Product-Name ~ $
crazyfury
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 17, 2012 8:18 pm

Linux Mint is funded by ads and donations.
 

Re: Broken Dependencies!

Postby daveit1000 on Sun Nov 18, 2012 12:14 am

hey so i got that error to what you do is open up your terminal windows by going in the menu and clicking on terminal or right clicking on a windows and click open in terminal then you type in the first option which is: gksudo synaptic, it will prompt you for your password enter it click OK. The manager will open up. There are 5 buttons they are: Section, Status, Origin, Custom Filters, Search Results you click on the custom filters one. Then on top there is a mini window what you click on is broken and to the right of it there will be your broken packages, you click on one press ctr-a(at least on my computer) this will select all the packages you right click on one then you choose mark for complete removal then a window will pop up click on mark and then on the toolbar in the synaptic package manager there is a button called apply click it. Another windows will open up click apply. Then it will remove those broken dependency's and you can happily install other deb files.

-Hope this helps
daveit1000
Level 1
Level 1
 
Posts: 7
Joined: Sat Sep 08, 2012 1:05 am

Re: Broken Dependencies!

Postby remoulder on Sun Nov 18, 2012 1:23 pm

crazyfury wrote:The following packages will be REMOVED

Not sure what you are trying to do here but you appear to be about to remove most of the system. Please provide more details of mint version and desktop and the command you are running.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Broken Dependencies!

Postby crazyfury on Sun Nov 18, 2012 10:30 pm

remoulder wrote:
crazyfury wrote:The following packages will be REMOVED

Not sure what you are trying to do here but you appear to be about to remove most of the system. Please provide more details of mint version and desktop and the command you are running.

What I am trying to do is fix the broken dependencies since they won't let me install apps or update. The two packages with errors is gvfs:i386 and libgudev-1.0-0:i386. My mint version as of now is the Linux 13 cinnamon. Desktop Details: Memory: 4GB Processor: AMD Phenom(tm) II X4 885 Processor x 4 Graphics card: GeForce 9800 GTX+/PCIe/SSE2 OS:64-bit. I am just using the default terminal that comes preinstalled if that's the command you are talking about.
crazyfury
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 17, 2012 8:18 pm

Re: Broken Dependencies!

Postby monkeyboy on Sun Nov 18, 2012 11:06 pm

Quick question, where did you download Opera from?
If you don't like it, make something better
If you can't make something better, adapt
If you can't do either ball your panties up and cry.

Complaining is like masticating most anyone can do it.
However doing it in public is really hardcore.
User avatar
monkeyboy
Level 5
Level 5
 
Posts: 793
Joined: Mon Oct 13, 2008 11:30 am

Re: Broken Dependencies!

Postby crazyfury on Tue Nov 20, 2012 3:35 pm

I tried downloading it from the software manager which looks like a star. That didn't work so I tried getting it from the official site. Downloading the default linux one and that didn't install because it said there was broken dependencies.
crazyfury
Level 1
Level 1
 
Posts: 3
Joined: Sat Nov 17, 2012 8:18 pm


Return to Software & Applications

Who is online

Users browsing this forum: tostoday and 19 guests