Linux Mint 14 Cinnamon - No Sound after Login

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Linux Mint 14 Cinnamon - No Sound after Login

Postby Dreamingtune on Sun Nov 18, 2012 1:19 pm

Hello

I made a new installation with RC Linux MInt 14 Cinnamon. All works, only sound make problems.

I have hear the little tick when the login screen to insert username/passwort appears, i hear the login sound but after login i have no sound.

I saw that i was not in the Group "sound", so i added me succesfully and after reboot it works like a charm -but only this one.

After starting again this evening i have at new no sound. I tried to uncheck "pulseaudio" in startup programms, does not help, i looked into alsamixer, nothing is muted. I klick on Volumecontrol in the Panel and see the output device "Internal Audio Analog Stereo" and in the parameters from sound i see "Analog Stereo Duplex".

Here some information:

Code: Select all
rina@rina-Aspire-5930 ~ $ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
rina@rina-Aspire-5930 ~ $ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf6500000 irq 48
rina@rina-Aspire-5930 ~ $ aplay /usr/share/sounds/startup.wav
/usr/share/sounds/startup.wav: Datei oder Verzeichnis nicht gefunden
rina@rina-Aspire-5930 ~ $ cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC888
Codec: LSI ID 1040
Codec: Nvidia MCP77/78 HDMI
rina@rina-Aspire-5930 ~ $


How can I resolve this? I need sound :-(
Dreamingtune
Level 1
Level 1
 
Posts: 10
Joined: Tue Feb 14, 2012 7:21 pm

Linux Mint is funded by ads and donations.
 

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby wazntme on Sun Nov 18, 2012 1:30 pm

I just resolved a similar problem.

My issued had to deal with HDMI settings sound config panel acting goofy and not saving.

I set everything to Built in Analog Stereo.

Right click speaker icon in lower panel make sure mute is not selected.
Left click speaker icon in lower panel, set output to analog stereo

I am new to this so....
User avatar
wazntme
Level 1
Level 1
 
Posts: 13
Joined: Tue Nov 13, 2012 8:39 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby remoulder on Sun Nov 18, 2012 1:42 pm

Discussion of Mint 14 RC issues as requested at http://blog.linuxmint.com/?p=2205
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby Dreamingtune on Mon Nov 19, 2012 6:31 pm

Hello

any other ideas?

Sound on my RC 14 is like playing Lotto, this reboot i have sound, next no, next no, after i have, after no. I newer know if i will have. Often it works, after login too, but if i click on a mp3 or oder music file, i hear a knock on the speakers and all is dead.

Please help me. It is possible that i have this problem because of the Nivida Driver? Because when i take a look into gnome-alsamixer it shows mit Nvidia 76/77 HDMI, but my soundcard is a realtek LC888!

But i did not found how change or control this.

Please help me
Dreamingtune
Level 1
Level 1
 
Posts: 10
Joined: Tue Feb 14, 2012 7:21 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby pkas on Tue Nov 20, 2012 12:09 pm

Try this, if you do not have sound...

1) Find the little icon on your menu/status bar that represents the speaker. It is probably near the right edge, but to the left of the date and time. Maybe to the left of the battery/power indicator.
2) Left click on the icon
3) You should see "Output device..." -- click it
4) You will see some choices. Select the one that is not currently selected.

This might help!

pkas
pkas
Level 1
Level 1
 
Posts: 2
Joined: Tue Nov 20, 2012 11:57 am

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby Dreamingtune on Tue Nov 20, 2012 4:12 pm

Hello

Thanks for your answer. Unfortunately when i made right click on the icon and then choose Output Devices, I only have one devices the actually selected "Internal Audio Analog Stereo" device.

I just noticed that when i connet my headphones, i have sound :shock:

I found the problem! :D in alsamixer I saw that "auto mute" was on! After deactivating this, i hear sound in my speakers.
After reboot i still have sound, and now, after 4 days and many reboots and shutdown i still have sound.

RESOLVED
Dreamingtune
Level 1
Level 1
 
Posts: 10
Joined: Tue Feb 14, 2012 7:21 pm

Linux Mint's Multiple Personality Disorder

Postby Gid on Sun Nov 25, 2012 10:57 am

I know this topic is marked as solved, but it's recent, and I had the same problem but found a different solution.

The whole thing started because the mixer applet wasn't appearing in my notification area. I added the horizontal one but double-clicked it by accident, muting the system. I go to unmute it, and nothing responds.

Enabling alsa-utils under Services in the Control Center brought back my audio.

I love Linux Mint, but jeez does its multiple personality disorder cause some headaches... I've found no less than four volume control apps so far!
Gid
Level 1
Level 1
 
Posts: 8
Joined: Sun Nov 25, 2012 8:44 am

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby beriaanirudh on Mon Dec 10, 2012 1:23 pm

Dreamingtune wrote:Hello

Thanks for your answer. Unfortunately when i made right click on the icon and then choose Output Devices, I only have one devices the actually selected "Internal Audio Analog Stereo" device.

I just noticed that when i connet my headphones, i have sound :shock:

I found the problem! :D in alsamixer I saw that "auto mute" was on! After deactivating this, i hear sound in my speakers.
After reboot i still have sound, and now, after 4 days and many reboots and shutdown i still have sound.

RESOLVED


Thanks dude!! i had the same problem..
beriaanirudh
Level 1
Level 1
 
Posts: 7
Joined: Thu Jun 07, 2012 2:54 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby TuxSurfer on Thu Dec 20, 2012 9:56 am

Dreamingtune wrote:
...I found the problem! :D in alsamixer I saw that "auto mute" was on! After deactivating this, i hear sound in my speakers.
After reboot i still have sound, and now, after 4 days and many reboots and shutdown i still have sound.

RESOLVED


Had the same issue also, Thanks, fixed it for me too! :D
User avatar
TuxSurfer
Level 1
Level 1
 
Posts: 4
Joined: Wed Oct 31, 2012 6:41 pm
Location: Boone, NC USA

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby spnoe on Mon Feb 18, 2013 1:38 pm

TuxSurfer wrote:
Dreamingtune wrote:
...I found the problem! :D in alsamixer I saw that "auto mute" was on! After deactivating this, i hear sound in my speakers.
After reboot i still have sound, and now, after 4 days and many reboots and shutdown i still have sound.

RESOLVED


Had the same issue also, Thanks, fixed it for me too! :D


Could someone advise me; I too have aproblem with sond via HDMI and when I checked Alsamixer I noticed it said that Auto Mute was enabled but I could not find a way to change this, youir help is very much appreciated.

Steve
spnoe
Level 1
Level 1
 
Posts: 12
Joined: Wed Aug 05, 2009 5:47 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby deminted on Fri Apr 12, 2013 11:12 am

First install & update alsamixer if it's not there. You can use Admin>software manager.
I have alsamixergui, alsa-utils, alsa-base installed.
in terminal
sudo alsamixer
Which generally comes up as a coloured panel with Master selected
use up-arrow to up the volume of the Master control.
Now scroll across the alsamixer controls using right-arrow >>, until you see the automute column
use down-arrow to set auto-mute to disabled
ctl-C gets out of alsamixer back to terminal.

This gets sound re-started for me. In terminal:
sudo alsactl -F init
then adjust alsamixer as above.
see
http://forums.linuxmint.com/viewtopic.php?f=48&t=122501&p=708231#p708231
deminted
Level 1
Level 1
 
Posts: 21
Joined: Thu Jan 12, 2012 4:34 pm

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby ArthurTonyPark on Sun Apr 28, 2013 3:12 am

I had a problem that was specific to the HDMI sound output. Solved by opening sound settings (left click on speaker icon, select sound settings). I too saw only one device in the 'output' tab of sound settings. However, I selected the 'hardware' tab, clicked on 'built-in audio' and changed the settings for the selected device to 'Digital Stereo (HDMI) + Analog Stereo Input'. This altered the single device available in the 'output' tab to be HDMI specific, and sound sprang into life.

Tony
You learn something new every day. Especially if you've just started using Linux.
ArthurTonyPark
Level 1
Level 1
 
Posts: 5
Joined: Fri Apr 19, 2013 2:15 am

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby iamramgarg on Wed Jun 12, 2013 2:06 am

Try this, it worked out for me.

1:) Type the following in the terminal:
gksudo gedit /etc/modprobe.d/alsa-base.conf

2:) Then add the following at the bottom of the file
options snd-hda-intel model=auto
iamramgarg
Level 1
Level 1
 
Posts: 1
Joined: Wed Jun 12, 2013 2:00 am

Re: Linux Mint 14 Cinnamon - No Sound after Login

Postby bugeyedalien on Wed Oct 30, 2013 8:46 pm

Anyone who have problems with no HDMI audio on Nvidia drivers.
Left click on the speaker symbol in your notification area, choose sound settings.

- Go to the Hardware tab

- Look at settings for the selected device , profile.
try the different outputs, make sure to have something playing in the background,
just make sure the volume is not too high if this works.

- Make sure you choose HDMI audio as output in the Output tab.

Oddly enough the "test speaker" does not work for me unless I already have something playing in the background .. !
bugeyedalien
Level 1
Level 1
 
Posts: 2
Joined: Wed Oct 30, 2013 7:51 pm
Location: South of Oslo.

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: rmockler and 6 guests