No sound in Impress

Questions about applications and software
Forum rules
Before you post please read this

No sound in Impress

Postby Nicki on Wed Nov 03, 2010 3:27 am

I have some PowerPoint presentations. They works in Windows. But now I can't hear the sound in some of them in Linux and Impress. I have no problem with the sound in other programs.
Nicki
Level 3
Level 3
 
Posts: 164
Joined: Wed May 27, 2009 3:15 pm
Location: Sweden

Linux Mint is funded by ads and donations.
 

Re: No sound in Impress

Postby unexistance on Wed Nov 03, 2010 9:28 pm

Hi,

As far as I know, multimedia support in OpenOffice are not that stellar, so to say :D

So you might need to modify the presentation in Impress

Regards,
:: Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved ::
unexistance
Level 5
Level 5
 
Posts: 646
Joined: Tue Aug 05, 2008 12:28 am
Location: Malaysia

Re: No sound in Impress

Postby princeinflorida on Fri Dec 17, 2010 5:43 pm

I was surprised and delighted to find that Linux Mint 8 played Powerpoint sound without any additional configuration. This was the first time with sound for me in any Linux distro.

I happened to use the very nice LXDE version, installed on one of my computers. The inclusion of codecs and design to play sound without additional configuration and installations was one of the reasons that I switched from another distro to Mint.

Now I find that in Mint 10 Gnome that it does not render sound with Powerpoint files.

I am hoping that the solution to this will be posted here.

In the mean time, you might try via Live CD Mint 8 and 9 with Powerpoint files containing sound to confirm.
Last edited by princeinflorida on Sat Dec 18, 2010 11:55 am, edited 1 time in total.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress

Postby riki on Sat Dec 18, 2010 5:11 am

Nicki wrote:I have some PowerPoint presentations. They works in Windows. But now I can't hear the sound in some of them in Linux and Impress. I have no problem with the sound in other programs.


Loooooong drawn out unresolved problem! I spent months and months trying to find a fix and eventually gave up. Some Linux distros seem to work OK, others not and, so far, there is nothing one can do about it. Believe me... and don't waste your time!
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: No sound in Impress

Postby princeinflorida on Sat Dec 18, 2010 12:21 pm

Niki, Rikki is right about the too long of a job attempting to configure your existing Impress installation.

Being to be able to fully render a Powerpoint file including sound is important to me so I have come up with what I posted above with the addition of the following.

I like Mint 8 LXDE which natively renders sound in PPT and was disappointed to find the Mint 9 LXDE did not natively contain Open Office in an attempt to make it even lighter. The Gnome editions all contain OO, as far as I know, and, in interest of this discussion, I just tried Mint 8 Gnome Live CD and it successfully renders sound in PPT. Again, I suggest you try Mint 9 Gnome Live CD.

For me, I have compromised to fully play PPT vs the very latest version of Mint. I am still using my installed Mint 8 LXDE.

You might also try Synaptic Package Manager to install the Powerpoint Viewer. Be sure to refresh it before entering "powerpoint" in the search window and you should find pptview that is something like an 80mB install. The install includes Wine since pptview is a version of Microsoft's free Powerpoint Viewer. Since I don't have Mint 10 installed, I don't know if you will have luck with sound, but it may be worth the try.

Also, make sure your version is fully updated. It would be nice if this alone would solve the sound problem

My Powerpoint test file is available here: http://www.box.net/shared/8is4icl0mb
Last edited by princeinflorida on Tue Dec 21, 2010 2:11 pm, edited 1 time in total.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress

Postby princeinflorida on Sat Dec 18, 2010 7:01 pm

I just tried Mint 9 Gnome Live CD and it fully renders sound in Powerpoint upon booting by default, with no configuration required other than Unmuting. (The default upon booting is Mute.)

Here is a second test Powerpoint file containing sound for trial: http://www.box.net/shared/p5j5h17u8n

It would be really nice if this capability were included in versions later than 9.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress

Postby riki on Sun Dec 19, 2010 4:25 am

princeinflorida wrote:I just tried Mint 9 Gnome Live CD and it fully renders sound in Powerpoint upon booting by default, with no configuration required other than Unmuting. (The default upon booting is Mute.)

Here is a second test Powerpoint file containing sound for trial: http://www.box.net/shared/p5j5h17u8n

It would be really nice if this capability were included in versions later than 9.


Well, I can't get sound in either LMDE or Julia.
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: No sound in Impress

Postby princeinflorida on Tue Dec 21, 2010 2:26 pm

Riki,
Note: Mint8 is Helena and Min9 is Isadora. As posted above Mint10 Julia does not render sound upon booting the live cd.

Be sure that your sound is working in general by playing an mp3 or video running Mint8LXDE or Mint8Gnome or Mint9Gnome as Live CD.

Also on live CD the sound is muted by default, so Unmute the sound.

After you confirm that sound is working for mp3 or video, open a Powerpoint file that you know for sure has sound. (I've uploaded two test files linked above.)

From my experience, you should have sound with the test files above. I don't know for sure about performance with a file made with Powerpoint 2007, but at least this is a start. Maybe someone who has a known PPT 2007 can give it a try and report here.

Since Mint 9 Isadora is a long term support release (LTS), supported until April 2013, this may be a good choice for an installation that plays PPT sound by default.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress

Postby riki on Tue Dec 21, 2010 3:51 pm

Thanks for your input princeinflorida. I have never used Helena. I am no longer interested in trying to make PPSs play sound in Linux, as stated earlier I have already spent/wasted far too much time on this issue. If it doesn't work out of the box, forget it. The devs know about it, they might decide to find a way one of these days. OOo/Impress with whom I've been corresponding don't appear to be interested either, so blow it.
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: No sound in Impress

Postby princeinflorida on Wed Dec 22, 2010 9:07 am

Hi Riki,
After spending a few years with various Linux distros and experiencing the problems especially with printers and this PPT sound problem, I can understand your feelings and frustration. The Mint10 Julia is unfortunately deficient for PPT initially, but your PPT problem is solved in the three Mint versions specified above. Your Powerpoint files will be fully rendered (including sound) "right out of the box". The nice thing is that it can be tried via Live CD and if one likes it, installed right then and there.
Best, Jon.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress

Postby riki on Wed Dec 22, 2010 9:18 am

princeinflorida wrote:Hi Riki,
After spending a few years with various Linux distros and experiencing the problems especially with printers and this PPT sound problem, I can understand your feelings and frustration. The Mint10 Julia is unfortunately deficient for PPT initially, but your PPT problem is solved in the three Mint versions specified above. Your Powerpoint files will be fully rendered (including sound) "right out of the box". The nice thing is that it can be tried via Live CD and if one likes it, installed right then and there.
Best, Jon.


Hi again princerinflorida. Wish I was in sunny Florida, here it's minus tons of degrees C and hibernating most of the time. If prior to the creation of Julia other flavours of Mint had sound with PPSs then I see no reason why the devs can't fix Julia to play sound in the very near future, surely it can't be that difficult. So I'll stick with Julia (I don't like going backwards) and be patient for things to happen. :)
Riki

Image
User avatar
riki
Level 4
Level 4
 
Posts: 370
Joined: Thu Jun 03, 2010 4:57 pm
Location: UK

Re: No sound in Impress

Postby princeinflorida on Thu Dec 23, 2010 8:58 am

Roger that and good for you!
BTW, it's 8 AM here in Miami now and 16C with a predicted high of 23C today.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Cloud Presentation With Sound and Sharing: authorStream

Postby princeinflorida on Wed Dec 29, 2010 10:17 am

Most online Powerpoint presentations, such as Google Docs (on my last try), do not render sound. I have found one that presents with sound and is a good sharing site. My Firefox browser seems to work best for fullscreen viewing. My Chrome browser did not present fullscreen but now with the latest version it works fine for fullscreen. So if you have a fullscreen problem, try another browser or a later version.

Here is a sample.
http://www.authorstream.com/Presentation/princeinflorida-739176-mirror-on-the-water/
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Re: No sound in Impress until now in LinuxMint13

Postby princeinflorida on Sun Nov 18, 2012 6:09 pm

:D OK, here it is two years later and the pendulum has swung back onto the positive side. As in LinuxMint8, my current installation of LinuxMint13Maya renders sound in presenting PPT files. How nice and I just found this out after having it installed for months now. :D The default application here for PPT is LibreOffice3.5 Impress and it works out of the box for sound.
User avatar
princeinflorida
Level 1
Level 1
 
Posts: 36
Joined: Thu Apr 08, 2010 4:43 pm

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: Flemur, Mark Phelps and 29 guests