Sound, Sound, my kingdom for a sound!!!

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Sat Nov 17, 2012 5:51 am

Have previously used Mint Debian. Approximately two weeks ago I was listening to a DVD, downloading and doing another
job on a spreadsheet when the broadband (wire not wireless) started to go down. I shut everything down and rebooted. Internet works fine but sound does not. Playback: Dummy output (Pulseaudio mixer). What the connection is between the broadband and sound card, I know not.

I know the sound card works because on Windows it is fine and I have managed to get it functioning with other editions of Mint but not Debian. Unfortunately, none of the other editions of Mint will either not install, or if they install refuse to boot.As a consequence, I have been resorting to live working of Mate to prove that sound does work.

The installing and boot issue is not for now.

The motherboard is AsusM4N78-AM and audio VIA VT 1708S 6-Channel
I have tried removing both ALSA and PulseAudio and re-installing but has no effect.

Please, Please let me know how to fix this issue. There must be knowledgeable Mint Maestros who know the answer to my problem.

love Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Linux Mint is funded by ads and donations.
 

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Sat Nov 17, 2012 8:18 am

Have you tried
Code: Select all
mv ~/.pulse pulse.bak
then restarting and seeing if you can reconfigure pulse-audio?
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Sat Nov 17, 2012 9:00 am

I typed the command exactly as you recommended in the terminal and got reply that pulse.bak is not recognised.
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Sat Nov 17, 2012 9:27 am

cwsnyder wrote:Have you tried
Code: Select all
mv ~/.pulse pulse.bak
then restarting and seeing if you can reconfigure pulse-audio?

My mistake. ~/.pulse is a folder. You will need to:
Code: Select all
mkdir pulse.bak
mv ~/.pulse pulse.bak
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Sat Nov 17, 2012 6:11 pm

you must think I am a plonker because I can't get anything to work!

The commands you recommended for the terminal produced replies against the first that the file alredy exists and against the second command unknown command
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Sun Nov 18, 2012 1:52 pm

The reason I typed them in to code blocks was so that you could simply copy the commands and paste them into your terminal. See if that works.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Mon Nov 19, 2012 4:01 am

Perhaps there are things which are not to be. Maybe I am destined never to hear sound on Mint.
Thanks for your help. Unfortunately the commands failed to respond with any help. Responses were in the negative.
I used SUDO

To be honest with you I have spent in excess of 60 hours trying to find a solution and now I am tired of the problem. There seems to be so many faults with Mint. Mint 13 failed to boot , Mint 14 failed to boot and Debian which I ran for over 6 months gave up on me. Installing a new download of Debian Cinnamon proved fruitless. Debian 10 seemed to work but the sound faded half way through the first song and then returned intermittently until the gaps of silence increased to hours!

I run three machines the motherboards are all new and different. This motherboard is an ASUS M4N78-AM

I just want a click solution. I am no good at terminal entries.

Perhaps a fatalistic view is the right way to proceed. Bin Mint and go back to Windows.

Love Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby Bonsaii on Mon Nov 19, 2012 6:56 am

Hi Curtrey,

What I believe cwsnyder wanted you to do,
is delete ("move to trash) your pulse user profile.
Upon reboot pulseaudio will create a new - hopefully functioning - one.

So, just open a file browser like nautilus,
click on your "home" folder,
hit ctrl+h to view hidden files and folders,
scroll down and delete the folder ".pulse"
and the file ".pulse-cookie".
Then reboot and see whether you got sound.

Good luck!
Thinkpad T410s, LMDE 64Bit, Cinnamon
Bonsaii
Level 2
Level 2
 
Posts: 89
Joined: Sat Oct 09, 2010 8:49 am

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Mon Nov 19, 2012 5:52 pm

Thanks for your help but not successful.

I think the solution lies with the message I got on one occasion, which read :-

Open Sound System No kernel Modules detected

This indicates to me that all my copies of Debian cinnamon are deficient of a ("driver") module in the kernel which would turn on the sound in Debian cinnamon. Why this should be, I don't know. I can hear songs using Microsoft Windows so there is not a fault with the hardware of the Motherboard.

I am sorry to say that I haven't a clue how to rectify the effects of the missing module in the kernel.
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby bu99zy on Mon Nov 19, 2012 6:03 pm

Try installing PulseAudio Volume Control and changing the profile of the configuration

Code: Select all
apt install pavucontrol


Image
User avatar
bu99zy
Level 3
Level 3
 
Posts: 135
Joined: Wed Jan 18, 2012 12:59 am

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Tue Nov 20, 2012 6:31 pm

Followed your instructions (copied and pasted to Terminal. Lots of action sent my hopes rising. On completion of Terminal activity I closed the computer and re-booted. Yes the Volume Control was in the Menu. Opened it and went to Configuration.
Click and "No Cards available for Configuration". Hopes dashed again!!!

This mystery grows by the day as today I downloaded Mint 14 RC. It did install but would not boot conventionally. I got it to boot by using SUPERGRUB which was the only way it would and then it was only in the safe mode. My point is that sound worked very well. I listened to songs whilst trying to sort out the boot problem. I gave up after a couple of hours but I do know the sound will work. It just refuses to do so in Debian.

What to do next?

love Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Tue Nov 20, 2012 7:07 pm

You can try creating a folder called something like bak and dragging your .pulse-cookie and .pulse folder inside the folder from your file manager, then try again to delete both file and folder and restart.otherwise. I don't know how else to get your sound which was working to work again without re-installing at least pulse-audio, or LMDE.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Wed Nov 21, 2012 9:22 am

Well chaps I suppose Christmas is close and mysteries are in the air. Today I booted LMDE and clicked on the volume control. Bingo, Kilo Gulf Ding Dong, a miracle. My audio device, Via VT 1708s is showing in the panel. That's the good news,
now for the bad:-

1. I've no idea what went wrong and moreover what fixed it.

2. LMDE now won't recognise the DVD drive so I still can't hear my tunes.

Over to you, over.

love Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Wed Nov 21, 2012 1:41 pm

Try installing the lshw package, then running the command in a terminal window and see if your DVD is listed there.
Code: Select all
sudo apt-get install lshw
lshw
You can also put one of your disks in the DVD and see if it will be mounted. In a terminal window, type ls /media/cdrom for a directory of a mounted CD.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby nobodynoze on Thu Nov 22, 2012 3:11 pm

With the hardware AsusM4N78-AM and audio VIA VT 1708S 6-Channel, it should work.

What is the current situation regarding ALSA and/or pulseaudio?

I wouldn't get rid of them. You could try a live dvd and mess around so that it isn't permanent in case, you try a bunch of settings. :)

The Volume Control, I found that after a while, I am able to figure things out. I had a lot of trouble configuring skype and sound to work through a usb headset I bought.

So many sound/audio options are given, but only some work or channel sound through. Also, you should look for some controls being either muted or way low.
nobodynoze
Level 1
Level 1
 
Posts: 47
Joined: Sat Oct 13, 2012 8:54 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Fri Nov 23, 2012 7:36 am

Hello Curtrey here

I got so fed up with the situation that I cleaned the partition which Mint was on and re-installed.

The strange thing is that if I use Mint live before installation it will see the sound card. But as the installation disc is in the DVD slot I can not play tunes. If I choose to install, then the system declines to recognise the sound card and consequently no sound. I have tried just about every combination of alsa and pulse having deleted and installed many many times.

I am beginning to believe that the problem is fundamental and lies in the heart of the Mint Debian system and not with pulse or alsa. When installed neither alsa or pulse can get to work as the system has not detected the VIA VT 1708S card. But it can when not installed!!!!!

Unfortunately I have no idea how to proceed and to make the system detect the VIA card so that both alsa and pulse come into the picture. The VIA works well with Microsoft Windows and used to work with Mint Debian until one day it stopped.
I can not understand why a reinstall does not rectify the fault and I have tried several downloads in case I had a corrupted download but the result is always the same - no sound.

Debian 10 could detect the VIA but the sound would fade after half a tune and the become very intermittent until I got a bleep every 10 minutes!!! No good bin it.

I will put my cards on the table and say that I am finding the Mint project fraught with problems and perhaps only valid to a very few software engineers. I can not get Mint 13 to load, Mint 14 I can not boot with GAG and when I try using SUPERGRUB after installation it fails to BOOT. I understand GAG doe not like any value of GRUB above 1 and used to be able to change Grub 2 for GRUB legacy but the option is not available with Mint 14. Bye-bye GAG.

If I costed out the time I had spent messing about with Mint which would be approximately 80 hours I could have bought 20 copies of Windows which I know works and if it did not I could kick ass.

I can work Mint Debian on 2 of my machines and have been doing so for over 6 months but this machine and Mint don't go together and I want all 3 to use the same system. At present Mint does not seem a candidate.

Best wishes Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Fri Nov 23, 2012 5:04 pm

I am embarrassed to say that after today's exploits there is probably nothing wrong with LMDE.
I removed the hard drive from the itinerant machine t test if the hard drive was corrupt or program on it. I put the hard drive into my second machine and booted it up. LMDE detected the sound card in the second machine resolving the issue of a corrupt program or hard drive.

So I am left with the following evidence:-

LMDE on the hard drive operates fine but not in machine 1
There is nothing wrong with the hard drive in machine 1

I am further lead to believe that the fault lies with the motherboard and in particular the VIA Vt 1708s sound card. However the sound card works OK with WINDOWS so it is failing in operating with LMDE

I found a reference in the VIA website to 1708 not working with Debian and a possible two fixes. However they are in the form of tar.gz files and I have no knowledge how to handle them. To get them installed needs a package created and I am, not able to do it.

Anybody got any ideas?

love Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Re: Sound, Sound, my kingdom for a sound!!!

Postby cwsnyder on Sat Nov 24, 2012 5:43 pm

tar.gz files usually include a README file outlining the process used to install the package. The main disadvantage to .tar.gz files in Ubuntu/Debian derivatives is that you will have to manually do any upgrades, and possibly may have trouble later if any if its dependencies update.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Sound, Sound, my kingdom for a sound!!!

Postby Curtrey on Fri Nov 30, 2012 4:40 am

I find it difficult to believe that no one knows how to fix the sound problem I have with LMDE.
But so be it. My view, for what it is worth, is that LMDE will always be in the margins. Potential users will be frighten back to WINDOWS, not only by the geek language and technical culture found in the forums but the inability of LMDE to provide an acceptable alternative to WINDOWS.

Curtrey
Curtrey
Level 1
Level 1
 
Posts: 36
Joined: Thu Nov 08, 2012 5:07 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 4 guests