Airplane mode stuck, rfkill unblock does not work.

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Airplane mode stuck, rfkill unblock does not work.

Postby d3sf on Tue Nov 20, 2012 8:38 pm

Hi,
I have a Sony VAIO model E SVE17115FDB Laptop using Atheros AR9485WB-EG Wireless Network Adapter. The problem here is simple, everytime i boot Linux Mint 13 Cinnamon 64-bits either via Mint4Win or a CD, Linux Mint always boot with Bluetooth On, but with Wireless Off and i can't set it On because "Airplane Mode" is on at boot and does not want to turn off. I tried running RFKILL List all and it gave me some stuff but the only blocked one was an "acer-wireless" one which was Softblocked. That's weird since my computer also had a Sony Wireless LAN which was not blocked at all. I tried rfkill unblock all but it only unblocked the Bluetooth which was responsive anyway. What should i do?

PS : I'm trying to boot Linux Mint 13 via CD or Mint4win since my computer uses hybrid Ivy Bridge (Core i7) and AMD RADEON HD 7650M and i want to check if i can get them to work since i had some problems with them using Ubuntu 12.04 (which had no Wireless problems). I'm on Windows 7 and intended to Dualboot.

I can provide more informations but it may take some time since i need to boot into a CD.

SOLUTION : using rmmod acer-wmi would unblock the wifi so, blacklisting acer-wmi unblocks the wifi and airplane mode.
d3sf
Level 1
Level 1
 
Posts: 4
Joined: Tue Nov 20, 2012 8:20 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 12 guests