Wireless Internet will not work

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[Wrong Info] Atheros Wifi Not Working

Postby stetucke on Wed Nov 21, 2012 3:21 pm

I set up Mint 13 on my HP mini 110 netbook yesterday, the OS loaded fine. The hardwire ethernet connection works.

I looked through these forums on how to get the wifi to work. I have downloaded and installed the ath9k_htc package like of thread suggested, no luck. I then found another thread that had a bunch of commands for the terminal to istall madwifi and WiCD so I followed that but still not luck.

Any help would be greatly apperciated as I am new to linux and now about 12 hours into this wifi problem. Thanks.
Last edited by stetucke on Wed Nov 21, 2012 7:56 pm, edited 1 time in total.
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Linux Mint is funded by ads and donations.
 

Re: Atheros Wifi Not Working

Postby AlbertP on Wed Nov 21, 2012 3:59 pm

Please run these commands in terminal and post the output:
Code: Select all
inxi -N
rfkill list
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros Wifi Not Working

Postby stetucke on Wed Nov 21, 2012 4:07 pm

stetucke@stetucke-Compaq-Mini-110c-1100 ~ $ inxi -N
Network: Card-1: Atheros AR8132 Fast Ethernet driver: atl1c
Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge
stetucke@stetucke-Compaq-Mini-110c-1100 ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Re: Atheros Wifi Not Working

Postby AlbertP on Wed Nov 21, 2012 4:11 pm

You don't have Atheros wifi, the Atheros chip here is your wired network. The wifi is Broadcom BCM4312.

Please connect to wired internet and install firmware-b43-lpphy-installer from Software Manager. Then wifi should work.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Atheros Wifi Not Working

Postby stetucke on Wed Nov 21, 2012 5:03 pm

When I first loaded the file I could see wireless connections in the area but could not connect. I restarted and now I can not see any wireless connections. Also the icon in the system tray of the two connected wires has been dulled and a red x is next to it. Also there is a new icon I thing from WiCD. The wired connection still works.
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Wireless Internet will not work

Postby stetucke on Wed Nov 21, 2012 7:54 pm

I have a Atheros AR8132 Fast Ethernet wired connection that works and a Broadcom BCM4312 802.11b/g LP-PHY that will not connect. I have tried loading drivers and following other procedures on these forums nothing has worked yet. I am running an HP Mini 100 with Mint 13. When I first loaded firmware-b43-lpphy-installer from Software Manager I was able to see wireless networks but not connect. After restarting I can no longer see the networks near me.

Thanks this problem has been whipping my rear.
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Re: [Wrong Info] Atheros Wifi Not Working

Postby fpd on Wed Nov 21, 2012 9:17 pm

STETUCKE:

I am no expert, but Mint13's Update kills wifi (Atheros, Broadcom, etc...) and touchpads.

I installed LM13 on my netbook and my wifi worked perfectly for over half a year (I work in crazy locations with minimal wifi, so updating hundreds of files is unthinkable - this forum barely loads). The moment I rebooted after letting LM13 "Update" (I went home where wifi is "normal"), my wifi AND my touchpad did not show as devices or modules. I re-installed LM13, disabled auto-update and will wait for LM15 to make the fix. I don't think anyone who can make changes listens to little people like me, so I look for my own (imperfect) solutions.

I dual-boot Windows (sorry... I need it so I can use Rosetta Stone and a few Windows-only apps), and my wifi and touchpad work normally... so all the "are you sure it works?" questions pushed me make my final (imperfect but functional) decision. Disabled AutoUpdate.

Best o'luck.
fpd
Level 1
Level 1
 
Posts: 32
Joined: Thu Oct 22, 2009 9:09 am

Re: Wireless Internet will not work

Postby AlbertP on Thu Nov 22, 2012 5:34 am

@ stetucke: You have probably installed the Broadcom STA driver. Please deactivate it in Additional Drivers if you ever activated it there.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless Internet will not work

Postby stetucke on Thu Nov 22, 2012 10:29 am

Disabled the driver in additional drivers, it still says no wireless networks found.
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Re: Wireless Internet will not work

Postby AlbertP on Thu Nov 22, 2012 1:59 pm

Please post inxi -N output again, when the wifi is not working.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: [Wrong Info] Atheros Wifi Not Working

Postby simple simon on Thu Nov 22, 2012 8:09 pm

fpd wrote:STETUCKE:

I am no expert, but Mint13's Update kills wifi (Atheros, Broadcom, etc...) and touchpads.

I installed LM13 on my netbook and my wifi worked perfectly for over half a year (I work in crazy locations with minimal wifi, so updating hundreds of files is unthinkable - this forum barely loads). The moment I rebooted after letting LM13 "Update" (I went home where wifi is "normal"), my wifi AND my touchpad did not show as devices or modules. I re-installed LM13, disabled auto-update and will wait for LM15 to make the fix. I don't think anyone who can make changes listens to little people like me, so I look for my own (imperfect) solutions.

I dual-boot Windows (sorry... I need it so I can use Rosetta Stone and a few Windows-only apps), and my wifi and touchpad work normally... so all the "are you sure it works?" questions pushed me make my final (imperfect but functional) decision. Disabled AutoUpdate.

Best o'luck.


Hi there, how did you reinstall? Just start from the CD and overwrite the existing installation?

I only installed Mint a few days ago on a pc that also multi-boots with windows and everything worked well until I allowed Mint to update... now I cannot go online, although the network works for computers in the same office and this computer still works OKwhen booted into Windows.

Simon
simple simon
Level 1
Level 1
 
Posts: 4
Joined: Thu Nov 22, 2012 9:07 am

Re: Wireless Internet will not work

Postby stetucke on Thu Nov 22, 2012 9:50 pm

Albert,

inxi -N
Network: Card-1: Atheros AR8132 Fast Ethernet driver: atl1c
Card-2: Broadcom BCM4312 802.11b/g LP-PHY

Thanks.
stetucke
Level 1
Level 1
 
Posts: 6
Joined: Wed Nov 21, 2012 3:10 pm

Re: Wireless Internet will not work

Postby mister_lister on Fri Nov 23, 2012 12:48 am

This is what I did to resolve my Broadcom wireless issues on a laptop:

do the following in terminal in your "/home/*user*/downloads/" directory...

sudo apt-get install b43-fwcutter
click on this link and download this file: http://mirror2.openwrt.org/sources/broa ... .5.tar.bz2
tar xf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
sudo b43-fwcutter -w /lib/firmware wl_apsta.o
modprobe b43


I edited as administrator the "/etc/modules" file and found that the "b43" module was in fact spelled in Upper Case letters ("B43), so I put the letter "B" in lower case and saved, the drivers load every time I boot.

The above solved my broadcom wireless issues. PLEASE EDIT THE SUBJECT LINE OF YOUR INITIAL POST AND ADD "(SOLVED) TO THE SUBJECT LINE IF THIS RESOLVES YOUR ISSUE.
mister_lister
Level 1
Level 1
 
Posts: 43
Joined: Thu Dec 18, 2008 6:40 pm

Re: Wireless Internet will not work

Postby AlbertP on Fri Nov 23, 2012 6:55 am

@ stetucke: It looks like there's still something left behind from the STA driver. Please try running "sudo modprobe b43". If that fixes your wifi, you can run:
Code: Select all
sudo rm /etc/modprobe.d/blacklist-bcm43.conf
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6513
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: Bing [Bot], trapper36 and 9 guests