Wireless Broadcom Driver Won't Stay Activated

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Wireless Broadcom Driver Won't Stay Activated

Postby wjs777 on Wed Nov 21, 2012 9:15 pm

Hello,
I just started with Linux 2 days ago, so I am very new to this OS and need all the help I can get. I was able to download Linux Mint 13 Cinnamon (32 bit version) and installed it to a HP/Compaq C717NR laptop, using an external Seagate 750GB USB Drive formatted with FAT32 (installed it on the first partition which is 100GB) . I used the Universal-USB-Installer ver. 1.9.1.6 to install the boot loader and the Linux Mint 13 Cinnamon onto the Seagate drive. It installed OK and seems to boot just fine. The problem I'm having, as it seems others have had, is the wireless function not working correctly. The laptop has the Broadcom BCM4311 controller. The first thing I did was to install the Broadcom STA Wireless Driver I found on the Linux Mint 13 under System Settings / Additional Drivers. It seemed to download and install OK using a wired internet connection but it never would turn the laptops wireless light on and the system said "Firmware Missing." I then found on a Unbuntu forum a command line to run for the Broadcom controller problem. This is the command they gave which I ran from the terminal: sudo apt-get install b43-fwcutter && sudo apt-get install firmware-b43-installer It ran OK and actually the light on the laptop came on but still could not set up a wireless connection. I then re-installed the Broadcom STA Wireless Driver on the Linux Mint 13 under System Settings / Additional Drivers. This time with the light on and the reinstall of the Broadcom STA Driver the system saw the wireless network and I could actually log into the network using the WEP/WPA password wirelessly. It worked great. It worked fine until I Rebooted. After each reboot now the wireless light won't come on and I can't see the network unless I re-run the Broadcom STA Wireless Driver under the Linux Mint 13 System Settings/ Additional Drivers and re-activate it. Then it will work till the next reboot. It acts as if the driver is not being written to the USB drive. What am I doing wrong? I'm sure it is something probably simple.

Any help would be greatly appreciated!
wjs777
Level 1
Level 1
 
Posts: 1
Joined: Wed Nov 21, 2012 4:37 pm

Linux Mint is funded by ads and donations.
 

Return to Newbie Questions

Who is online

Users browsing this forum: No registered users and 23 guests