Unable to automount the ntfs partitions; ntfs-3g err[SOLVED]

Forum rules
Before you post please read this

Unable to automount the ntfs partitions; ntfs-3g err[SOLVED]

Postby deepla on Wed Nov 21, 2012 8:58 am

Hi i am trying to automount two of my ntfs partitions (sda5 and sda6) on my laptop (it has only one hard drive).I edited /etc/fstab file as suggested in ubuntu sites and it looks like this now

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda2 during installation
UUID=541dd69d-b17f-492a-a7d9-76288420572c / ext4 errors=remount-ro 0 1
# swap was on /dev/sda3 during installation
UUID=69826754-dc75-4de3-b48d-33bb5125c447 none swap sw 0 0
UUID="5E677FCD2164E8C3" ntfs-3g /home/mount/D uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0
UUID="169A708B75D3D9CD" ntfs-3g /home/mount/E uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0


blkid command gives the following result


/dev/sda1: UUID="DABE11ABBE118165" TYPE="ntfs"
/dev/sda2: UUID="541dd69d-b17f-492a-a7d9-76288420572c" TYPE="ext4"
/dev/sda3: UUID="69826754-dc75-4de3-b48d-33bb5125c447" TYPE="swap"
/dev/sda5: LABEL="D" UUID="5E677FCD2164E8C3" TYPE="ntfs"
/dev/sda6: LABEL="E" UUID="169A708B75D3D9CD" TYPE="ntfs"


However when i boot i get the message "an error has occured to ntfs-3g. press S for skip mounting and M for manual recovery " When i enter S it boots but without mounting the partitions. What do i do ?
I have included quotes in UUID in fstab entry. Is it necessary. I tried booting without this. But then the drives are not only mounted but are not detected also in the left pane of nautilus. Synaptic shows that ntfs-3g is installed.

I tried pysdm. It was automounting but it was not allowing read or right the partitions. Also once I unmount any of these partitions it wouldn't let me mount it.
Last edited by deepla on Thu Nov 22, 2012 11:54 am, edited 1 time in total.
deepla
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 21, 2012 8:35 am

Linux Mint is funded by ads and donations.
 

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby nomko on Wed Nov 21, 2012 10:03 am

Check here: http://askubuntu.com/questions/120233/c ... oot-access

And there's a tool available which can help you mount partitions: http://community.linuxmint.com/software/view/pysdm
ASUS P5KPL-AM SE*Intel Core2 Quad CPU Q8200*4 GiB ram*nVidia GeForce 9500GT*Realtek RTL8101/8102E*Optiarc DVD-RW AD-7200A*HDD:Samsung HD501LJ/HD103SI*Sitecom X5-N600 Router (WLR-5100)*Mint 16

Copy.com

I don't need Google, my wife knows everything!
User avatar
nomko
Level 7
Level 7
 
Posts: 1935
Joined: Sat Feb 25, 2012 7:28 pm
Location: The Hague, The Netherlands

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby deepla on Wed Nov 21, 2012 10:19 am

I have already tried pysdm. I got exactly the same error as mentioned in the link you suggested.
[quote="nomko"]Check here: http://askubuntu.com/questions/120233/c ... oot-access

However no solution for this is mentioned in the above link.
deepla
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 21, 2012 8:35 am

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby altair4 on Wed Nov 21, 2012 10:57 am

I have included quotes in UUID in fstab entry. Is it necessary.

It should work with quotes around the uuid number but it usually is written without them. For consistency sake remove them.
I tried booting without this. But then the drives are not only mounted but are not detected also in the left pane of nautilus.

No partition auto mounting in fstab will display in the left side of Nautilus unless you create a bookmark to it.
Also once I unmount any of these partitions it wouldn't let me mount it.

You have to ask yourself why you are trying to mount these partitions via fstab. If you want the ability as a regular user to mount and unmount them then don't put anything in fstab. Your partitions will show up on the left side panel and when cliked will mount - click again and they will unmount. Put them is fstab and control has been given back to root. Only root can mount and only root can unmount.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5523
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby deepla on Thu Nov 22, 2012 2:16 am

Thanks altair4,
I am trying to set up linux for my prof who is rather intimidated by linux and knows only Windows. I have installed Windows in virtualbox with the vdi in one of the ntfs partitions. He should be able to start the virtual windows machine from a shortcut on the desktop. Having to mount the partion may scare him off. So if i am able to configure so that the ntfs partition can be mounted at boot up and can be used as a regular user it would be enough. What is the best way to do that ? pysdm automounts but only as read-only. Eventhough i tried several times to unclick the option "mount as read-only" it was not getting saved, as described in the thread

http://askubuntu.com/questions/120233/c ... oot-access

thank you
deepla
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 21, 2012 8:35 am

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby altair4 on Thu Nov 22, 2012 8:41 am

Go back to basics:

[1] Stop using PySDM.
I would go so far as to suggest you remove the package complely but that's up to you. Just don't use it again.

[2] Change the lines in fstab for your NTFS partitions from this:
UUID="5E677FCD2164E8C3" ntfs-3g /home/mount/D uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0
UUID="169A708B75D3D9CD" ntfs-3g /home/mount/E uid=1000,gid=1000,umask=0022,sync,auto,nosuid,rw,nouser 0 0

To this:
UUID=5E677FCD2164E8C3 /home/mount/D ntfs defaults,uid=1000,gid=1000,umask=0000,windows_names 0 0
UUID=169A708B75D3D9CD /home/mount/E ntfs defaults,uid=1000,gid=1000,umask=0000,windows_names 0 0

[3] If any of these partitions are currently mounted unmount them.

[4] Then run the following command to mount them back with the correct fstab entries:
Code: Select all
sudo mount -a

If for some reason you cannot unmount them just reboot the box.

The problem with your original fstab entries is that the filysystem ( ntfs-3g ) and the mount point were reversed. The second position should be a mount point and in your entries it's ntfs-3g. There is no such mount point so it failed. Had I noticed that when I first read your post we could have saved some time - Sorry about that. As long as you are redoing the fstab lines anyway you might as well set it to the current standard which is something PySDM cannot do.


Note: Specifying "ntfs" invokes "ntfs-3g" automatically so either one will work.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5523
Joined: Tue Feb 03, 2009 10:27 am

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby deepla on Thu Nov 22, 2012 11:37 am

Thank you altair4,
That did seem to work ! Also I had made a dumb mistake. The mount point created was in /home/username/mount/D. The folder username is described as' Home' when you open it in nautilus and I confused it with home. Good that you suggested sudo mount -a. It gave the error ' no such file or directory'. I corrected it and it is mounting now. I had removed pysdm.

However when I try to open the virtual machine it does not boot !

Failed to start the virtual machine Win7.
Could not open the medium '/media/D/windows 7 iso/Win7.vdi'.
VD: error VERR_FILE_NOT_FOUND opening image file '/media/D/windows 7 iso/Win7.vdi' (VERR_FILE_NOT_FOUND).

On booting, I am seeing the D and E drive icons on the desktop and on the left pane of nautilus it shows that both the drives are mounted (by the small up arrow next to the drive name). When I click to unmount it it shows "unable to unmount" error (as you had explained). So the drives must be mounted. Also when I hover over the drive letters on the nautilus , it shows the mount folder name correctly .
The virtual machine starts only if i click and open the drive once ! It is as if it is not mounted. When I open the drives I see that theyare in read and write mode.

What could be the problem ? Could it be that the virtual machine is unable to see the mount point (/home/username/mount/D which i created )?
Prior to editing fstab the drives used to be mounted (when clicked open ) in /media/D and /media/E. Is the virtual machine still looking there ? But how then is it able to see it correctly once i click open the drive ?

Thanks for the suggestions
Last edited by deepla on Thu Nov 22, 2012 11:50 am, edited 1 time in total.
deepla
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 21, 2012 8:35 am

Re: Unable to automount the ntfs partitions; ntfs-3g error

Postby deepla on Thu Nov 22, 2012 11:49 am

Hi ,
I changed the mount point to /media/D as virtual box liked it Now everything is working well . Thank you once again for helping me.
deepla
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 21, 2012 8:35 am

Linux Mint is funded by ads and donations.
 

Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 1 guest