Please Help - Xservernot found, unable to resolve host

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read this

Please Help - Xservernot found, unable to resolve host

Postby chibi03 on Tue Nov 20, 2012 4:41 pm

Hi everyone,

I'm pretty much a noob with linux and at the end of my knowledge. I probably did the stupidest thing ever. :cry: Today I just wanted to uninstall my lyx editor and accidentially
uninstalled a bunch of important packages :( As a result Mint now gives me a Xserver not found error and can't connect to the internet.

The error message:
X-server not found: /usr/bin/X: 0 -audit 0 -auth
/var/lib/mdm/> 0.Xauth -nolisten tcp vt
... please install Xserver ...


I can't install xserver with apt-get because of the lack of internet connection and the command xorg -configure is not found.
I believe the best way to start would be to get my internet working first but I don't know how. In the command line I always get
the error
sudo: unable to resolve host


and can't download any packages... After some research I found the suggestion of changing the line "managed=false" to true in NetworkManager.conf
but that didn't help. And restarting the Network-manager service didn't change anything either.

I'd be really thankful for any kind of suggestion. I really don't know what to do anymore.

Kind regards.

PS: I'm using Linux Mint 13 on a MSI GE60 installed as dual boot with windows.
chibi03
Level 1
Level 1
 
Posts: 2
Joined: Tue Nov 20, 2012 4:27 pm

Linux Mint is funded by ads and donations.
 

Re: Please Help - Xservernot found, unable to resolve host

Postby coltstrgj on Tue Nov 20, 2012 5:58 pm

I may be wrong, but I always thought that x server was the gui host process. I thought that it handled the graphics card, and the display on the monitor. If I am correct, then the two problems are unrelated. Also If I am correct, are you trying to use wifi or ethernet. I doubt that this is the problem though, otherwise you would have noticed the lack of gui probably.
coltstrgj
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 19, 2012 12:43 am

Re: Please Help - Xservernot found, unable to resolve host

Postby chibi03 on Tue Nov 20, 2012 6:04 pm

Yes they are two different problems, but the began at the same time. I have neither a gui nor internet, and I really don't know how to fix this...

thanks for your reply.
chibi03
Level 1
Level 1
 
Posts: 2
Joined: Tue Nov 20, 2012 4:27 pm

Re: Please Help - Xservernot found, unable to resolve host

Postby coltstrgj on Thu Nov 22, 2012 3:55 pm

I am very sorry about the delay in response. please use
Code: Select all
lsmod
and look for your internet adapter. Also are you trying to use wifi or ethernet. Please post the result for the internet adapter that you are using, and if you can not find it post the whole list here.
I doubt that you will be able to find it if the internet is not working. In fact, i hope that you dont if its wifi, if you do, it is a problem that I will likely not be able to help.
coltstrgj
Level 1
Level 1
 
Posts: 9
Joined: Mon Nov 19, 2012 12:43 am


Return to Newbie Questions

Who is online

Users browsing this forum: Bing [Bot] and 35 guests