Linux Mint Nadia shutdown problem solution:

Write tutorials and howtos in here
There are more tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please. Before you post please read this

Linux Mint Nadia shutdown problem solution:

Postby Zorba on Fri Nov 23, 2012 2:30 pm

If you face a shudown problem in linux mint nadia, which is caused by the switch to plymouth here is the solution:

1- Solution 1: run in terminal:
sudo shutdown -P now

if this doen't fix the problem then try:

2- Solution 2:

Step 1: Go to terminal and type


sudo gedit /etc/default/grub


It will open the grub file. Change the line
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off
and close it after saving.


Step 2: Again hit the terminal and type


sudo gedit /etc/modules


It will open the modules - just type apm power_off=1 below lp and save the file.


Step 3: Next type in the terminal
sudo update-grub

Now the grub will be updated and you won't face any issue with shutdown.

In addition, you may need to modify ACPI configuration to enable smooth shutdown. To do so, type the following in the terminal.


sudo modprobe -rf rt2860sta
sudo modprobe rt2860sta
echo blacklist rt2800pci | sudo tee -a /etc/modprobe.d/blacklist.conf


Once you restart your computer, your shutdown would be proper and things won't hang at shutdown.

3- Solution 3:

You can get a patch for mountall from a ppa that will allow you to remove plymouth but this is not going to help this problem which is caused by libplymouth2.

You need libplymouth2. You need to file a bug on this or find one that you can join;
Code:

ubuntu-bug libplymouth2
Image Image
User avatar
Zorba
Level 8
Level 8
 
Posts: 2012
Joined: Tue May 29, 2012 10:12 pm
Location: Tunisia

Linux Mint is funded by ads and donations.
 

Return to Tutorials / Howtos

Who is online

Users browsing this forum: mst3kharris and 8 guests