Cannot set custom keyboard shortcuts in Cinnamon Settings

Please post suggestions for improvement of Cinnamon here
https://github.com/linuxmint/Cinnamon

Cannot set custom keyboard shortcuts in Cinnamon Settings

Postby Bordee on Sat Nov 24, 2012 2:59 pm

Hi everyone,

I was wondering if anyone has figured out how to get custom keyboard shortcuts (e.g., setting Firefox to launch with alt + f) to work through Cinnamon Settings > Keyboard > Keyboard shortcuts > Custom shortcuts. I have tried a variety of different key combinations and applications to launch in the custom shortcuts, and I haven't managed to get any to work.

In earlier versions of Gnome 3 (before 3.5 or 3.6), I was able to set custom keyboard shortcuts using alt + (a letter), and it would work without any problems. Since about Gnome 3.5 or so, I noticed that custom shortcuts seem to have gotten messed up. At the time that Gnome updated to 3.5 or so, I was using Arch Linux, and I recalled that all of a sudden my custom keyboard shortcuts no longer worked. I installed Linux Mint 14 over my old Arch install, so I'm not entirely sure whether the custom shortcuts have been resolved in the latest versions of Gnome Shell in Arch.

I did some research and it seems that there might be an upstream problem with Gnome Shell custom keyboard shortcuts (gnome-settings-daemon problems) or with Ubuntu Unity and legacy gconf configurations.
See
http://askubuntu.com/questions/122748/e ... on-gnome-3
https://bbs.archlinux.org/viewtopic.php?id=150587&p=1 (suggests that maybe this issue has been resolved in recent updates in Arch?)
http://ubuntuforums.org/showthread.php?p=11834672


In addition, my research suggests that there might be a way to set the custom shortcuts manually with dconf of even gconf or gsettings

I installed dconf-editor and went into org.gnome.desktop.wm.keybindings. I noticed that all of those keybindings worked. Next, I went into org.gnome.settings-daemon.plugins.media-keys. There, I could manually change commands such terminal from the default ctrl + alt + t to something else like alt + t, and it initially worked.

Of potential importance, I noticed that under gnome.settings-daemon.plugins.media-keys there is a "Custom keybindings" listed. However, it appears that custom keybindings is empty per its description and [] without any additional commands or text.

Based on what I had read from earlier research, I wondered if I could set the custom shortcuts in gconf. To that end, I installed gconf-editor. I navigated from Desktop > gnome > keybindings >custom, and I found that the firefox custom shortcut that I attempted to set through the Cinnamon settings was listed as:

(custom 3)
action firefox
binding <Alt>f
name firefox

However, even though this custom shortcut was listed, it would not work. After installing gconf-editor and restarting, all of my keyboard shortcuts from org.gnome.settings-daemon.plugins.media-keys (in dconf) were no longer working. In that manner, I could not open a terminal with alt + t or ctrl + alt + t. This setback makes me wonder if installing gconf and poking around gconf-editor somehow borked dconf and gnome-settings-daemon.

Also, another thing that I'm wondering is whether the non-custom keyboard shortcuts in Keyboard under Cinnamon Settings are controlled/being written into dconf, whereas the custom keyboard settings are getting controlled/getting written into gconf?

So, has anyone figured out a workaround to get custom keyboard shortcuts working?

Thanks for any potential help or suggestions.
Bordee
Level 1
Level 1
 
Posts: 29
Joined: Sat Sep 11, 2010 3:07 pm

Linux Mint is funded by ads and donations.
 

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby Bordee on Sun Nov 25, 2012 12:39 pm

To add some more information to this problem, I booted a live CD of Cinnarch (Arch LInux based distro), and I was able to set custom keyboard shortcuts without any issues.

This further suggests that the keyboard shortcut issues are related to Ubuntu 12.10 Gnome configuration issues/bugs.
Bordee
Level 1
Level 1
 
Posts: 29
Joined: Sat Sep 11, 2010 3:07 pm

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby Chonnawonga on Sun Nov 25, 2012 12:52 pm

This is definitely a bug. See the report here: https://bugs.launchpad.net/linuxmint/+bug/1077930
Chonnawonga
Level 1
Level 1
 
Posts: 1
Joined: Wed Nov 30, 2011 11:28 am

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby Bordee on Sun Nov 25, 2012 5:47 pm

Looking a little bit further with Cinnarch, I think the bug -- as you properly describe it and point out -- has to do with dconf. In Cinnarch's dconf, org.gnome.settings-daemon.plugins.media-keys has entries for custom-keybindings instead of being [] like in Mint 14.

So in a nutshell, I think that somehow the custom-keybindings need to get into/read by dconf for the custom shortcuts to work.
Bordee
Level 1
Level 1
 
Posts: 29
Joined: Sat Sep 11, 2010 3:07 pm

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby ScottyD on Mon Nov 26, 2012 4:37 pm

Is there a work around for this? I just installed Mint 14 and can't add the few custom key bindings I need. :?
ScottyD
Level 1
Level 1
 
Posts: 40
Joined: Thu Oct 20, 2011 5:16 pm

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby electrickite on Tue Dec 04, 2012 12:37 am

electrickite
Level 1
Level 1
 
Posts: 4
Joined: Wed Nov 28, 2012 1:57 pm

Re: Cannot set custom keyboard shortcuts in Cinnamon Setting

Postby ScottyD on Tue Dec 04, 2012 10:44 am

electrickite wrote:I posted a potential workaround for this here:
http://forums.linuxmint.com/viewtopic.php?f=208&t=117585&start=20#p655476


electrickite, Excellent workaround!!!

mucho thanks... :D

Scott
ScottyD
Level 1
Level 1
 
Posts: 40
Joined: Thu Oct 20, 2011 5:16 pm

Linux Mint is funded by ads and donations.
 

Return to Cinnamon

Who is online

Users browsing this forum: LesStrater and 6 guests