[SOLVED] LMDE no speaker sound - headphones OK

Questions about codecs, DVD playback, web plugins...
Forum rules
Before you post please read this

[SOLVED] LMDE no speaker sound - headphones OK

Postby bonesTdog on Sat Nov 24, 2012 4:46 pm

Hi all,
I have have been wrestling with the sound on my HP DV7 notebook and tried every trick I could find on google to fix my "no sound on speakers" issue. Headphones work fine. I am not sure if I am just missing something (very possible) or if I have found a bug that should be reported.

I have a multi-booted HP DV7 with both LMDE and LMDE-KDE running on separate partitions. I installed the KDE version to see if a fresh install would help cure the problem. I know the hardware works fine as my other distros work fine.

Here is what I have tried:
-Checking every option, multimedia settings, alsa mixer,etc to ensure there is no mute checked and all volumes are up. Hopefully I didn't miss anything. Headphones working tell me I think I got them all.
-Editing /etc/modprobe.d/alsa-base.conf and added 'options snd-hda-intel model=generic' to the end. Oddly enough, commenting out 'options snd-usb-audio index=-2' got headphones working.
-Removing .pulse and forcing the system to re-create
-Removing pulse altogether and installing ALSA

Nothing seems to have cured the problem. I LOVE this distro and want to commit to it full time, but no sound is a deal killer so I am committed to figuring out how to fix it.

Here is my lshw in case that helps

*-multimedia
description: Audio device
product: RV710/730 HDMI Audio [Radeon HD 4000 series]
vendor: Advanced Micro Devices [AMD] nee ATI
physical id: 0.1
bus info: pci@0000:01:00.1
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:50 memory:da010000-da013fff

Can any of you offer any help or suggestions?
Last edited by bonesTdog on Sat Dec 22, 2012 10:57 pm, edited 1 time in total.
User avatar
bonesTdog
Level 1
Level 1
 
Posts: 29
Joined: Mon Jan 03, 2011 10:34 pm

Linux Mint is funded by ads and donations.
 

Re: LMDE no speaker sound - headphones OK

Postby Mik3e on Sat Nov 24, 2012 7:19 pm

I manage sound with gnome-alsamixer. If I accidentally mute the 'main' or 'headphone' control the sound goes away until I increase the volumn via the panel icon at the lower right. No other control works, not the added upper panel applet, not gnome-alsamixer. So, keep looking, somewhere there's a trigger.
Mik3e
Level 2
Level 2
 
Posts: 99
Joined: Sat Jan 01, 2011 2:54 pm

Re: LMDE no speaker sound - headphones OK

Postby bonesTdog on Sat Nov 24, 2012 7:56 pm

Thanks, but gnome-alsa mixer is not installed. I am assuming that is because this is the KDE version of LMDE.
User avatar
bonesTdog
Level 1
Level 1
 
Posts: 29
Joined: Mon Jan 03, 2011 10:34 pm

Re: LMDE no speaker sound - headphones OK

Postby shemmie on Sun Nov 25, 2012 12:07 am

Same problem for me.

*-multimedia
description: Audio device
product: Redwood HDMI Audio [Radeon HD 5000 Series]
vendor: Advanced Micro Devices [AMD] nee ATI
physical id: 0.1
bus info: pci@0000:02:00.1
version: 00
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:46 memory:cfedc000-cfedffff

Now I'm guessing we don't want sound through this - and this would be via the HDMI port and thus we shouldn't expect speaker sound?

I set my default hardware to Built-In Audio Analog Speakers, and tested - but still no sound.

I suspect this default sound is:

*-multimedia
description: Audio device
product: 5 Series/3400 Series Chipset High Definition Audio
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:45 memory:f0a00000-f0a03fff

I'm using LMDE KDE. Any thoughts appreciated.
shemmie
Level 1
Level 1
 
Posts: 1
Joined: Sat Nov 24, 2012 11:55 pm

Re: LMDE no speaker sound - headphones OK

Postby bonesTdog on Tue Nov 27, 2012 8:40 pm

What is your computer hardware?
User avatar
bonesTdog
Level 1
Level 1
 
Posts: 29
Joined: Mon Jan 03, 2011 10:34 pm

Re: LMDE no speaker sound - headphones OK

Postby starccraft on Fri Nov 30, 2012 8:51 am

PackardBell Easynote 2x Intel(R) Core(TM)2 Duo CPU T5450 @ 1.66GHz LMDE XFCE
starccraft
Level 1
Level 1
 
Posts: 8
Joined: Tue Apr 17, 2012 9:18 am

Re: LMDE no speaker sound - headphones OK

Postby cmpellison on Fri Dec 14, 2012 11:01 pm

Have you considered if it's a power saving issue?

I had exactly the same issue with two brand new installations of Mint 14 64bit (Cinnamon). At what seemed like random times the internal speakers on my Dell XPS-15 would cease functioning. I eventually figured out that the headphones were still working, so this was a really frustrating problem to figure out. I read through all the different posts about ALSA & PulseAudio and all the bizarreness with Linux sound. The system has an Intel integrated audio chipset.

But then I noticed that on restart the sound would work, but at some point would stop. So I'd just restart - I know, not an effective solution.

What it came down to was the power-save settings for the audio. If my system went into power-save (off AC power and over to battery) the speakers would cut out. This would happen after 10 minutes. And no matter what I did I couldn't get the speakers to come back on. (Yeah, I wanted to pull my hair out reading post after post of people saying "the pulseaudio setting was muted" or "did you check to see if 'sound' was turned off?" Not helpful.

I eventually adjusted the script for pm-utils that would turn ON powersaving on the audio card -> /usr/lib/pm-utils/power.d/intel-audio-powersave

At the end of the script I changed

Code: Select all
case $1 in
    true) audio_powersave 1 ;;
    false) audio_powersave 0 ;;
    help) help;;
    *) exit $NA
esac

exit 0


to

Code: Select all
case $1 in
    true) audio_powersave 0 ;;
    false) audio_powersave 0 ;;
    help) help;;
    *) exit $NA
esac

exit 0


The system won't go into powersave for the audio card now, and has been clear of the problem since.
cmpellison
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 14, 2012 10:46 pm

Re: LMDE no speaker sound - headphones OK

Postby bonesTdog on Sun Dec 16, 2012 9:59 pm

Well rats. Some good pointers but still no dice. Looking in alsamixer, I can't help believe I still have a setting wrong. Can anyone speak to the menu options I find in alsamixer > F2 (System Info) > /proc/asound/devices. I see a collection of devices with codes listed below.

Can anyone provide any insight?

1: : sequencer
2: [ 0- 1]: digital audio playback
3: [ 0- 0]: digital audio playback
4: [ 0- 0]: digital audio capture
5: [ 0- 1]: hardware dependent
6. [ 0- 0]: hardware dependent
7: [ 0] : control
8: [ 1- 3]: digital audio playback
9: [ 1- 0]: hardware dependent
10: [ 1] : control
33: : timer
User avatar
bonesTdog
Level 1
Level 1
 
Posts: 29
Joined: Mon Jan 03, 2011 10:34 pm

Re: LMDE no speaker sound - headphones OK

Postby bonesTdog on Sat Dec 22, 2012 10:57 pm

Oddly enough, the newest update pack along with updating the kernel to 3.2.0-4 magically did the trick. Thanks for all of your help!
User avatar
bonesTdog
Level 1
Level 1
 
Posts: 29
Joined: Mon Jan 03, 2011 10:34 pm

Re: LMDE no speaker sound - headphones OK

Postby losst on Thu Jan 17, 2013 9:44 am

cmpellison wrote:Have you considered if it's a power saving issue?

I had exactly the same issue with two brand new installations of Mint 14 64bit (Cinnamon). At what seemed like random times the internal speakers on my Dell XPS-15 would cease functioning. I eventually figured out that the headphones were still working, so this was a really frustrating problem to figure out. I read through all the different posts about ALSA & PulseAudio and all the bizarreness with Linux sound. The system has an Intel integrated audio chipset.

But then I noticed that on restart the sound would work, but at some point would stop. So I'd just restart - I know, not an effective solution.

What it came down to was the power-save settings for the audio. If my system went into power-save (off AC power and over to battery) the speakers would cut out. This would happen after 10 minutes. And no matter what I did I couldn't get the speakers to come back on. (Yeah, I wanted to pull my hair out reading post after post of people saying "the pulseaudio setting was muted" or "did you check to see if 'sound' was turned off?" Not helpful.

I eventually adjusted the script for pm-utils that would turn ON powersaving on the audio card -> /usr/lib/pm-utils/power.d/intel-audio-powersave

At the end of the script I changed

Code: Select all
case $1 in
    true) audio_powersave 1 ;;
    false) audio_powersave 0 ;;
    help) help;;
    *) exit $NA
esac

exit 0


to

Code: Select all
case $1 in
    true) audio_powersave 0 ;;
    false) audio_powersave 0 ;;
    help) help;;
    *) exit $NA
esac

exit 0


The system won't go into powersave for the audio card now, and has been clear of the problem since.


This appears to have fixed the problem for me- LMDE 1204 64bit Alienware M17x R3 -at least for now. Thanks
losst
Level 1
Level 1
 
Posts: 8
Joined: Sat Jan 12, 2013 8:23 pm

Re: [SOLVED] LMDE no speaker sound - headphones OK

Postby eduartua on Sat Feb 23, 2013 8:31 pm

This works right for me on my Dell XPS L502X hardware:
System: Host: eduartua-XPS-L502X Kernel: 3.5.0-17-generic x86_64 (64 bit) Desktop: N/A Distro: Linux Mint 14 Nadia
Machine: System: Dell product: Dell System XPS L502X
Mobo: Dell model: 0YR8NN version: A00 Bios: Dell version: A09 date: 01/13/2012
CPU: Quad core Intel Core i7-2670QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz 3: 800.00 MHz 4: 800.00 MHz 5: 800.00 MHz 6: 800.00 MHz 7: 800.00 MHz 8: 800.00 MHz
Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Card-2: NVIDIA GF108 [GeForce GT 540M]
X.Org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1366x768@60.1hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 9.0
Audio: Card: Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: 1.0.25
Network: Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: down mac: 84:8f:69:c9:f7:f3
Card-2: Intel Centrino Wireless-N 1030 driver: iwlwifi
IF: wlan0 state: up mac: 4c:eb:42:5a:51:59
Drives: HDD Total Size: 750.2GB (3.5% used) 1: id: /dev/sda model: ST9750420AS size: 750.2GB
Partition: ID: / size: 38G used: 6.3G (18%) fs: ext4 ID: /home size: 235G used: 19G (9%) fs: ext4
ID: swap-1 size: 3.08GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 64.0C mobo: 64.0C gpu: 55.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 191 Uptime: 12 min Memory: 793.6/7880.7MB Client: Shell inxi: 1.8.4
eduartua
Level 1
Level 1
 
Posts: 1
Joined: Sat Feb 23, 2013 8:28 pm

Re: [SOLVED] LMDE no speaker sound - headphones OK

Postby cmpellison on Thu Mar 21, 2013 12:44 pm

The frustrating thing about this was that after a number of weeks I started having the problem AGAIN... except this time it was related to the machine going to sleep and waking again. If I left the laptop open and running I'd never have the speakers turn off, but as soon as I closed the lid and slept it it would happen. It seemed to solve itself when I updated the kernel from the stock 3.5* that shipped with LM14 to 3.6.9
cmpellison
Level 1
Level 1
 
Posts: 2
Joined: Fri Dec 14, 2012 10:46 pm

Linux Mint is funded by ads and donations.
 

Return to Sound, Multimedia & Codecs

Who is online

Users browsing this forum: No registered users and 1 guest