<SOLVED> mintconstructor breaks resolv.conf symlink

Questions about applications and software
Forum rules
Before you post please read how to get help

<SOLVED> mintconstructor breaks resolv.conf symlink

Postby freemantsinq on Sun Nov 25, 2012 10:01 am

<SOLVED>

OS: Linuxmint 14 Cinnamon 64 bit.
Mintconstructor version: 3.1.2
Objective: remaster original livecd of LM14 Cinn 64bit using mintconstructor (without upgrading to keep size down, install Opera, remove Firefox and Thunderbird, customize desktop settings, remaster)
Tutorial(s) Referenced: http://community.linuxmint.com/tutorial/view/918 (and another in a pdf I can't find at the moment)
Symptoms: mintconstructor breaks resolv.conf symlink.
SOLUTION: mintconstructor deletes WORKDIR/root/etc/resolv.conf upon closing the chroot terminal. backup WORKDIR/root/etc/resolv.conf prior to closing the chroot terminal and deposit it again afterwards.

The following is a reference for anyone that discovers their remasters are missing the resolv.conf symlink and how to fix it.

# install mintconstructor
# HOST TERMINAL: sudo /usr/lib/linuxmint/mintConstructor/mintConstructor.py
# under "Directory" choose location for project files
# select "New Project"
# click "Browse" button and location .iso file of livecd to customize
# click "Next" then "Yes" to confirm
# rename (as root) "...WORKDIR/root/usr/share/applications/ubiquity-gtkui.desktop" to "Install Mint.desktop" (NOTE: this step is for those that would like the "install mint" link on the desktop to go away. it's still in the menu if you need it)

### (as root) backup WORKDIR/root/etc/resolv.conf symlink file at this point from your working directory!

# click "Open a chroot terminal"
# CHROOT TERMINAL: aptitude update
# CHROOT TERMINAL: reboot (NOTE: this will restart the computer, the pdf tutorial said this was required to prevent the build from failing. THIS STEP IS NOT NECESSARY from my experience. works just fine without a reboot)
# open up the chroot terminal again (NOTE: if you rebooted unnecessarily)
# CHROOT TERMINAL: aptitude install opera
# CHROOT TERMINAL: aptitude remove thunderbird firefox
# CHROOT TERMINAL: aptitude install -f (NOTE: to correct dependencies, if any.)
# CHROOT TERMINAL: aptitude purge ~c
# CHROOT TERMINAL: aptitude unmarkauto ~M
# CHROOT TERMINAL: aptitude clean
# CHROOT TERMINAL: rm -rf /var/cache/apt/*.bin && rm -rf /var/cache/debconf/*.dat-old && rm -rf /var/lib/aptitude/*.old && rm -rf /var/lib/dpkg/*-old
# CHROOT TERMINAL: updatedb
# CHROOT TERMINAL: history -c
# CHROOT TERMINAL: rm /root/.bash_history
# CHROOT TERMINAL: rm /root/.nano_history
# CHROOT TERMINAL: history -c
# close chroot terminal

### replace your copy of resolv.conf that you previously backed up to WORKDIR/root/etc/ at this point.

# click "Next"
# give a name to the .iso file and fill out the description field if desirable
# click "Next"
# click "Yes"
# wait until iso is built
# boot iso and customize settings as desired
# log out of live session and log back in (username: mint, password: none)
# copy configuration folders (examples: .config and .gconf) to "...WORKDIR/root/etc/skel/"
# rebuild iso
# you're done.



EDIT: I created another project from a vanilla copy of Linuxmint 14 Cinnamon 64bit. Recorded the file size and number of files before and after opening chroot while performing no other actions to see if mintconstructor deleted any other files. Here's the results:

BEFORE OPENING CHROOT TERMINAL
153,424 items, totalling 3.8 GB
(some contents unreadable)

AFTER CLOSING CHROOT TERMINAL
153,423 items, totalling 3.8 GB
(some contents unreadable)

It appears that only one file is deleted.
freemantsinq
Level 1
Level 1
 
Posts: 2
Joined: Sun Nov 25, 2012 9:12 am

Linux Mint is funded by ads and donations.
 

Return to Software & Applications

Who is online

Users browsing this forum: No registered users and 20 guests